aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2012-05-15 06:16:32 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2012-05-15 06:16:32 +0800
commit50f96c510f9b05d385ec7a11c5bbbf4e0dc5932c (patch)
tree18ba640d4c6e2677f3ba9f9f01d8d4cd4f255ae4
parent15cdcc6c741fdaee13b00388ee253175d5d08fc6 (diff)
downloadfreebsd-ports-gnome-50f96c510f9b05d385ec7a11c5bbbf4e0dc5932c.tar.gz
freebsd-ports-gnome-50f96c510f9b05d385ec7a11c5bbbf4e0dc5932c.tar.zst
freebsd-ports-gnome-50f96c510f9b05d385ec7a11c5bbbf4e0dc5932c.zip
Add py-MySQLdb51, a slave port of py-MySQLdb with MySQL 5.1.
PR: ports/152066 Submitted by: Tom Judge <tom@tomjudge.com>
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-MySQLdb51/Makefile18
2 files changed, 19 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9d1d4bedc5d6..2b4937624a6c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -644,6 +644,7 @@
SUBDIR += py-MySQLdb
SUBDIR += py-MySQLdb41
SUBDIR += py-MySQLdb50
+ SUBDIR += py-MySQLdb51
SUBDIR += py-PyGreSQL
SUBDIR += py-bsddb
SUBDIR += py-bsddb3
diff --git a/databases/py-MySQLdb51/Makefile b/databases/py-MySQLdb51/Makefile
new file mode 100644
index 000000000000..50aba85e3317
--- /dev/null
+++ b/databases/py-MySQLdb51/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: py-MySQLdb51
+# Date created: 2010-11-8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= 51
+
+COMMENT= Access a MySQL database through Python (Using MySQL 5.1 Client)
+
+CONFLICTS= py*-MySQLdb-devel-[0-9]* py*-MySQLdb-[0-9]* py*-MySQLdb[45][0-9]-[0-9]*
+
+WANT_MYSQL_VER= 51
+
+MASTERDIR= ${.CURDIR}/../py-MySQLdb
+
+.include "${MASTERDIR}/Makefile"