aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-05-13 09:08:41 +0800
committerwen <wen@FreeBSD.org>2011-05-13 09:08:41 +0800
commit517aba0311e569253dacdc0cf99c23f42e6e686b (patch)
tree13a093fd235bc0b1266cc4bdc6731a3f2d1b88d0
parent0cd8c17dec826e0c577ff94d9e50bdf0adbb91ae (diff)
downloadfreebsd-ports-gnome-517aba0311e569253dacdc0cf99c23f42e6e686b.tar.gz
freebsd-ports-gnome-517aba0311e569253dacdc0cf99c23f42e6e686b.tar.zst
freebsd-ports-gnome-517aba0311e569253dacdc0cf99c23f42e6e686b.zip
Stjerm is a quake-like terminal emulator. It's window is shown with a key
shortcut. Stjerm is very minimalistic and works well with Compiz window manager. WWW: https://code.google.com/p/stjerm-terminal/ PR: ports/155939 Submitted by: Zhihao Yuan <lichray@gmail.com>
-rw-r--r--x11/Makefile1
-rw-r--r--x11/stjerm/Makefile28
-rw-r--r--x11/stjerm/distinfo2
-rw-r--r--x11/stjerm/files/patch-src_config.c11
-rw-r--r--x11/stjerm/pkg-descr5
5 files changed, 47 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 3a229e3f897e..b9cd9997f524 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -263,6 +263,7 @@
SUBDIR += stalonetray
SUBDIR += startup-notification
SUBDIR += sterm
+ SUBDIR += stjerm
SUBDIR += swarp
SUBDIR += sxpc
SUBDIR += tabbed
diff --git a/x11/stjerm/Makefile b/x11/stjerm/Makefile
new file mode 100644
index 000000000000..2c744c125a72
--- /dev/null
+++ b/x11/stjerm/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: stjerm
+# Date created: 2011-03-25
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stjerm
+PORTVERSION= 0.14
+CATEGORIES= x11
+MASTER_SITES= http://stjerm-terminal.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A GTK+-based quake-like terminal emulator
+
+USE_AUTOTOOLS= aclocal autoheader automake
+AUTOMAKE_ARGS= --add-missing
+ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} \
+ -I${LOCALBASE}/share/aclocal
+USE_GNOME= vte gtk20
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN8= stjerm.8
+LICENSE_FILE= ${WRKSRC}/COPYING
+PLIST_FILES= bin/stjerm
+
+.include <bsd.port.mk>
diff --git a/x11/stjerm/distinfo b/x11/stjerm/distinfo
new file mode 100644
index 000000000000..216a6e556b71
--- /dev/null
+++ b/x11/stjerm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stjerm-0.14.tar.gz) = 1c2f121c0f81a6ca70c9baf9d9f2e65637015f927709d6290d896b13370b3249
+SIZE (stjerm-0.14.tar.gz) = 28545
diff --git a/x11/stjerm/files/patch-src_config.c b/x11/stjerm/files/patch-src_config.c
new file mode 100644
index 000000000000..26e46f4f14b8
--- /dev/null
+++ b/x11/stjerm/files/patch-src_config.c
@@ -0,0 +1,11 @@
+--- src/config.c.orig 2011-03-25 16:35:40.389707429 -0500
++++ src/config.c 2011-03-25 16:41:20.529584111 -0500
+@@ -546,7 +546,7 @@ void conf_init(void)
+ exit(1);
+ }
+
+- signal(SIGUSR1, (__sighandler_t) mainwindow_toggle);
++ signal(SIGUSR1, (sig_t) mainwindow_toggle);
+
+ conf_find_position();
+ }
diff --git a/x11/stjerm/pkg-descr b/x11/stjerm/pkg-descr
new file mode 100644
index 000000000000..013e5ee9fbb6
--- /dev/null
+++ b/x11/stjerm/pkg-descr
@@ -0,0 +1,5 @@
+Stjerm is a quake-like terminal emulator. It's window is shown with a key
+shortcut. Stjerm is very minimalistic and works well with Compiz window
+manager.
+
+WWW: https://code.google.com/p/stjerm-terminal/