aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-12-26 18:00:10 +0800
committerrakuco <rakuco@FreeBSD.org>2016-12-26 18:00:10 +0800
commit517c684d2256062ce18a6b158e7fd7b4bd26edd1 (patch)
tree642e9e3e4a87be7d287849f02782b67167cacd58
parent53a756f04f5be0f57555ce29c8b9d6a81ec6e982 (diff)
downloadfreebsd-ports-gnome-517c684d2256062ce18a6b158e7fd7b4bd26edd1.tar.gz
freebsd-ports-gnome-517c684d2256062ce18a6b158e7fd7b4bd26edd1.tar.zst
freebsd-ports-gnome-517c684d2256062ce18a6b158e7fd7b4bd26edd1.zip
Drop post-configure target from several Qt5 ports.
Qt's configure script already creates all the necessary Makefiles for the directories we need to build, so there is no need to run qmake again in post-configure. Reviewed by: tcberner, Adriaan de Groot <groot@kde.org> Differential Revision: https://reviews.freebsd.org/D8899
-rw-r--r--devel/dbus-qt5/Makefile6
-rw-r--r--devel/qt5-buildtools/Makefile6
-rw-r--r--net/qt5-network/Makefile4
-rw-r--r--print/qt5-printsupport/Makefile6
4 files changed, 0 insertions, 22 deletions
diff --git a/devel/dbus-qt5/Makefile b/devel/dbus-qt5/Makefile
index be289520ce81..9bc93a64078f 100644
--- a/devel/dbus-qt5/Makefile
+++ b/devel/dbus-qt5/Makefile
@@ -24,12 +24,6 @@ TOOLS= qdbuscpp2xml qdbusxml2cpp
QT_DEFINES= DBUS
QT_CONFIG= dbus
-post-configure:
-.for t in ${TOOLS}
- @cd ${WRKSRC}/src/tools/${t} && \
- ${SETENV} ${QMAKE_ENV} ${WRKSRC}/bin/qmake ${QMAKE_ARGS}
-.endfor
-
post-build:
.for t in ${TOOLS}
@cd ${WRKSRC}/src/tools/${t} && \
diff --git a/devel/qt5-buildtools/Makefile b/devel/qt5-buildtools/Makefile
index 3eca86a53a6f..41582e2c51f6 100644
--- a/devel/qt5-buildtools/Makefile
+++ b/devel/qt5-buildtools/Makefile
@@ -21,12 +21,6 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
MORE_WRKSRCS= src/tools/moc \
src/tools/rcc
-post-configure:
-.for d in ${MORE_WRKSRCS}
- @cd ${WRKSRC}/${d} && \
- ${SETENV} ${QMAKE_ENV} ${WRKSRC}/bin/qmake ${QMAKE_ARGS}
-.endfor
-
post-build:
.for d in ${MORE_WRKSRCS}
@cd ${WRKSRC}/${d} && \
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index 75b52457af18..04794ffc20bc 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -29,10 +29,6 @@ post-patch:
${BUILD_WRKSRC}/ssl/qsslsocket_openssl.cpp \
${BUILD_WRKSRC}/ssl/qsslsocket_openssl_symbols.cpp
-post-configure:
- @cd ${WRKSRC}/src/plugins/bearer/generic && \
- ${SETENV} ${QMAKE_ENV} ${WRKSRC}/bin/qmake ${QMAKE_ARGS}
-
post-build:
@cd ${WRKSRC}/src/plugins/bearer/generic && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
index b3d4420e0820..27afe0bb59d2 100644
--- a/print/qt5-printsupport/Makefile
+++ b/print/qt5-printsupport/Makefile
@@ -34,12 +34,6 @@ QT_DEFINES+= -CUPS
QT_CONFIG+= -cups
.endif
-post-configure:
-.if ${PORT_OPTIONS:MCUPS}
- @cd ${WRKSRC}/src/plugins/${PORTNAME}/cups && \
- ${SETENV} ${QMAKE_ENV} ${WRKSRC}/bin/qmake ${QMAKE_ARGS}
-.endif
-
post-build:
.if ${PORT_OPTIONS:MCUPS}
@cd ${WRKSRC}/src/plugins/${PORTNAME}/cups && \