aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2014-09-09 18:03:57 +0800
committerhrs <hrs@FreeBSD.org>2014-09-09 18:03:57 +0800
commit51b73d2885780697ca35449f2e4d66b1c6d02c5e (patch)
tree365722dbd9986c2964ecee2946fff954c2fb8261
parent38214125330f6a54add4435d4c5597c285e94ea6 (diff)
downloadfreebsd-ports-gnome-51b73d2885780697ca35449f2e4d66b1c6d02c5e.tar.gz
freebsd-ports-gnome-51b73d2885780697ca35449f2e4d66b1c6d02c5e.tar.zst
freebsd-ports-gnome-51b73d2885780697ca35449f2e4d66b1c6d02c5e.zip
Add a patch forgotten in the previous commit.
PR: 193444
-rw-r--r--print/tex-dvipdfmx/Makefile5
-rw-r--r--print/tex-dvipdfmx/files/patch-texk-dvipdfmx-Makefile.in38
2 files changed, 39 insertions, 4 deletions
diff --git a/print/tex-dvipdfmx/Makefile b/print/tex-dvipdfmx/Makefile
index e83880562616..ca306d18c9e2 100644
--- a/print/tex-dvipdfmx/Makefile
+++ b/print/tex-dvipdfmx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dvipdfmx
PORTVERSION= 20140317
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2014/
PKGNAMEPREFIX= tex-
@@ -73,8 +74,4 @@ post-install:
${LN} -f -s ${LOCALBASE}/share/fonts/adobe-cmaps \
${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/cmap/adobe-cmaps
-Xpost-install:
- ${RM} -f ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/glyphlist/glyphlist.txt \
- ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/glyphlist/pdfglyphlist.txt
-
.include <bsd.port.mk>
diff --git a/print/tex-dvipdfmx/files/patch-texk-dvipdfmx-Makefile.in b/print/tex-dvipdfmx/files/patch-texk-dvipdfmx-Makefile.in
new file mode 100644
index 000000000000..cea5d9c30025
--- /dev/null
+++ b/print/tex-dvipdfmx/files/patch-texk-dvipdfmx-Makefile.in
@@ -0,0 +1,38 @@
+--- Makefile.in.orig 2014-08-22 16:41:51.000000000 +0900
++++ Makefile.in 2014-08-22 16:42:55.000000000 +0900
+@@ -165,7 +165,7 @@
+ @XDVIPDFMX_TRUE@am__EXEEXT_2 = xdvipdfmx$(EXEEXT)
+ am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" \
+ "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(cmapdatadir)" \
+- "$(DESTDIR)$(configdatadir)" "$(DESTDIR)$(glyphlistdatadir)" \
++ "$(DESTDIR)$(configdatadir)" \
+ "$(DESTDIR)$(mapdatadir)"
+ PROGRAMS = $(bin_PROGRAMS) $(noinst_PROGRAMS)
+ nodist_call_dvipdfmx_OBJECTS = call_dvipdfmx-callexe.$(OBJEXT)
+@@ -286,7 +286,7 @@
+ NROFF = nroff
+ MANS = $(dist_man1_MANS)
+ DATA = $(dist_cmapdata_DATA) $(dist_configdata_DATA) \
+- $(dist_glyphlistdata_DATA) $(dist_mapdata_DATA)
++ $(dist_mapdata_DATA)
+ am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) \
+ $(LISP)config.h.in
+ # Read a list of newline-separated strings from the standard input,
+@@ -2076,7 +2076,7 @@
+ all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) config.h \
+ all-local
+ installdirs:
+- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(cmapdatadir)" "$(DESTDIR)$(configdatadir)" "$(DESTDIR)$(glyphlistdatadir)" "$(DESTDIR)$(mapdatadir)"; do \
++ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(cmapdatadir)" "$(DESTDIR)$(configdatadir)" "$(DESTDIR)$(mapdatadir)"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: install-am
+@@ -2138,7 +2138,7 @@
+ info-am:
+
+ install-data-am: install-dist_cmapdataDATA install-dist_configdataDATA \
+- install-dist_glyphlistdataDATA install-dist_mapdataDATA \
++ install-dist_mapdataDATA \
+ install-man
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) install-data-hook