aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-20 11:22:08 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-20 11:22:08 +0800
commit52535d143b58acfe068e9800e8c96b104c3830c6 (patch)
treeabb109254aeb29d2c49bf6b7dc5b68682a9bc9ae
parente0d13f7eabb169d1b6b49c433f24c1ea253c6a3a (diff)
downloadfreebsd-ports-gnome-52535d143b58acfe068e9800e8c96b104c3830c6.tar.gz
freebsd-ports-gnome-52535d143b58acfe068e9800e8c96b104c3830c6.tar.zst
freebsd-ports-gnome-52535d143b58acfe068e9800e8c96b104c3830c6.zip
- Update USE_PYTHON
- Fix OPTIONSFILE - Support STAGEDIR - Reformat pkg-descr - Use single space after WWW:
-rw-r--r--www/py-qpy/Makefile8
-rw-r--r--www/py-qpy/pkg-descr11
-rw-r--r--www/py-qpy/pkg-plist2
3 files changed, 10 insertions, 11 deletions
diff --git a/www/py-qpy/Makefile b/www/py-qpy/Makefile
index a637956038be..2d41d64fc46c 100644
--- a/www/py-qpy/Makefile
+++ b/www/py-qpy/Makefile
@@ -12,18 +12,18 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Generating safely-quoted html text from python code
OPTIONS_DEFINE= DOCS
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
MAKE_ENV= USE_DISTUTILS=yes
-USE_PYTHON= 2.5+
USE_PYDISTUTILS=yes
+USE_PYTHON= -2.7
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES.txt LICENSE.txt README.txt ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES.txt LICENSE.txt README.txt ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/www/py-qpy/pkg-descr b/www/py-qpy/pkg-descr
index 306456c2e2d4..c5c3de916434 100644
--- a/www/py-qpy/pkg-descr
+++ b/www/py-qpy/pkg-descr
@@ -1,8 +1,7 @@
-Qpy provides a convenient mechanism for generating safely-quoted html
-text from python code.
+Qpy provides a convenient mechanism for generating safely-quoted html text from
+python code.
-It does this by implementing a quoted-string data type and a
-modification of the python compiler. (This main idea comes from
-Quixote's htmltext/PTL.)
+It does this by implementing a quoted-string data type and a modification of the
+python compiler. (This main idea comes from Quixote's htmltext/PTL.)
-WWW: http://www.mems-exchange.org/software/qpy/
+WWW: http://www.mems-exchange.org/software/qpy/
diff --git a/www/py-qpy/pkg-plist b/www/py-qpy/pkg-plist
index 24a8b3d7cb6f..a215491c25f3 100644
--- a/www/py-qpy/pkg-plist
+++ b/www/py-qpy/pkg-plist
@@ -28,8 +28,8 @@ bin/qpyrun.py
%%PYTHON_SITELIBDIR%%/qpy/translate.py
%%PYTHON_SITELIBDIR%%/qpy/translate.pyc
%%PYTHON_SITELIBDIR%%/qpy/translate.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/qpy
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/qpy