aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-11-14 02:23:34 +0800
committerclement <clement@FreeBSD.org>2004-11-14 02:23:34 +0800
commit55da8ee9103cfa30c548e98a8c146127bc50bb4e (patch)
tree0396e79cda958a853d4f5d292b845d0ad5dbeb64
parent8d58f3cef6ec84e5d1da1d569457a53a0032de5e (diff)
downloadfreebsd-ports-gnome-55da8ee9103cfa30c548e98a8c146127bc50bb4e.tar.gz
freebsd-ports-gnome-55da8ee9103cfa30c548e98a8c146127bc50bb4e.tar.zst
freebsd-ports-gnome-55da8ee9103cfa30c548e98a8c146127bc50bb4e.zip
- minor cleanups.
-rw-r--r--www/apache2/Makefile8
-rw-r--r--www/apache2/Makefile.modules11
-rw-r--r--www/apache2/Makefile.modules.3rd5
-rw-r--r--www/apache2/files/apache.sh2
-rw-r--r--www/apache2/pkg-message20
-rw-r--r--www/apache20/Makefile8
-rw-r--r--www/apache20/Makefile.modules11
-rw-r--r--www/apache20/Makefile.modules.3rd5
-rw-r--r--www/apache20/files/apache.sh2
-rw-r--r--www/apache20/pkg-message20
10 files changed, 26 insertions, 66 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 6524b7561da5..9e4b8b1b76f5 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -146,7 +146,7 @@ show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
show-categories:
-.for category in ${ALL_MODULES_CATEGORIES:S/SLAVE_PORT//}
+.for category in ${ALL_MODULES_CATEGORIES}
@${ECHO_MSG} "${category} contains these modules:"
@${ECHO_MSG} " ${${category}_MODULES}"
.endfor
@@ -172,9 +172,9 @@ pre-everything::
@${ECHO_MSG} " To disable a module category: WITHOUT_<CATEGORY>_MODULES"
@${ECHO_MSG} ""
@${ECHO_MSG} " Per default categories are:"
- @${ECHO_MSG} " ${DEFAULT_MODULES_CATEGORIES:C/SLAVE_PORT//}"
+ @${ECHO_MSG} " ${DEFAULT_MODULES_CATEGORIES}"
@${ECHO_MSG} " Categories available:"
- @${ECHO_MSG} " ${ALL_MODULES_CATEGORIES:C/SLAVE_PORT//}"
+ @${ECHO_MSG} " ${ALL_MODULES_CATEGORIES}"
@${ECHO_MSG} ""
@${ECHO_MSG} " To see all available knobs, type make show-options"
@${ECHO_MSG} " To see all modules in different categories, type make show-categories"
@@ -193,10 +193,8 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
-.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
-.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
diff --git a/www/apache2/Makefile.modules b/www/apache2/Makefile.modules
index 1cc5791ceead..c0bff5aba490 100644
--- a/www/apache2/Makefile.modules
+++ b/www/apache2/Makefile.modules
@@ -12,10 +12,6 @@
# $FreeBSD$
#
-.if defined(SLAVE_DESIGNED_FOR) && ${PORTVERSION} != ${SLAVE_DESIGNED_FOR}
-IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
-.endif
-
# MPM section:
# << TO BE WRITTEN >>
.if defined (SLAVE_PORT_MPM)
@@ -127,11 +123,8 @@ SSL_MODULES= ssl
SUEXEC_MODULES= suexec
THREADS_MODULES= cgid
-# Work in progress
-SLAVE_PORT_MODULES?= # If you are porting a slave port for apache2 please define SLAVE_PORT_MODULES
-
DEFAULT_MODULES_CATEGORIES= \
- AUTH DAV MISC SLAVE_PORT
+ AUTH DAV MISC
ALL_MODULES_CATEGORIES= AUTH DAV EXPERIMENTAL LDAP MISC PROXY SSL \
- SUEXEC THREADS SLAVE_PORT
+ SUEXEC THREADS
diff --git a/www/apache2/Makefile.modules.3rd b/www/apache2/Makefile.modules.3rd
index e4eed7202856..46f26cc49de5 100644
--- a/www/apache2/Makefile.modules.3rd
+++ b/www/apache2/Makefile.modules.3rd
@@ -121,6 +121,11 @@ do-install:
IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
.endif
+.if defined(SLAVE_PORT_MODULES)
+DEFAULT_MODULES_CATEGORIES+= SLAVE_PORT
+ALL_MODULES_CATEGORIES+= SLAVE_PORT
+.endif
+
# Module selection
.for category in ${DEFAULT_MODULES_CATEGORIES}
DEFAULT_MODULES+= ${${category}_MODULES}
diff --git a/www/apache2/files/apache.sh b/www/apache2/files/apache.sh
index ff570a83a9c7..fc71c2890619 100644
--- a/www/apache2/files/apache.sh
+++ b/www/apache2/files/apache.sh
@@ -19,7 +19,7 @@
# Set it to yes to run `limits $limits_args`
# just before apache starts.
# apache2_flags (str): Set to "" by default.
-# Extra flags passed to start command
+# Extra flags passed to start command.
# apache2limits_args (str): Default to "-e -C daemon"
# Arguments of pre-start limits run.
#
diff --git a/www/apache2/pkg-message b/www/apache2/pkg-message
index 510dd32f581d..301283fc1a86 100644
--- a/www/apache2/pkg-message
+++ b/www/apache2/pkg-message
@@ -1,18 +1,2 @@
- ***********************************
- * !!!!!!!!!!! WARNING !!!!!!!!!!! *
- ***********************************
-Since 2.0.49_2, to run apache www server from startup, add apache2_enable="YES"
-in your /etc/rc.conf.
-Available variables you add/set to /etc/rc.conf.
-- apache2_enable (bool): Set to "NO" by default.
- Set it to "YES" to enable apache2.
-- apache2ssl_enable (bool): Set to "NO" by default.
- Set it to "YES" to start apache with SSL
- (if <IfDefined SSL> exists in httpd.conf).
-- apache2limits_enable (bool):Set to "NO" by default.
- Set it to yes to run `limits $limits_args`
- just before apache starts.
-- apache2_flags (str): Set to "" by default.
- Extra flags passed to start command.
-- apache2limits_args (str): Default to "-e -C daemon"
- Arguments of pre-start limits run.
+To run apache www server from startup, add apache2_enable="YES"
+in your /etc/rc.conf. Extra options can be found in startup script.
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 6524b7561da5..9e4b8b1b76f5 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -146,7 +146,7 @@ show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
show-categories:
-.for category in ${ALL_MODULES_CATEGORIES:S/SLAVE_PORT//}
+.for category in ${ALL_MODULES_CATEGORIES}
@${ECHO_MSG} "${category} contains these modules:"
@${ECHO_MSG} " ${${category}_MODULES}"
.endfor
@@ -172,9 +172,9 @@ pre-everything::
@${ECHO_MSG} " To disable a module category: WITHOUT_<CATEGORY>_MODULES"
@${ECHO_MSG} ""
@${ECHO_MSG} " Per default categories are:"
- @${ECHO_MSG} " ${DEFAULT_MODULES_CATEGORIES:C/SLAVE_PORT//}"
+ @${ECHO_MSG} " ${DEFAULT_MODULES_CATEGORIES}"
@${ECHO_MSG} " Categories available:"
- @${ECHO_MSG} " ${ALL_MODULES_CATEGORIES:C/SLAVE_PORT//}"
+ @${ECHO_MSG} " ${ALL_MODULES_CATEGORIES}"
@${ECHO_MSG} ""
@${ECHO_MSG} " To see all available knobs, type make show-options"
@${ECHO_MSG} " To see all modules in different categories, type make show-categories"
@@ -193,10 +193,8 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
-.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
-.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
diff --git a/www/apache20/Makefile.modules b/www/apache20/Makefile.modules
index 1cc5791ceead..c0bff5aba490 100644
--- a/www/apache20/Makefile.modules
+++ b/www/apache20/Makefile.modules
@@ -12,10 +12,6 @@
# $FreeBSD$
#
-.if defined(SLAVE_DESIGNED_FOR) && ${PORTVERSION} != ${SLAVE_DESIGNED_FOR}
-IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
-.endif
-
# MPM section:
# << TO BE WRITTEN >>
.if defined (SLAVE_PORT_MPM)
@@ -127,11 +123,8 @@ SSL_MODULES= ssl
SUEXEC_MODULES= suexec
THREADS_MODULES= cgid
-# Work in progress
-SLAVE_PORT_MODULES?= # If you are porting a slave port for apache2 please define SLAVE_PORT_MODULES
-
DEFAULT_MODULES_CATEGORIES= \
- AUTH DAV MISC SLAVE_PORT
+ AUTH DAV MISC
ALL_MODULES_CATEGORIES= AUTH DAV EXPERIMENTAL LDAP MISC PROXY SSL \
- SUEXEC THREADS SLAVE_PORT
+ SUEXEC THREADS
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index e4eed7202856..46f26cc49de5 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -121,6 +121,11 @@ do-install:
IGNORE= "Sorry, ${SLAVENAME} and ${PORTNAME} versions are out of sync"
.endif
+.if defined(SLAVE_PORT_MODULES)
+DEFAULT_MODULES_CATEGORIES+= SLAVE_PORT
+ALL_MODULES_CATEGORIES+= SLAVE_PORT
+.endif
+
# Module selection
.for category in ${DEFAULT_MODULES_CATEGORIES}
DEFAULT_MODULES+= ${${category}_MODULES}
diff --git a/www/apache20/files/apache.sh b/www/apache20/files/apache.sh
index ff570a83a9c7..fc71c2890619 100644
--- a/www/apache20/files/apache.sh
+++ b/www/apache20/files/apache.sh
@@ -19,7 +19,7 @@
# Set it to yes to run `limits $limits_args`
# just before apache starts.
# apache2_flags (str): Set to "" by default.
-# Extra flags passed to start command
+# Extra flags passed to start command.
# apache2limits_args (str): Default to "-e -C daemon"
# Arguments of pre-start limits run.
#
diff --git a/www/apache20/pkg-message b/www/apache20/pkg-message
index 510dd32f581d..301283fc1a86 100644
--- a/www/apache20/pkg-message
+++ b/www/apache20/pkg-message
@@ -1,18 +1,2 @@
- ***********************************
- * !!!!!!!!!!! WARNING !!!!!!!!!!! *
- ***********************************
-Since 2.0.49_2, to run apache www server from startup, add apache2_enable="YES"
-in your /etc/rc.conf.
-Available variables you add/set to /etc/rc.conf.
-- apache2_enable (bool): Set to "NO" by default.
- Set it to "YES" to enable apache2.
-- apache2ssl_enable (bool): Set to "NO" by default.
- Set it to "YES" to start apache with SSL
- (if <IfDefined SSL> exists in httpd.conf).
-- apache2limits_enable (bool):Set to "NO" by default.
- Set it to yes to run `limits $limits_args`
- just before apache starts.
-- apache2_flags (str): Set to "" by default.
- Extra flags passed to start command.
-- apache2limits_args (str): Default to "-e -C daemon"
- Arguments of pre-start limits run.
+To run apache www server from startup, add apache2_enable="YES"
+in your /etc/rc.conf. Extra options can be found in startup script.