aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordmgk <dmgk@FreeBSD.org>2019-12-28 20:23:15 +0800
committerdmgk <dmgk@FreeBSD.org>2019-12-28 20:23:15 +0800
commit560a793e925aeab4e023e843933c55cf959030a6 (patch)
tree6b25fee08a4e018dc977989fcde89f60da92fc22
parent810491d9c353cf59c3899839414196f4e3e7b696 (diff)
downloadfreebsd-ports-gnome-560a793e925aeab4e023e843933c55cf959030a6.tar.gz
freebsd-ports-gnome-560a793e925aeab4e023e843933c55cf959030a6.tar.zst
freebsd-ports-gnome-560a793e925aeab4e023e843933c55cf959030a6.zip
New port: security/age
age is a simple, modern and secure encryption tool with small explicit keys, no config options, and UNIX-style composability. WWW: https://github.com/FiloSottile/age
-rw-r--r--security/Makefile1
-rw-r--r--security/age/Makefile28
-rw-r--r--security/age/distinfo7
-rw-r--r--security/age/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7058f64c990f..5509d62f1ed3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -20,6 +20,7 @@
SUBDIR += afl
SUBDIR += afl++
SUBDIR += afterglow
+ SUBDIR += age
SUBDIR += aide
SUBDIR += akmos
SUBDIR += amap
diff --git a/security/age/Makefile b/security/age/Makefile
new file mode 100644
index 000000000000..c68f041427d6
--- /dev/null
+++ b/security/age/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= age
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+DISTVERSIONSUFFIX= -beta2
+CATEGORIES= security
+
+MAINTAINER= dmgk@FreeBSD.org
+COMMENT= Simple, modern and secure file encryption tool
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= FiloSottile
+GH_TUPLE= \
+ Filosottile:go:9090b284250b:filosottile_go/vendor/golang.org/x/crypto \
+ golang:sys:97732733099d:golang_sys/vendor/golang.org/x/sys
+
+GO_TARGET= ./cmd/age \
+ ./cmd/age-keygen
+
+PLIST_FILES= ${GO_TARGET:C/.\/cmd/bin/}
+
+.include <bsd.port.mk>
diff --git a/security/age/distinfo b/security/age/distinfo
new file mode 100644
index 000000000000..9e0d316e41a6
--- /dev/null
+++ b/security/age/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1577534378
+SHA256 (FiloSottile-age-v1.0.0-beta2_GH0.tar.gz) = ca0fcfe45415c03c637c2332231f1793bf4dbd6a03e663a71ef2b7554647d763
+SIZE (FiloSottile-age-v1.0.0-beta2_GH0.tar.gz) = 19958
+SHA256 (Filosottile-go-9090b284250b_GH0.tar.gz) = a2f640d4e1f822e95427550c700b85344b0076f15bff567ecf4c3ea14b089eee
+SIZE (Filosottile-go-9090b284250b_GH0.tar.gz) = 1714485
+SHA256 (golang-sys-97732733099d_GH0.tar.gz) = 8d60fa6ab0c2b099f2c7d6f8c0a5df177c5c524183a2a38e0e8d2d18cde53532
+SIZE (golang-sys-97732733099d_GH0.tar.gz) = 1350239
diff --git a/security/age/pkg-descr b/security/age/pkg-descr
new file mode 100644
index 000000000000..e5c8b271d15a
--- /dev/null
+++ b/security/age/pkg-descr
@@ -0,0 +1,4 @@
+age is a simple, modern and secure encryption tool with small explicit keys, no
+config options, and UNIX-style composability.
+
+WWW: https://github.com/FiloSottile/age