aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwollman <wollman@FreeBSD.org>2004-01-10 08:08:13 +0800
committerwollman <wollman@FreeBSD.org>2004-01-10 08:08:13 +0800
commit5621c90969abbec1331fe2c7df035553123e4173 (patch)
tree2fd2e743c3e134346588a54e0e0f4a3018c79ebb
parent48cdc49eb2012bffeca5002afd35e7e7fda9c93e (diff)
downloadfreebsd-ports-gnome-5621c90969abbec1331fe2c7df035553123e4173.tar.gz
freebsd-ports-gnome-5621c90969abbec1331fe2c7df035553123e4173.tar.zst
freebsd-ports-gnome-5621c90969abbec1331fe2c7df035553123e4173.zip
Utility for displaying the physical configuration of a network device
supporting the Entity MIB.
-rw-r--r--net/Makefile1
-rw-r--r--net/entitymib/Makefile31
-rw-r--r--net/entitymib/distinfo2
-rw-r--r--net/entitymib/pkg-descr9
-rw-r--r--net/entitymib/pkg-message9
-rw-r--r--net/entitymib/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f49853972bb8..3c25bb2eb879 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -126,6 +126,7 @@
SUBDIR += edonkey-gui-gtk-urlslave
SUBDIR += edonkey-gui-java
SUBDIR += ehnt
+ SUBDIR += entitymib
SUBDIR += erlang_xmlrpc
SUBDIR += etherape
SUBDIR += etherboot
diff --git a/net/entitymib/Makefile b/net/entitymib/Makefile
new file mode 100644
index 000000000000..93fbfc1ba4ae
--- /dev/null
+++ b/net/entitymib/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: entitymib
+# Date created: 9 January 2004
+# Whom: Garrett Wollman <wollman@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= entitymib
+PORTVERSION= 20040109
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= wollman
+DISTFILES= entitymib entitymib.1
+EXTRACT_ONLY=
+
+MAINTAINER= wollman@FreeBSD.org
+COMMENT=Display the Entity MIB of an SNMP agent
+
+RUN_DEPENDS= ${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node \
+ ${SITE_PERL}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net/net-snmp
+
+USE_PERL= yes
+MAN1= entitymib.1
+
+NO_BUILD= nope
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/entitymib ${PREFIX}/bin/entitymib
+ ${INSTALL_MAN} ${DISTDIR}/entitymib.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/entitymib/distinfo b/net/entitymib/distinfo
new file mode 100644
index 000000000000..59dfe8bd8f2d
--- /dev/null
+++ b/net/entitymib/distinfo
@@ -0,0 +1,2 @@
+MD5 (entitymib) = 97b9aeb0dee69afddf5daaf7060b7578
+MD5 (entitymib.1) = d53780d3d220405f5437e1115ff1fec1
diff --git a/net/entitymib/pkg-descr b/net/entitymib/pkg-descr
new file mode 100644
index 000000000000..2169cdd503c9
--- /dev/null
+++ b/net/entitymib/pkg-descr
@@ -0,0 +1,9 @@
+entitymib is a utility for displaying the physical configuration of an
+SNMPv2c or v3 agent using the SNMP Entity MIB, and, for certain Cisco
+Systems switches, displaying additional sensor and configuration
+information from proprietary MIBs (which must be obtained separately).
+
+entitymib is written entirely in Perl, but it uses the NetSNMP library
+through its Perl binding, SNMP(3), and requires that NetSNMP's MIB
+directories be correctly configured to provide, at a minimum, the
+Entity MIB.
diff --git a/net/entitymib/pkg-message b/net/entitymib/pkg-message
new file mode 100644
index 000000000000..15b47a3226e4
--- /dev/null
+++ b/net/entitymib/pkg-message
@@ -0,0 +1,9 @@
+In order to use the full functionality of entitymib for Cisco
+switches, you must obtain and install the following Cisco proprietary
+MIB modules:
+
+ CISCO-ENTITY-SENSOR-MIB
+ CISCO-ASSET-ENTITY-MIB
+ CISCO-ENTITY-EXT-MIB
+
+Not all MIBs are supported by all Cisco switches.
diff --git a/net/entitymib/pkg-plist b/net/entitymib/pkg-plist
new file mode 100644
index 000000000000..03ef1e6aac8e
--- /dev/null
+++ b/net/entitymib/pkg-plist
@@ -0,0 +1 @@
+bin/entitymib