aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-19 14:02:57 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-19 14:02:57 +0800
commit5680a67d7886ea5f5a33e0ad5266826017df7ffd (patch)
treeec2b420abb96881e46d53f32092524cda0046075
parent2c6294d89d054533e69611dc012b4fd859557e1c (diff)
downloadfreebsd-ports-gnome-5680a67d7886ea5f5a33e0ad5266826017df7ffd.tar.gz
freebsd-ports-gnome-5680a67d7886ea5f5a33e0ad5266826017df7ffd.tar.zst
freebsd-ports-gnome-5680a67d7886ea5f5a33e0ad5266826017df7ffd.zip
Add OPTIONS
PR: ports/97382 Submitted by: Dryice Liu <dryice@dryice.name> (maintainer) Approved by: tmclaugh (mentor)
-rw-r--r--www/roundup/Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 523ac396a003..2d966c553354 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -19,7 +19,30 @@ USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
USE_GETTEXT= yes
+OPTIONS= SQLITE "Support Sqlite as backend" on
+OPTIONS+= METAKIT "Support metakit as backend" off
+OPTIONS+= PGSQL "Support posggresql as backend" off
+OPTIONS+= MYSQL "Support mysql as backend" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SQLITE)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/sqlite/__init__.py:${PORTSDIR}/databases/py-PySQLite11
+.endif
+
+.if defined(WITH_METAKIT)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/metakit.py:${PORTSDIR}/databases/metakit
+.endif
+
+.if defined(WITH_PGSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
+.endif
+
+.if defined(WITH_MYSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+.endif
+
MAN1= roundup-admin.1 roundup-demo.1 roundup-mailgw.1 \
roundup-server.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>