aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-03-31 21:16:05 +0800
committerJason W. Bacon <jwb@FreeBSD.org>2018-03-31 21:16:05 +0800
commit56d5a1146ff6fd435092314bc591fe070997ea79 (patch)
tree603154866b5c6162281c68380cfbfe60e15868c0
parent1050f7a8e925734ef9aedece3735422a82ac5609 (diff)
downloadfreebsd-ports-gnome-56d5a1146ff6fd435092314bc591fe070997ea79.tar.gz
freebsd-ports-gnome-56d5a1146ff6fd435092314bc591fe070997ea79.tar.zst
freebsd-ports-gnome-56d5a1146ff6fd435092314bc591fe070997ea79.zip
biology/stacks: Software pipeline for building loci from short-read sequences
Reviewed by: mat Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D14885
-rw-r--r--biology/Makefile1
-rw-r--r--biology/stacks/Makefile20
-rw-r--r--biology/stacks/distinfo3
-rw-r--r--biology/stacks/files/patch-htslib_Makefile20
-rw-r--r--biology/stacks/pkg-descr6
-rw-r--r--biology/stacks/pkg-message16
-rw-r--r--biology/stacks/pkg-plist70
7 files changed, 136 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 53733c94937b..0189fabea514 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -109,6 +109,7 @@
SUBDIR += sim4
SUBDIR += slclust
SUBDIR += ssaha
+ SUBDIR += stacks
SUBDIR += tRNAscan-SE
SUBDIR += t_coffee
SUBDIR += tinker
diff --git a/biology/stacks/Makefile b/biology/stacks/Makefile
new file mode 100644
index 000000000000..a7582268a71d
--- /dev/null
+++ b/biology/stacks/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= stacks
+DISTVERSION= 1.48
+CATEGORIES= biology
+MASTER_SITES= http://catchenlab.life.illinois.edu/stacks/source/
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Software pipeline for building loci from short-read sequences
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake python shebangfix
+SHEBANG_FILES= scripts/*.pl scripts/*.py
+GNU_CONFIGURE= yes
+
+LDFLAGS+= -lpthread
+
+.include <bsd.port.mk>
diff --git a/biology/stacks/distinfo b/biology/stacks/distinfo
new file mode 100644
index 000000000000..e32def18090a
--- /dev/null
+++ b/biology/stacks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520376299
+SHA256 (stacks-1.48.tar.gz) = e9f6251f5f609f9dd0bb1de17a51f69ce1a9af531548c4d2456a89783b1dcd1e
+SIZE (stacks-1.48.tar.gz) = 895195
diff --git a/biology/stacks/files/patch-htslib_Makefile b/biology/stacks/files/patch-htslib_Makefile
new file mode 100644
index 000000000000..7a1235d9f2a2
--- /dev/null
+++ b/biology/stacks/files/patch-htslib_Makefile
@@ -0,0 +1,20 @@
+--- htslib/Makefile.orig 2016-09-16 15:40:03 UTC
++++ htslib/Makefile
+@@ -22,13 +22,13 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
+-AR = ar
+-RANLIB = ranlib
++CC ?= gcc
++AR ?= ar
++RANLIB ?= ranlib
+
+ CPPFLAGS =
+ # TODO: probably update cram code to make it compile cleanly with -Wc++-compat
+-CFLAGS = -g -Wall -O2
++CFLAGS ?= -g -Wall -O2
+ EXTRA_CFLAGS_PIC = -fpic
+ LDFLAGS =
+ LIBS =
diff --git a/biology/stacks/pkg-descr b/biology/stacks/pkg-descr
new file mode 100644
index 000000000000..f7c91c33e98f
--- /dev/null
+++ b/biology/stacks/pkg-descr
@@ -0,0 +1,6 @@
+Stacks is a software pipeline for building loci from short-read sequences, such
+as those generated on the Illumina platform. Stacks was developed to work with
+restriction enzyme-based data, such as RAD-seq, for the purpose of building
+genetic maps and conducting population genomics and phylogeography.
+
+WWW: http://catchenlab.life.illinois.edu/stacks/
diff --git a/biology/stacks/pkg-message b/biology/stacks/pkg-message
new file mode 100644
index 000000000000..6f077b3c391c
--- /dev/null
+++ b/biology/stacks/pkg-message
@@ -0,0 +1,16 @@
+===
+
+If you would like to use the stacks web interface, follow the instructions at:
+
+ http://catchenlab.life.illinois.edu/stacks/manual-v1/#install
+
+You will need to install databases/p5-DBD-mysql to allow the optional
+wrapper scripts to interact with the database server.
+
+To set up the web server, you will need an apache server such as www/apache24,
+MySQL server and client packages such as databases/mysql56-client and
+databases/mysql56-server, and PHP interface modules such as
+databases/php56-mysql (php56 will be automatically installed as a dependency),
+and lastly textproc/p5-Spreadsheet-WriteExcel.
+
+===
diff --git a/biology/stacks/pkg-plist b/biology/stacks/pkg-plist
new file mode 100644
index 000000000000..4f85229d528c
--- /dev/null
+++ b/biology/stacks/pkg-plist
@@ -0,0 +1,70 @@
+bin/clone_filter
+bin/count_fixed_catalog_snps.py
+bin/cstacks
+bin/denovo_map.pl
+bin/exec_velvet.pl
+bin/export_sql.pl
+bin/genotypes
+bin/index_radtags.pl
+bin/integrate_alignments.py
+bin/kmer_filter
+bin/load_radtags.pl
+bin/load_sequences.pl
+bin/phasedstacks
+bin/populations
+bin/process_radtags
+bin/process_shortreads
+bin/pstacks
+bin/ref_map.pl
+bin/rxstacks
+bin/sort_read_pairs.pl
+bin/sstacks
+bin/stacks_export_notify.pl
+bin/ustacks
+%%DATADIR%%/php/CatalogClass.php
+%%DATADIR%%/php/Locus.php
+%%DATADIR%%/php/ajax.js
+%%DATADIR%%/php/annotate.js
+%%DATADIR%%/php/annotate_marker.php
+%%DATADIR%%/php/catalog.php
+%%DATADIR%%/php/catalog_genotypes.php
+%%DATADIR%%/php/constants.php.dist
+%%DATADIR%%/php/correct_genotype.php
+%%DATADIR%%/php/correct_genotypes.php
+%%DATADIR%%/php/db_functions.php
+%%DATADIR%%/php/export.js
+%%DATADIR%%/php/export_batch.php
+%%DATADIR%%/php/fst_view.php
+%%DATADIR%%/php/hapstat_view.php
+%%DATADIR%%/php/header.php
+%%DATADIR%%/php/images/caret-d.png
+%%DATADIR%%/php/images/caret-u.png
+%%DATADIR%%/php/images/excel_icon.png
+%%DATADIR%%/php/images/l-arrow-disabled.png
+%%DATADIR%%/php/images/l-arrow.png
+%%DATADIR%%/php/images/r-arrow-disabled.png
+%%DATADIR%%/php/images/r-arrow.png
+%%DATADIR%%/php/images/stacks_bg.png
+%%DATADIR%%/php/images/stacks_logo_rev_small.png
+%%DATADIR%%/php/index.php
+%%DATADIR%%/php/last_modified.php
+%%DATADIR%%/php/phist_view.php
+%%DATADIR%%/php/pop_view.php
+%%DATADIR%%/php/population_view.js
+%%DATADIR%%/php/samples.php
+%%DATADIR%%/php/sequence_blast.php
+%%DATADIR%%/php/stack_view.php
+%%DATADIR%%/php/stacks.css
+%%DATADIR%%/php/stacks.js
+%%DATADIR%%/php/stacks_functions.php
+%%DATADIR%%/php/sumstat_view.php
+%%DATADIR%%/php/tag.php
+%%DATADIR%%/php/tags.php
+%%DATADIR%%/php/version.php
+%%DATADIR%%/php/view_sequence.php
+%%DATADIR%%/sql/catalog_index.sql
+%%DATADIR%%/sql/chr_index.sql
+%%DATADIR%%/sql/mysql.cnf.dist
+%%DATADIR%%/sql/stacks.sql
+%%DATADIR%%/sql/tag_index.sql
+@dir %%DATADIR%%/php/export