aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-05-05 23:53:06 +0800
committerRene Ladan <rene@FreeBSD.org>2020-05-05 23:53:06 +0800
commit5714fb68e8eeb6c05801762cff55390d5df15047 (patch)
treef295ba6d371af507de2b152afee74b9c3d06a0ed
parent0786acb3155523a38d1442f3c16ca56750f1db04 (diff)
downloadfreebsd-ports-gnome-5714fb68e8eeb6c05801762cff55390d5df15047.tar.gz
freebsd-ports-gnome-5714fb68e8eeb6c05801762cff55390d5df15047.tar.zst
freebsd-ports-gnome-5714fb68e8eeb6c05801762cff55390d5df15047.zip
net-mgmt/chillispot: revert r534081, net/openradius was rescued in r534057
This was caused by a race condition: - `rmport -a` noticed that openradius was expired and added the port to its queue - this was with r534032 - in r534057, the port was rescued and the PR was closed - sometime later, rmport got to check upon the now rescued openradius (which from its viewpoint was still broken and expired), did not see any outstanding PR, so decided it was time to remove it. I also checked manually for an outstanding PR, but then it was already closed.
-rw-r--r--net-mgmt/chillispot/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-mgmt/chillispot/Makefile b/net-mgmt/chillispot/Makefile
index 286311a4d096..d9706307bd65 100644
--- a/net-mgmt/chillispot/Makefile
+++ b/net-mgmt/chillispot/Makefile
@@ -21,11 +21,16 @@ CONFIGURE_ARGS=-sysconfdir=${PREFIX}/etc
USE_RC_SUBR= chillispot
SUB_FILES= pkg-message installguide.txt
-OPTIONS_DEFINE= APACHE FREERADIUS
+OPTIONS_DEFINE= APACHE RADIUS
+OPTIONS_SINGLE= RADIUS
+OPTIONS_SINGLE_RADIUS= FREERADIUS OPENRADIUS
+
FREERADIUS_DESC=depend on FreeRADIUS
+OPENRADIUS_DESC=depend on OpenRADIUS
APACHE_USE= apache_run=22+
FREERADIUS_RUN_DEPENDS= radiusd:net/freeradius
+OPENRADIUS_RUN_DEPENDS= radiusd:net/openradius
.include <bsd.port.pre.mk>