aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2013-11-18 07:07:02 +0800
committerfeld <feld@FreeBSD.org>2013-11-18 07:07:02 +0800
commit57598d68e7e241d7e5538f9d09d7ec344f1baf86 (patch)
tree613c92a3b5aad0dceba969766449a236eab49a64
parentd13b7aa2b353bd1c8fb601c7f365deabb6032b0b (diff)
downloadfreebsd-ports-gnome-57598d68e7e241d7e5538f9d09d7ec344f1baf86.tar.gz
freebsd-ports-gnome-57598d68e7e241d7e5538f9d09d7ec344f1baf86.tar.zst
freebsd-ports-gnome-57598d68e7e241d7e5538f9d09d7ec344f1baf86.zip
Take maintainership
Add patch that allows audio device selection with FreeBSD's OSS PR: ports/181104 Submitted by: Natacha Porte Approved by: swills (mentor)
-rw-r--r--audio/mumble/Makefile4
-rw-r--r--audio/mumble/files/patch-src-mumble-OSS.cpp30
2 files changed, 32 insertions, 2 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index 1a3e5d5157fe..23946c091b38 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -3,11 +3,11 @@
PORTNAME= mumble
PORTVERSION= 1.2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/Mumble/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= feld@FreeBSD.org
COMMENT= A voice chat software primarily intended for use while gaming
LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex \
diff --git a/audio/mumble/files/patch-src-mumble-OSS.cpp b/audio/mumble/files/patch-src-mumble-OSS.cpp
new file mode 100644
index 000000000000..596269e4681f
--- /dev/null
+++ b/audio/mumble/files/patch-src-mumble-OSS.cpp
@@ -0,0 +1,30 @@
+--- src/mumble/OSS.cpp.orig 2013-08-03 14:01:25.000000000 +0200
++++ src/mumble/OSS.cpp 2013-08-03 14:12:51.000000000 +0200
+@@ -153,7 +153,6 @@
+ qhOutput.insert(QString(), QLatin1String("Default OSS Device"));
+ qhDevices.insert(QString(), QLatin1String("/dev/dsp"));
+
+-#if (SOUND_VERSION >= 0x040002)
+ int mixerfd = open("/dev/mixer", O_RDWR, 0);
+ if (mixerfd == -1) {
+ qWarning("OSSEnumerator: Failed to open /dev/mixer");
+@@ -182,15 +181,14 @@
+ if (ainfo.caps & PCM_CAP_HIDDEN)
+ continue;
+
+- qhDevices.insert(handle, device);
++ qhDevices.insert(name, device);
+
+ if (ainfo.caps & PCM_CAP_INPUT)
+- qhInput.insert(handle, name);
++ qhInput.insert(name, name);
+ if (ainfo.caps & PCM_CAP_OUTPUT)
+- qhOutput.insert(handle, name);
++ qhOutput.insert(name, name);
+ }
+ close(mixerfd);
+-#endif
+ }
+
+ OSSInput::OSSInput() {
+