aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-03-08 16:27:31 +0800
committerrene <rene@FreeBSD.org>2013-03-08 16:27:31 +0800
commit57dc963adef1ecd5461ed963b0c1b9193bf52ea8 (patch)
tree38fcdc7a8a6d37492a439c4e76d71188751fa491
parenta94032bff80fc6610a262689d3ed0d15df38f195 (diff)
downloadfreebsd-ports-gnome-57dc963adef1ecd5461ed963b0c1b9193bf52ea8.tar.gz
freebsd-ports-gnome-57dc963adef1ecd5461ed963b0c1b9193bf52ea8.tar.zst
freebsd-ports-gnome-57dc963adef1ecd5461ed963b0c1b9193bf52ea8.zip
- Convert to optionsNG
- Add desktop entry - Update COMMENT - Add description to pkg-descr independent of Atomix - Add license (GPLv2) - Cleanups, overhaul installation of documentation - Bump PORTREVISION - Transfer maintainership to submitter PR: ports/173176 Submitted by: nemysis <nemysis@gmx.ch>
-rw-r--r--games/lmarbles/Makefile54
-rw-r--r--games/lmarbles/distinfo2
-rw-r--r--games/lmarbles/pkg-descr5
-rw-r--r--games/lmarbles/pkg-plist14
4 files changed, 50 insertions, 25 deletions
diff --git a/games/lmarbles/Makefile b/games/lmarbles/Makefile
index 834d704c2a70..243aa1eeccfc 100644
--- a/games/lmarbles/Makefile
+++ b/games/lmarbles/Makefile
@@ -1,38 +1,58 @@
-# New ports collection makefile for: marbles
-# Date created: 12 June 2002
-# Whom: verm@drunkmonk.net
-#
+# Created by: verm@drunkmonk.net
# $FreeBSD$
-#
PORTNAME= lmarbles
PORTVERSION= 1.0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
-MASTER_SITES= SF/lgames/${PORTNAME}
+MASTER_SITES= SF/lgames/${PORTNAME} \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A challenging puzzle game similar to Atomix
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Atomix-like game of moving marbles in puzzles
+
+LICENSE= GPLv2
USE_SDL= sdl mixer
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${DATADIR}
+CONFIGURE_ARGS= --localstatedir=${ETCDIR}
MAN6= ${PORTNAME}.6
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog README README-SDL.txt
+
+DOCSRCDIR2= ${WRKSRC}/src/manual
+DOCSDIR2= ${DOCSDIR}/manual
+DOC_FILES2= *.jpg *.html
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|(datadir)/icons|(datadir)/pixmaps|g' \
+ -e 's|(datadir)/pixmaps/lmarbles32.gif|(datadir)/pixmaps/lmarbles32.png|g' \
+ -e 's|(datadir)/pixmaps/lmarbles48.gif|(datadir)/pixmaps/lmarbles48.png|g' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-m 666||g' \
+ -e 's|lmarbles.prfs|lmarbles.prfs.sample|g' \
+ ${WRKSRC}/src/Makefile.in
post-install:
- @${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
- @${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
- @${CHMOD} 0664 ${DATADIR}/${PORTNAME}.prfs
- @${CHOWN} root:games ${DATADIR}/${PORTNAME}.prfs
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/manual/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps/
+ @if [ ! -f ${ETCDIR}/lmarbles.prfs ] ; then \
+ ${INSTALL_DATA} ${ETCDIR}/lmarbles.prfs.sample ${ETCDIR}/lmarbles.prfs ; \
+ fi
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
.endif
.include <bsd.port.mk>
diff --git a/games/lmarbles/distinfo b/games/lmarbles/distinfo
index 4b7c4424a077..2c1a23ce0b1a 100644
--- a/games/lmarbles/distinfo
+++ b/games/lmarbles/distinfo
@@ -1,2 +1,4 @@
SHA256 (lmarbles-1.0.8.tar.gz) = 0e5a16a0116d325589b28f3555ced6a0b486f0fd7632cd3d98bee5cddf213e83
SIZE (lmarbles-1.0.8.tar.gz) = 914238
+SHA256 (lmarbles_icons.tar.gz) = 7e33408a4b6a2e39c979654607757d53432f2d1eaa6814f4f2892939faa8a8cb
+SIZE (lmarbles_icons.tar.gz) = 4096
diff --git a/games/lmarbles/pkg-descr b/games/lmarbles/pkg-descr
index 9f655e1d2e66..ed0c488d8e96 100644
--- a/games/lmarbles/pkg-descr
+++ b/games/lmarbles/pkg-descr
@@ -2,4 +2,9 @@ LMarbles is a game similar to Atomix and was heavily inspired by it.
The goal is to arrange a figure out of single marbles within a time
limit to reach the next level.
+Your goal in the puzzle game marbles is to create a more or less complex
+figure out of single marbles within a time limit to reach the next
+level. Sounds easy? Well, there is a problem: If a marble starts to
+move, it will not stop until it hits a wall or another marble.
+
WWW: http://lgames.sourceforge.net/index.php?project=LMarbles
diff --git a/games/lmarbles/pkg-plist b/games/lmarbles/pkg-plist
index a1eb464309cc..c4525d0a5e42 100644
--- a/games/lmarbles/pkg-plist
+++ b/games/lmarbles/pkg-plist
@@ -1,11 +1,5 @@
bin/lmarbles
share/applications/lmarbles.desktop
-%%PORTDOCS%%%%DOCSDIR%%/arrow.jpg
-%%PORTDOCS%%%%DOCSDIR%%/arrow2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/crumble.jpg
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/marbles.jpg
-%%PORTDOCS%%%%DOCSDIR%%/teleport.jpg
%%DATADIR%%/gfx/board.bmp
%%DATADIR%%/gfx/f_red.bmp
%%DATADIR%%/gfx/f_small.bmp
@@ -63,7 +57,6 @@ share/applications/lmarbles.desktop
%%DATADIR%%/gfx/wood/wall.bmp
%%DATADIR%%/gfx/wood/wall_crumble.bmp
%%DATADIR%%/levels/Original
-%%DATADIR%%/lmarbles.prfs
%%DATADIR%%/sounds/alarm.wav
%%DATADIR%%/sounds/arrow.wav
%%DATADIR%%/sounds/click.wav
@@ -72,7 +65,9 @@ share/applications/lmarbles.desktop
%%DATADIR%%/sounds/select.wav
%%DATADIR%%/sounds/stop.wav
%%DATADIR%%/sounds/teleport.wav
+share/pixmaps/lmarbles32.png
share/pixmaps/lmarbles48.gif
+share/pixmaps/lmarbles48.png
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/levels
@dirrm %%DATADIR%%/gfx/wood
@@ -80,5 +75,8 @@ share/pixmaps/lmarbles48.gif
@dirrm %%DATADIR%%/gfx/metal
@dirrm %%DATADIR%%/gfx
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec if cmp -s %D/%%ETCDIR%%/lmarbles.prfs.sample %D/%%ETCDIR%%/lmarbles.prfs ; then rm -f %D/%%ETCDIR%%/lmarbles.prfs ; fi
+%%ETCDIR%%/lmarbles.prfs.sample
+@exec if [ ! -f %D/%%ETCDIR%%/lmarbles.prfs ] ; then cp -p %D/%F %B/lmarbles.prfs ; fi
+@dirrmtry %%ETCDIR%%
@dirrmtry share/applications