aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-18 01:26:55 +0800
committerwill <will@FreeBSD.org>2001-04-18 01:26:55 +0800
commit57f93c2e89143c7bb7e5a38cd0a8540a5963f047 (patch)
tree2fe45323872a5eac5520c1f22495ce2c18482493
parentfb340bdb41d237e32e71f1a1e3993efafc0958f9 (diff)
downloadfreebsd-ports-gnome-57f93c2e89143c7bb7e5a38cd0a8540a5963f047.tar.gz
freebsd-ports-gnome-57f93c2e89143c7bb7e5a38cd0a8540a5963f047.tar.zst
freebsd-ports-gnome-57f93c2e89143c7bb7e5a38cd0a8540a5963f047.zip
Fix problems with configure bug that doesn't evaluate variables for
support/*.in. PR: 26570 Submitted by: maintainer Found by: mharo
-rw-r--r--www/apache2/Makefile1
-rw-r--r--www/apache2/files/patch-configure20
-rw-r--r--www/apache20/Makefile1
-rw-r--r--www/apache20/files/patch-configure20
-rw-r--r--www/apache21/Makefile1
-rw-r--r--www/apache21/files/patch-configure20
-rw-r--r--www/apache22/Makefile1
-rw-r--r--www/apache22/files/patch-configure20
8 files changed, 80 insertions, 4 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index a549fead3c9e..5ce2baf3327c 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.16
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
http://www.cybernic.com/mirror/dist/httpd/ \
diff --git a/www/apache2/files/patch-configure b/www/apache2/files/patch-configure
index 5419d37c531c..2640a5466ac0 100644
--- a/www/apache2/files/patch-configure
+++ b/www/apache2/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Apr 4 12:45:36 2001
-+++ configure Sun Apr 8 03:25:31 2001
++++ configure Sat Apr 14 18:25:08 2001
@@ -3760,7 +3760,9 @@
-e "s/[ ]*$/'/g" \
$srcdir/config.layout > $pldconf
@@ -10,6 +10,24 @@
rm $pldconf
for var in prefix exec_prefix bindir sbindir libexecdir mandir \
sysconfdir datadir iconsdir htdocsdir cgidir includedir \
+@@ -3777,7 +3779,7 @@
+ ;;
+ esac
+ val=`echo $val | sed -e 's:\(.\)/*$:\1:'`
+- val=`echo $val | sed -e 's:$\([a-z_]*\):$(\1):g'`
++ val=`echo $val | sed -e 's:$\([a-z_]*\):${\1}:g'`
+ if test "$autosuffix" = "yes"; then
+ if echo $val | grep apache >/dev/null; then
+ addtarget=no
+@@ -3788,7 +3790,7 @@
+ val="$val/apache"
+ fi
+ fi
+- eval "$var='$val'"
++ eval "$var=\"$val\""
+ done
+
+
@@ -9678,6 +9680,10 @@
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index a549fead3c9e..5ce2baf3327c 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.16
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
http://www.cybernic.com/mirror/dist/httpd/ \
diff --git a/www/apache20/files/patch-configure b/www/apache20/files/patch-configure
index 5419d37c531c..2640a5466ac0 100644
--- a/www/apache20/files/patch-configure
+++ b/www/apache20/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Apr 4 12:45:36 2001
-+++ configure Sun Apr 8 03:25:31 2001
++++ configure Sat Apr 14 18:25:08 2001
@@ -3760,7 +3760,9 @@
-e "s/[ ]*$/'/g" \
$srcdir/config.layout > $pldconf
@@ -10,6 +10,24 @@
rm $pldconf
for var in prefix exec_prefix bindir sbindir libexecdir mandir \
sysconfdir datadir iconsdir htdocsdir cgidir includedir \
+@@ -3777,7 +3779,7 @@
+ ;;
+ esac
+ val=`echo $val | sed -e 's:\(.\)/*$:\1:'`
+- val=`echo $val | sed -e 's:$\([a-z_]*\):$(\1):g'`
++ val=`echo $val | sed -e 's:$\([a-z_]*\):${\1}:g'`
+ if test "$autosuffix" = "yes"; then
+ if echo $val | grep apache >/dev/null; then
+ addtarget=no
+@@ -3788,7 +3790,7 @@
+ val="$val/apache"
+ fi
+ fi
+- eval "$var='$val'"
++ eval "$var=\"$val\""
+ done
+
+
@@ -9678,6 +9680,10 @@
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index a549fead3c9e..5ce2baf3327c 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.16
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
http://www.cybernic.com/mirror/dist/httpd/ \
diff --git a/www/apache21/files/patch-configure b/www/apache21/files/patch-configure
index 5419d37c531c..2640a5466ac0 100644
--- a/www/apache21/files/patch-configure
+++ b/www/apache21/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Apr 4 12:45:36 2001
-+++ configure Sun Apr 8 03:25:31 2001
++++ configure Sat Apr 14 18:25:08 2001
@@ -3760,7 +3760,9 @@
-e "s/[ ]*$/'/g" \
$srcdir/config.layout > $pldconf
@@ -10,6 +10,24 @@
rm $pldconf
for var in prefix exec_prefix bindir sbindir libexecdir mandir \
sysconfdir datadir iconsdir htdocsdir cgidir includedir \
+@@ -3777,7 +3779,7 @@
+ ;;
+ esac
+ val=`echo $val | sed -e 's:\(.\)/*$:\1:'`
+- val=`echo $val | sed -e 's:$\([a-z_]*\):$(\1):g'`
++ val=`echo $val | sed -e 's:$\([a-z_]*\):${\1}:g'`
+ if test "$autosuffix" = "yes"; then
+ if echo $val | grep apache >/dev/null; then
+ addtarget=no
+@@ -3788,7 +3790,7 @@
+ val="$val/apache"
+ fi
+ fi
+- eval "$var='$val'"
++ eval "$var=\"$val\""
+ done
+
+
@@ -9678,6 +9680,10 @@
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index a549fead3c9e..5ce2baf3327c 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -7,6 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.16
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
http://www.cybernic.com/mirror/dist/httpd/ \
diff --git a/www/apache22/files/patch-configure b/www/apache22/files/patch-configure
index 5419d37c531c..2640a5466ac0 100644
--- a/www/apache22/files/patch-configure
+++ b/www/apache22/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Apr 4 12:45:36 2001
-+++ configure Sun Apr 8 03:25:31 2001
++++ configure Sat Apr 14 18:25:08 2001
@@ -3760,7 +3760,9 @@
-e "s/[ ]*$/'/g" \
$srcdir/config.layout > $pldconf
@@ -10,6 +10,24 @@
rm $pldconf
for var in prefix exec_prefix bindir sbindir libexecdir mandir \
sysconfdir datadir iconsdir htdocsdir cgidir includedir \
+@@ -3777,7 +3779,7 @@
+ ;;
+ esac
+ val=`echo $val | sed -e 's:\(.\)/*$:\1:'`
+- val=`echo $val | sed -e 's:$\([a-z_]*\):$(\1):g'`
++ val=`echo $val | sed -e 's:$\([a-z_]*\):${\1}:g'`
+ if test "$autosuffix" = "yes"; then
+ if echo $val | grep apache >/dev/null; then
+ addtarget=no
+@@ -3788,7 +3790,7 @@
+ val="$val/apache"
+ fi
+ fi
+- eval "$var='$val'"
++ eval "$var=\"$val\""
+ done
+
+
@@ -9678,6 +9680,10 @@