aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-12-17 11:32:45 +0800
committerdbn <dbn@FreeBSD.org>2013-12-17 11:32:45 +0800
commit5918ee96b607a4e1b2c8008982c3dca7dbe79d52 (patch)
tree8098c45c368aca01c001c8b59920bf5160b4ba6d
parentccb5eaf1e82364e9e1ae432a02c7f2a4e6c6de01 (diff)
downloadfreebsd-ports-gnome-5918ee96b607a4e1b2c8008982c3dca7dbe79d52.tar.gz
freebsd-ports-gnome-5918ee96b607a4e1b2c8008982c3dca7dbe79d52.tar.zst
freebsd-ports-gnome-5918ee96b607a4e1b2c8008982c3dca7dbe79d52.zip
Fix build of x11-toolkits/py-kivy on some systems (pygame.joystick related).
On some systems pygame.joystick does not import into python preventing some documentation from being built, thus some missing files on install. For documentation building prevent any attempt to import pygame.joystick as a work-around.
-rw-r--r--x11-toolkits/py-kivy/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index a171a33c4d22..6027fb264118 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -122,6 +122,8 @@ post-build: do-build-docs
do-build-docs:
${MKDIR} ${WRKSRC}/doc/build/doctrees ${WRKSRC}/doc/build/html \
${WRKSRC}/doc/build/latex-a4 ${WRKSRC}/doc/build/latex-letter
+ ${REINPLACE_CMD} -i '' -e 's/\(import pygame\.joystick\)/#\1/' \
+ ${WRKSRC}/kivy/input/providers/androidjoystick.py
(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} doc/autobuild.py)
(cd ${WRKSRC}; \
@@ -142,6 +144,8 @@ do-build-docs:
${SETENV} ${MAKE_ENV} ${GMAKE} -C ${WRKSRC}/doc/build/latex-letter \
all-pdf > /dev/null
.endif
+ ${REINPLACE_CMD} -i '' -e 's/#\(import pygame\.joystick\)/\1/' \
+ ${WRKSRC}/kivy/input/providers/androidjoystick.py
post-install: do-install-docs