aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:23:34 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:23:34 +0800
commit594dc7cfdcd72c68fe2f15d879e78ef30d7cc814 (patch)
treeab3b5f041a48ac0f9ea16008ec1daf862f537549
parent197e34167f91933cdb8448cc7a7d995b760151d1 (diff)
downloadfreebsd-ports-gnome-594dc7cfdcd72c68fe2f15d879e78ef30d7cc814.tar.gz
freebsd-ports-gnome-594dc7cfdcd72c68fe2f15d879e78ef30d7cc814.tar.zst
freebsd-ports-gnome-594dc7cfdcd72c68fe2f15d879e78ef30d7cc814.zip
- adoption of optionsNG
- trim historical headers Approved by: portmgr (miwi)
-rw-r--r--devel/py-yaml/Makefile15
-rw-r--r--devel/qtscriptgenerator/Makefile13
-rw-r--r--devel/talloc/Makefile5
-rw-r--r--devel/tevent/Makefile5
-rw-r--r--devel/thrift/Makefile10
-rw-r--r--devel/tijmp/Makefile11
-rw-r--r--devel/trac-bitten/Makefile20
7 files changed, 38 insertions, 41 deletions
diff --git a/devel/py-yaml/Makefile b/devel/py-yaml/Makefile
index 5382ff963db0..f5d1e6ddfb11 100644
--- a/devel/py-yaml/Makefile
+++ b/devel/py-yaml/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: py-yaml
-# Date created: Jan 3, 2003
-# Whom: ijliao
-#
+# Created by: ijliao@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= yaml
PORTVERSION= 3.10
@@ -16,7 +11,7 @@ DISTNAME= PyYAML-${PORTVERSION}
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= Python YAML parser
-OPTIONS= YAML "Enable LibYAML binding" Off
+OPTIONS_DEFINE= YAML
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -27,14 +22,16 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-.if !defined(NOPORTEXAMPLES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
post-install:
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}/)
.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_YAML)
+.if ${PORT_OPTIONS:MYAML}
PYSETUP= setup.py --with-libyaml
PYDISTUTILS_BUILD_TARGET= build_ext
PYDISTUTILS_BUILDARGS+= --include-dirs=${LOCALBASE}/include \
diff --git a/devel/qtscriptgenerator/Makefile b/devel/qtscriptgenerator/Makefile
index f4d86275725e..8d8b4d3936a1 100644
--- a/devel/qtscriptgenerator/Makefile
+++ b/devel/qtscriptgenerator/Makefile
@@ -1,20 +1,19 @@
-# New ports collection makefile for: qtscriptgenerator
-# Date Created: 13 Apr 2009
-# Whom: Mina R Waheeb <syncer@gmail.com>
-#
+# Created by: Mina R Waheeb <syncer@gmail.com>
# $FreeBSD$
PORTNAME= qtscriptgenerator
PORTVERSION= 0.2.0
PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= syncer@gmail.com
COMMENT= Tool that generates Qt bindings for Qt Script
-OPTIONS= PHONON "Build Phonon support" on
+OPTIONS_DEFINE= PHONON
+PHONON_DESC= Build Phonon support
+OPTIONS_DEFAULT= PHONON
USE_QT4= corelib declarative designer doc help help-tools gui \
iconengines imageformats inputmethods linguist network \
@@ -28,7 +27,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PHONON)
+.if ${PORT_OPTIONS:MPHONON}
USE_QT4+= phonon
PLIST_SUB+= PHONON=""
.else
diff --git a/devel/talloc/Makefile b/devel/talloc/Makefile
index 8178a549002e..e846aa3dac5f 100644
--- a/devel/talloc/Makefile
+++ b/devel/talloc/Makefile
@@ -28,7 +28,8 @@ MAKE_JOBS_SAFE= yes
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PLIST_SUB+= PKGCONFIGDIR=${PKGCONFIGDIR:S;${PREFIX}/;;}
-OPTIONS= PYTHON "Python bindings" on
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT= PYTHON
.include <bsd.port.options.mk>
@@ -52,7 +53,7 @@ _MAKE_JOBS= --jobs=${MAKE_JOBS_NUMBER}
.endif
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON_RUN= yes
PLIST_FILES+= include/pytalloc.h \
lib/libpytalloc-util.so \
diff --git a/devel/tevent/Makefile b/devel/tevent/Makefile
index 33d060f6e8b1..a0c2a6a0353f 100644
--- a/devel/tevent/Makefile
+++ b/devel/tevent/Makefile
@@ -28,7 +28,8 @@ MAKE_JOBS_SAFE= yes
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
PLIST_SUB+= PKGCONFIGDIR=${PKGCONFIGDIR:S;${PREFIX}/;;}
-OPTIONS= PYTHON "Python bindings" on
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT= PYTHON
.include <bsd.port.options.mk>
@@ -57,7 +58,7 @@ _MAKE_JOBS= --jobs=${MAKE_JOBS_NUMBER}
.endif
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON_RUN= yes
PLIST_FILES+= %%PYTHON_SITELIBDIR%%/_tevent.so \
%%PYTHON_SITELIBDIR%%/tevent.py
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index deac1d0515d8..fc33e08fcd3c 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -31,8 +31,9 @@ CONFIGURE_ARGS= --with-boost=${LOCALBASE} --with-libevent=${LOCALBASE} \
--enable-shared --enable-static --with-zlib
CONFIGURE_ENV+= ${MAKE_ENV}
-OPTIONS= GLIB "Building C (GLib) Library" off \
- QT "Building Qt Library" off
+OPTIONS_DEFINE= GLIB QT4
+GLIB_DESC= C (GLib) Library
+
# For Perl support, use devel/p5-Thrift.
# For Python support, use devel/py-thrift.
# For Ruby support, use devel/rubygem-thrift.
@@ -51,10 +52,11 @@ CONFIGURE_ARGS+= \
--without-python \
--without-ruby
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.include "bsd.thrift.mk"
-.if !defined(WITHOUT_GLIB)
+.if ${PORT_OPTIONS:MGLIB}
CONFIGURE_ARGS+= --with-c_glib
LIB_DEPENDS+= glib-2.0:${PORTSDIR}/devel/glib20
PLIST_SUB+= GLIB=""
@@ -64,7 +66,7 @@ CONFIGURE_ARGS+= \
PLIST_SUB+= GLIB="@comment "
.endif
-.if !defined(WITHOUT_QT)
+.if ${PORT_OPTIONS:MQT4}
CONFIGURE_ARGS+= --with-qt4
USE_QT4= network moc_build qmake_build rcc_build uic_build
PLIST_SUB+= QT=""
diff --git a/devel/tijmp/Makefile b/devel/tijmp/Makefile
index 7defe30ebb38..570630879aa5 100644
--- a/devel/tijmp/Makefile
+++ b/devel/tijmp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: tijmp
-# Date created: 8 October 2007
-# Whom: Ronald Klop <ronald@echteman.nl>
-#
+# Created by: Ronald Klop <ronald@echteman.nl>
# $FreeBSD$
-#
PORTNAME= tijmp
PORTVERSION= 0.7
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.khelekore.org/jmp/tijmp/ \
MAINTAINER= ronald@echteman.nl
COMMENT= Tools Interface Java Memory Profiler
-OPTIONS= OPTIMIZED_CFLAGS "Compile with -O3" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS
USE_GMAKE= yes
USE_JAVA= yes
@@ -32,9 +28,10 @@ PLIST_FILES= lib/lib${PORTNAME}.la \
lib/lib${PORTNAME}.so lib/lib${PORTNAME}.so.0 \
%%JAVAJARDIR%%/${PORTNAME}.jar
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS?= -O3
.endif
diff --git a/devel/trac-bitten/Makefile b/devel/trac-bitten/Makefile
index dd61f68b064d..5101ca924c12 100644
--- a/devel/trac-bitten/Makefile
+++ b/devel/trac-bitten/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: trac-bitten
-# Date created: Oct 26 2009
-# Whom: Tim Niemueller <tim@niemueller.de>
-#
+# Created by: Tim Niemueller <tim@niemueller.de>
# $FreeBSD$
-#
PORTNAME= bitten
PORTVERSION= 0.6
@@ -26,11 +22,15 @@ GROUPS= bitten-slave
BITTEN_UID= 952
BITTEN_GID= 952
-OPTIONS= BITTEN_MASTER "Build bitten master" ON
+OPTIONS_DEFINE= BITTEN_MASTER
+BITTEN_MASTER_DESC= Build bitten master
+
+OPTIONS_DEFAULT= BITTEN_MASTER
+
.include <bsd.port.options.mk>
BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-distribute
-.if defined(WITH_BITTEN_MASTER)
+.if ${PORT_OPTIONS:MBITTEN_MASTER}
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
.endif
@@ -48,11 +48,11 @@ PYDISTUTILS_PKGNAME= Bitten
PATCH_STRIP= -p1
USE_RC_SUBR= bitten-slave
-.if defined(WITHOUT_BITTEN_MASTER)
+.if ${PORT_OPTIONS:MBITTEN_MASTER}
+PLIST_SUB+= MASTER_PORT="" EGG_NAME="Bitten"
+.else
PYDISTUTILS_EXTRA_INSTALLARGS=--without-master
PLIST_SUB+= MASTER_PORT="@comment " EGG_NAME="BittenSlave"
-.else
-PLIST_SUB+= MASTER_PORT="" EGG_NAME="Bitten"
.endif
# reproduce rule here with added PYDISTUTILS_EXTRA_INSTALLARGS