aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrix <brix@FreeBSD.org>2008-04-07 01:02:24 +0800
committerbrix <brix@FreeBSD.org>2008-04-07 01:02:24 +0800
commit598fc9890f3253bb72ae6c5eded53aade08710b0 (patch)
treeee86b26e9bd89ad6a36d9749f6c875599e0276ce
parent45a0cf61a54f5a126ac26372387b0a55a51df0a9 (diff)
downloadfreebsd-ports-gnome-598fc9890f3253bb72ae6c5eded53aade08710b0.tar.gz
freebsd-ports-gnome-598fc9890f3253bb72ae6c5eded53aade08710b0.tar.zst
freebsd-ports-gnome-598fc9890f3253bb72ae6c5eded53aade08710b0.zip
- Move a few perl modules from runtime to build dependencies
- Sort build and runtime dependencies - Fix a GNUism in Makefile.PL - Bump PORTREVISION Approved by: erwin (mentor) Reported by: pointyhat via erwin and pav Pointy hat to: brix
-rw-r--r--www/ikiwiki/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/www/ikiwiki/Makefile b/www/ikiwiki/Makefile
index 8c76bfe30248..d3150efd7aa9 100644
--- a/www/ikiwiki/Makefile
+++ b/www/ikiwiki/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ikiwiki
PORTVERSION= 2.41
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -13,21 +14,21 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= brix@FreeBSD.org
COMMENT= A wiki compiler
-BUILD_DEPENDS= ${SITE_PERL}/Text/Markdown.pm:${PORTSDIR}/textproc/p5-Text-Markdown \
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/CGI/FormBuilder.pm:${PORTSDIR}/www/p5-CGI-FormBuilder \
+ ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber \
${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/Text/Markdown.pm:${PORTSDIR}/textproc/p5-Text-Markdown \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS= ${BUILD_DEPENDS} \
- ${SITE_PERL}/CGI/FormBuilder.pm:${PORTSDIR}/www/p5-CGI-FormBuilder \
- ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/File/MimeInfo.pm:${PORTSDIR}/devel/p5-File-MimeInfo \
- ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
${SITE_PERL}/RPC/XML.pm:${PORTSDIR}/net/p5-RPC-XML \
- ${SITE_PERL}/XML/Feed.pm:${PORTSDIR}/textproc/p5-XML-Feed \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+ ${SITE_PERL}/XML/Feed.pm:${PORTSDIR}/textproc/p5-XML-Feed
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -62,6 +63,7 @@ post-patch:
@${REINPLACE_CMD} \
-e 's|$$(PREFIX)/share/man|$$(PREFIX)/man|' \
-e 's|$$(PREFIX)/lib/w3m|$$(PREFIX)/libexec/w3m|' \
+ -e 's|-wholename|-path|' \
${WRKSRC}/Makefile.PL
.ifndef(WITH_W3M)
@${REINPLACE_CMD} -e '/w3m/d' ${WRKSRC}/Makefile.PL