aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-06 04:28:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-06 04:28:03 +0800
commit5a6762cc4bc618c8d518bf7a377719ff3f9e836a (patch)
tree993210cdbeb57d143f90cad86810e48ad3b770aa
parente8b330991d4b74f89062bfc68612f955d22744ed (diff)
downloadfreebsd-ports-gnome-5a6762cc4bc618c8d518bf7a377719ff3f9e836a.tar.gz
freebsd-ports-gnome-5a6762cc4bc618c8d518bf7a377719ff3f9e836a.tar.zst
freebsd-ports-gnome-5a6762cc4bc618c8d518bf7a377719ff3f9e836a.zip
- Update to 3.2.16
- Add LICENSE - Sort RUN_DEPENDS - Use REINPLACE_CMD instead of patch file Changes: https://github.com/rails/rails/blob/v3.2.16/railties/CHANGELOG.md
-rw-r--r--www/rubygem-railties/Makefile11
-rw-r--r--www/rubygem-railties/distinfo4
-rw-r--r--www/rubygem-railties/files/patch-rdoc23
3 files changed, 10 insertions, 28 deletions
diff --git a/www/rubygem-railties/Makefile b/www/rubygem-railties/Makefile
index 8e7c7333238a..0b14ba797192 100644
--- a/www/rubygem-railties/Makefile
+++ b/www/rubygem-railties/Makefile
@@ -1,15 +1,17 @@
# $FreeBSD$
PORTNAME= railties
-PORTVERSION= 3.2.15
+PORTVERSION= 3.2.16
CATEGORIES= www rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Rails internals bootup, plugins, generators, and rake tasks
-RUN_DEPENDS= rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
- rubygem-actionpack>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack \
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionpack>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-activesupport>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport \
rubygem-thor>=0.14.6:${PORTSDIR}/devel/rubygem-thor \
rubygem-rack-ssl>=1.3.2:${PORTSDIR}/www/rubygem-rack-ssl
@@ -20,4 +22,7 @@ RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/rails
+post-patch:
+ @${REINPLACE_CMD} -e '61,72 d' ${WRKSRC}/${GEM_NAME}.gemspec
+
.include <bsd.port.mk>
diff --git a/www/rubygem-railties/distinfo b/www/rubygem-railties/distinfo
index e61a33efe50d..577eef94ccfe 100644
--- a/www/rubygem-railties/distinfo
+++ b/www/rubygem-railties/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rubygem/railties-3.2.15.gem) = 1df2eeeb39acb016bd4b96e19234daf6429515944367e0e9c004b3489c997803
-SIZE (rubygem/railties-3.2.15.gem) = 1587712
+SHA256 (rubygem/railties-3.2.16.gem) = 177c699a03e3bb4d1d0fec745890dd4ee0998d04ce42e5b606028584cbb19d88
+SIZE (rubygem/railties-3.2.16.gem) = 1587712
diff --git a/www/rubygem-railties/files/patch-rdoc b/www/rubygem-railties/files/patch-rdoc
deleted file mode 100644
index b20bc36a6a73..000000000000
--- a/www/rubygem-railties/files/patch-rdoc
+++ /dev/null
@@ -1,23 +0,0 @@
---- railties-3.2.15.gemspec.orig 2013-10-23 21:13:19.836314932 +0000
-+++ railties-3.2.15.gemspec 2013-10-23 21:13:46.760309952 +0000
-@@ -59,20 +59,6 @@
- - !ruby/object:Gem::Version
- version: '2.0'
- - !ruby/object:Gem::Dependency
-- name: rdoc
-- requirement: !ruby/object:Gem::Requirement
-- requirements:
-- - - "~>"
-- - !ruby/object:Gem::Version
-- version: '3.4'
-- type: :runtime
-- prerelease: false
-- version_requirements: !ruby/object:Gem::Requirement
-- requirements:
-- - - "~>"
-- - !ruby/object:Gem::Version
-- version: '3.4'
--- !ruby/object:Gem::Dependency
- name: activesupport
- requirement: !ruby/object:Gem::Requirement
- requirements: