aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2016-01-11 02:16:41 +0800
committerohauer <ohauer@FreeBSD.org>2016-01-11 02:16:41 +0800
commit5ac289dd4cf892dd3394c74f2938c1ad7a785c5a (patch)
tree7f08c2f18b27f586a34c5b7ee4b65215af8353df
parent134d6b6e0e61f3a86101c780d3b5368595430528 (diff)
downloadfreebsd-ports-gnome-5ac289dd4cf892dd3394c74f2938c1ad7a785c5a.tar.gz
freebsd-ports-gnome-5ac289dd4cf892dd3394c74f2938c1ad7a785c5a.tar.zst
freebsd-ports-gnome-5ac289dd4cf892dd3394c74f2938c1ad7a785c5a.zip
- use "SED" instead "REINPLACE_CMD -i"
- provide better config for apache24 - bump PORTREVISION
-rw-r--r--devel/viewvc/Makefile3
-rw-r--r--devel/viewvc/files/pkg-message.in29
2 files changed, 20 insertions, 12 deletions
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index 821996841fa7..e6b48d8deb32 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= viewvc
PORTVERSION= 1.1.24
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.viewvc.org/ \
LOCAL/ohauer
@@ -63,7 +64,7 @@ post-patch:
${WRKSRC}/bin/standalone.py
# to much files, use own shebangfix
${FIND} ${WRKSRC} -type f | ${GREP} -v -e 'png' -e 'images' \
- | ${XARGS} ${REINPLACE_CMD} -i '' \
+ | ${XARGS} ${SED} -i '' \
-e '1s|^\#![[:space:]]*/usr/bin/env python|\#!${PYTHON_CMD}|' \
-e '1s|^\#![[:space:]]*/usr/bin/python|\#!${PYTHON_CMD}|'
diff --git a/devel/viewvc/files/pkg-message.in b/devel/viewvc/files/pkg-message.in
index 41fab98afee4..ea4dc8da3006 100644
--- a/devel/viewvc/files/pkg-message.in
+++ b/devel/viewvc/files/pkg-message.in
@@ -8,10 +8,10 @@
To enable the standalone ViewVC server in rc.conf use
parameter viewvc_enable="YES".
- You can also adjust the user which runs the ViewVC standalone
+ You can also adjust the user which runs the ViewVC standalone
server with the parameter "viewvc_user".
- If you want to run the ViewVC standalone server with another
+ If you want to run the ViewVC standalone server with another
IP/PORT, use the parameter "viewvc_flags".
To see all available parameters, use the command
@@ -21,16 +21,23 @@
To use ViewVC with Apache or lighttpd as a CGI script,
see the following config examples.
- Example config lines for Apache
- ===============================
- Alias /viewvc "%%PREFIX%%/viewvc/bin/cgi/"
- <Directory "%%PREFIX%%/viewvc/bin/cgi">
- AddHandler cgi-script .cgi
- Options NONE +ExecCGI
- DirectoryIndex viewvc.cgi
- Require all granted
- </Directory>
+ Example config lines for Apache 2.4
+ ===================================
+ <IfModule wsgi_module>
+ WSGIRestrictSignal Off
+ </IfModule>
+ <IfModule !wsgi_module>
+ ScriptAlias "/viewvc" "%%PREFIX%%/viewvc/bin/cgi/viewvc.cgi"
+ </IfModule>
+
+ <IfModule wsgi_module>
+ WSGIScriptAlias "/viewvc" "%%PREFIX%%/viewvc/bin/wsgi/viewvc.wsgi"
+ </IfModule>
+
+ <Location /viewvc>
+ Options NONE +ExecCGI
+ </Location>
Example config lines for lighttpd
=================================