aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-05-12 19:31:12 +0800
committerpav <pav@FreeBSD.org>2009-05-12 19:31:12 +0800
commit5acdaffb9669cfd6f62bbb452a66e99a4570f271 (patch)
tree743c50a2825a04af1a5c0fa02d5b4596776f5a1a
parent8e65539a1529b2047b2d27802d8f60a1b7abeb15 (diff)
downloadfreebsd-ports-gnome-5acdaffb9669cfd6f62bbb452a66e99a4570f271.tar.gz
freebsd-ports-gnome-5acdaffb9669cfd6f62bbb452a66e99a4570f271.tar.zst
freebsd-ports-gnome-5acdaffb9669cfd6f62bbb452a66e99a4570f271.zip
- Add an option for unixODBC
PR: ports/133746 Submitted by: Eugene Perevyazko <john@dnepro.net> Approved by: maintainer timeout (27 days)
-rw-r--r--net/freeradius/Makefile13
-rw-r--r--net/freeradius/pkg-plist4
2 files changed, 15 insertions, 2 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 969ec9649ccb..3b777c031364 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -53,6 +53,7 @@ OPTIONS= KERBEROS "With Kerberos support" off \
OPTIONS+= MYSQL "With MySQL database support" off
.endif
OPTIONS+= PGSQL "With PostgreSQL database support" off \
+ UNIXODBC "With unixODBC database support" off \
FIREBIRD "With Firebird database support (EXPERIMENTAL)" off \
SNMP "With SNMP support" off \
EDIR "With Novell eDirectory support" off \
@@ -91,8 +92,7 @@ CONFIGURE_ARGS+=--without-rlm_sql_db2 \
--without-rlm_sql_freetds \
--without-rlm_sql_iodbc \
--without-rlm_sql_oracle \
- --without-rlm_sql_sybase \
- --without-rlm_sql_unixodbc
+ --without-rlm_sql_sybase
.if ${ARCH} == amd64
CONFIGURE_ARGS+= --with-pic
@@ -154,6 +154,15 @@ CONFIGURE_ARGS+=--without-rlm_sql_postgresql
PLIST_SUB+= PGSQL="@comment "
.endif
+.ifdef(WITH_UNIXODBC)
+CONFIGURE_ARGS+=--with-rlm_sql_unixodbc
+PLIST_SUB+= UNIXODBC=""
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.else
+CONFIGURE_ARGS+=--without-rlm_sql_unixodbc
+PLIST_SUB+= UNIXODBC="@comment "
+.endif
+
.ifdef(WITH_FIREBIRD)
USE_FIREBIRD= YES
CONFIGURE_ARGS+=--with-rlm_sql_firebird
diff --git a/net/freeradius/pkg-plist b/net/freeradius/pkg-plist
index 0353a31f628c..68ebce85e383 100644
--- a/net/freeradius/pkg-plist
+++ b/net/freeradius/pkg-plist
@@ -306,6 +306,10 @@ lib/rlm_sql_log.so
%%PGSQL%%lib/rlm_sql_postgresql.a
%%PGSQL%%lib/rlm_sql_postgresql.la
%%PGSQL%%lib/rlm_sql_postgresql.so
+%%UNIXODBC%%lib/rlm_sql_unixodbc-%%PORTVERSION%%.so
+%%UNIXODBC%%lib/rlm_sql_unixodbc.a
+%%UNIXODBC%%lib/rlm_sql_unixodbc.la
+%%UNIXODBC%%lib/rlm_sql_unixodbc.so
lib/rlm_sqlcounter-%%PORTVERSION%%.la
lib/rlm_sqlcounter-%%PORTVERSION%%.so
lib/rlm_sqlcounter.a