aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-17 22:35:08 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-17 22:35:08 +0800
commit5b1d20856883adf7f5bd398a2806790ad961fea6 (patch)
tree4d43fff93a8f50d926f6a749ce1193a2b2b8384e
parente92b532a98dd6406573cacdbccc6066ab332489c (diff)
downloadfreebsd-ports-gnome-5b1d20856883adf7f5bd398a2806790ad961fea6.tar.gz
freebsd-ports-gnome-5b1d20856883adf7f5bd398a2806790ad961fea6.tar.zst
freebsd-ports-gnome-5b1d20856883adf7f5bd398a2806790ad961fea6.zip
add mpg321
A completely free clone of mpg123
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mpg321/Makefile32
-rw-r--r--audio/mpg321/distinfo1
-rw-r--r--audio/mpg321/files/patch-configure11
-rw-r--r--audio/mpg321/pkg-comment1
-rw-r--r--audio/mpg321/pkg-descr1
-rw-r--r--audio/mpg321/pkg-plist1
7 files changed, 48 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0ef0737c3e31..5ded110c0516 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -106,6 +106,7 @@
SUBDIR += mpegaudio
SUBDIR += mpg123
SUBDIR += mpg123.el
+ SUBDIR += mpg321
SUBDIR += mpmf20
SUBDIR += mq3
SUBDIR += musicbox
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
new file mode 100644
index 000000000000..938b554c088f
--- /dev/null
+++ b/audio/mpg321/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: mpg321
+# Date created: Mar 17, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpg321
+PORTVERSION= 0.0.5
+CATEGORIES= audio
+MASTER_SITES= http://gemini.woot.net/~hosehead/packages/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= smpeg.1:${PORTSDIR}/graphics/smpeg \
+ ao.1:${PORTSDIR}/audio/libao \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl-devel \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lc_r -lgnugetopt" \
+ CFLAGS="-I${LOCALBASE}/include" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= mpg321.1
+
+.include <bsd.port.mk>
diff --git a/audio/mpg321/distinfo b/audio/mpg321/distinfo
new file mode 100644
index 000000000000..058abc07a68b
--- /dev/null
+++ b/audio/mpg321/distinfo
@@ -0,0 +1 @@
+MD5 (mpg321_0.0.5.tar.gz) = 6fa2a3012f4ba4c4ffdcb07b6d6013a3
diff --git a/audio/mpg321/files/patch-configure b/audio/mpg321/files/patch-configure
new file mode 100644
index 000000000000..c467932cceb5
--- /dev/null
+++ b/audio/mpg321/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Feb 10 20:39:39 2001
++++ configure Sat Feb 10 20:39:50 2001
+@@ -1078,7 +1078,7 @@
+ AO_LIBS="-L$ao_prefix/lib"
+ fi
+
+- AO_LIBS="$AO_LIBS -lao -ldl"
++ AO_LIBS="$AO_LIBS -lao"
+
+ echo $ac_n "checking for ao""... $ac_c" 1>&6
+ echo "configure:1085: checking for ao" >&5
diff --git a/audio/mpg321/pkg-comment b/audio/mpg321/pkg-comment
new file mode 100644
index 000000000000..44ca8b90f889
--- /dev/null
+++ b/audio/mpg321/pkg-comment
@@ -0,0 +1 @@
+A completely free clone of mpg123
diff --git a/audio/mpg321/pkg-descr b/audio/mpg321/pkg-descr
new file mode 100644
index 000000000000..44ca8b90f889
--- /dev/null
+++ b/audio/mpg321/pkg-descr
@@ -0,0 +1 @@
+A completely free clone of mpg123
diff --git a/audio/mpg321/pkg-plist b/audio/mpg321/pkg-plist
new file mode 100644
index 000000000000..4a3d39061645
--- /dev/null
+++ b/audio/mpg321/pkg-plist
@@ -0,0 +1 @@
+bin/mpg321