aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2004-02-02 23:11:17 +0800
committernectar <nectar@FreeBSD.org>2004-02-02 23:11:17 +0800
commit5b9ac883d395c83db6b1f5f89943c1cf77e14a89 (patch)
tree0d844dda13f97608e527d830bb42030a1a8f3043
parent8e184b70808c2efdb71a213fdfcc3f43dfe84f75 (diff)
downloadfreebsd-ports-gnome-5b9ac883d395c83db6b1f5f89943c1cf77e14a89.tar.gz
freebsd-ports-gnome-5b9ac883d395c83db6b1f5f89943c1cf77e14a89.tar.zst
freebsd-ports-gnome-5b9ac883d395c83db6b1f5f89943c1cf77e14a89.zip
Enable RFC 2307bis, schema mapping, and paged results.
PR: ports/61996 Submitted by: Joseph Scott <joseph@randomnetworks.com>
-rw-r--r--net/nss_ldap/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 77cfe4315e01..d17d716522e8 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
@@ -26,8 +26,12 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
- --with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret
+CONFIGURE_ARGS+= \
+ --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
+ --with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret \
+ --enable-rfc2307bis \
+ --enable-schema-mapping \
+ --enable-paged-results
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
@@ -40,7 +44,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
${CAT} ${PKGMESSAGE}
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500112
IGNORE= NSS modules only supported on FreeBSD 5.1 or later