aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-07-12 13:00:41 +0800
committerknu <knu@FreeBSD.org>2002-07-12 13:00:41 +0800
commit5bc095e912132c9c1ae5c295e08186aafd06b9d1 (patch)
treee853bb7680eecb98fc6a6243499a92784ed73c9e
parentccec9fe7f30a80fd51096114f68fdb0d1aa75757 (diff)
downloadfreebsd-ports-gnome-5bc095e912132c9c1ae5c295e08186aafd06b9d1.tar.gz
freebsd-ports-gnome-5bc095e912132c9c1ae5c295e08186aafd06b9d1.tar.zst
freebsd-ports-gnome-5bc095e912132c9c1ae5c295e08186aafd06b9d1.zip
- Use apxs to determine the location for httpd.conf.
- Make APXS overridable. PR: ports/40283 Submitted by: Sean Chittenden <sean@chittenden.org>
-rw-r--r--www/mod_ruby/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 7cae3ad42330..a66223bdd189 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -22,7 +22,7 @@ USE_RUBY= yes
USE_RUBY_RD= yes
.endif
-APXS= ${LOCALBASE}/sbin/apxs
+APXS?= ${LOCALBASE}/sbin/apxs
CONFIGURE_ARGS= --with-apxs="${APXS}" \
--enable-eruby=yes \
@@ -42,7 +42,7 @@ post-build:
.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/examples/httpd.conf ${PREFIX}/etc/apache/httpd.conf.${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/httpd.conf `${APXS} -q SYSCONFDIR`/httpd.conf.${PORTNAME}
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
.for f in ${DOCS_EN}