aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2014-12-23 07:04:17 +0800
committerdumbbell <dumbbell@FreeBSD.org>2014-12-23 07:04:17 +0800
commit5bebe6a62d9ab7796738b8cf47e8cea68cb6f008 (patch)
treec4aafe980f6f5ff7e0903fde047107a9dd8c45d5
parent8fed23cf2459f63a11abf55cc9928fe2cf6cea15 (diff)
downloadfreebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.tar.gz
freebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.tar.zst
freebsd-ports-gnome-5bebe6a62d9ab7796738b8cf47e8cea68cb6f008.zip
Final removal of WITH_NEW_XORG
This knob was turned on for all version of FreeBSD in r369875 (2014-10-03) and officially deprecated. Since then, it was gradually removed from many ports when they needed an update. x11-servers/xorg-server was the last major user of this knob. The port was updated to xserver 1.14 in r374982 (2014-12-19). The update got rid of the knob, clearing the path to the final removal. This commit changes ports who were checking for WITH_NEW_XORG and remove its handling from bsd.port.mk. While here, two sanity checks are added to warn user about WITH_KMS and WITH_NEW_XORG which have no effect now. Differential Revision: https://reviews.freebsd.org/D1351 Reviewed by: antoine, bapt, kwm Approved by: portmgr (antoine, bapt), kwm
-rw-r--r--Mk/bsd.port.mk8
-rw-r--r--Mk/bsd.sanity.mk8
-rw-r--r--games/sea-defender/Makefile4
-rw-r--r--games/sea-defender/files/patch-snoutlib_gldefs.h (renamed from games/sea-defender/files/extra-snoutlib_gldefs.h)0
-rw-r--r--multimedia/libva-intel-driver/Makefile10
-rw-r--r--textproc/ibus/Makefile5
-rw-r--r--textproc/ibus/files/extra-xigrabkeycode29
-rw-r--r--x11-servers/xephyr/Makefile6
-rw-r--r--x11-toolkits/py-kivy/Makefile6
-rw-r--r--x11/kde4-workspace/Makefile4
-rw-r--r--x11/xorg-minimal/Makefile2
11 files changed, 10 insertions, 72 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bd7b9cca4a61..216271b378e5 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1225,14 +1225,6 @@ _OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
.error OSREL (${OSREL}) and OSVERSION (${OSVERSION}) do not agree on major version number.
.endif
-# Enable new xorg for FreeBSD versions after Radeon KMS was imported unless
-# WITHOUT_NEW_XORG is set.
-.if !defined(WITHOUT_NEW_XORG)
-WITH_NEW_XORG?= yes
-.else
-.undef WITH_NEW_XORG
-.endif
-
# Only define tools here (for transition period with between pkg tools)
.include "${PORTSDIR}/Mk/bsd.commands.mk"
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 722b022f8dfa..17a80a2599dc 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -7,6 +7,14 @@
WARNING+= "WITHOUT_NLS is deprecated use OPTIONS_UNSET=NLS instead"
.endif
+.if defined(WITH_NEW_XORG) || defined(WITHOUT_NEW_XORG)
+WARNING+= "WITH_NEW_XORG and WITHOUT_NEW_XORG knobs were removed and have no effect"
+.endif
+
+.if defined(WITH_KMS) || defined(WITHOUT_KMS)
+WARNING+= "WITH_KMS was removed and has no effect"
+.endif
+
#.if defined(PKGORIGIN)
#.for _c in ${CATEGORIES}
#_CAT?= ${_c}
diff --git a/games/sea-defender/Makefile b/games/sea-defender/Makefile
index eaf6e14540d9..2a241d6cde2e 100644
--- a/games/sea-defender/Makefile
+++ b/games/sea-defender/Makefile
@@ -47,10 +47,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if defined(WITH_NEW_XORG)
-EXTRA_PATCHES+= ${FILESDIR}/extra-snoutlib_gldefs.h
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sea ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/games/sea-defender/files/extra-snoutlib_gldefs.h b/games/sea-defender/files/patch-snoutlib_gldefs.h
index ef24e8028c9e..ef24e8028c9e 100644
--- a/games/sea-defender/files/extra-snoutlib_gldefs.h
+++ b/games/sea-defender/files/patch-snoutlib_gldefs.h
diff --git a/multimedia/libva-intel-driver/Makefile b/multimedia/libva-intel-driver/Makefile
index 027e4019a35e..83488b865018 100644
--- a/multimedia/libva-intel-driver/Makefile
+++ b/multimedia/libva-intel-driver/Makefile
@@ -30,16 +30,6 @@ PLIST_FILES= lib/va/i965_drv_video.so
.include <bsd.port.pre.mk>
-.if defined(WITH_NEW_XORG)
-pre-configure:
-.if !exists(${LOCALBASE}/lib/libkms.so)
- @${ECHO} "${PKGNAME}: Rebuild graphics/libdrm with the KMS option enabled."
- @${FALSE}
-.endif
-.else
-IGNORE= this port needs libdrm version that is available when WITH_NEW_XORG is set
-.endif
-
post-patch: .SILENT
${REINPLACE_CMD} -e 's/-ldl//' \
${WRKSRC}/src/Makefile.am
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index b9cf94f3d545..a07bea582ac0 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -107,11 +107,6 @@ PLIST_SUB+= COMPDIR=""
PLIST_SUB+= COMPDIR="@comment "
.endif
-# Workaround XIGrabKeycode/XIUngrabKeycode bug: XIAllMasterDevice does not work
-.if !defined(WITH_NEW_XORG)
-EXTRA_PATCHES+= ${FILESDIR}/extra-xigrabkeycode
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib/dbus|/var/db/dbus|g' ${WRKSRC}/src/ibusshare.c
diff --git a/textproc/ibus/files/extra-xigrabkeycode b/textproc/ibus/files/extra-xigrabkeycode
deleted file mode 100644
index ed0d9723e595..000000000000
--- a/textproc/ibus/files/extra-xigrabkeycode
+++ /dev/null
@@ -1,29 +0,0 @@
---- ui/gtk3/keybindingmanager.vala.orig 2014-02-03 14:11:48.000000000 -0500
-+++ ui/gtk3/keybindingmanager.vala 2014-02-03 14:12:18.000000000 -0500
-@@ -35,6 +35,8 @@
- Gdk.ModifierType.HYPER_MASK |
- Gdk.ModifierType.META_MASK);
-
-+ public static const int META_CORE_KEYBOARD_ID = 3;
-+
- /**
- * Helper class to store keybinding
- */
-@@ -254,7 +256,7 @@
- XI.set_mask(evmask.mask, XI.EventType.KeyRelease);
-
- int retval = XI.grab_keycode (xdisplay,
-- XI.AllMasterDevices,
-+ META_CORE_KEYBOARD_ID,
- keycode,
- xdisplay.default_root_window(),
- X.GrabMode.Async,
-@@ -275,7 +277,7 @@
- }
-
- int retval = XI.ungrab_keycode (xdisplay,
-- XI.AllMasterDevices,
-+ META_CORE_KEYBOARD_ID,
- keycode,
- xdisplay.default_root_window(),
- get_grab_modifiers(modifiers));
diff --git a/x11-servers/xephyr/Makefile b/x11-servers/xephyr/Makefile
index c5cc7d916ee9..708feeefc12d 100644
--- a/x11-servers/xephyr/Makefile
+++ b/x11-servers/xephyr/Makefile
@@ -23,10 +23,6 @@ PLIST_FILES= bin/Xephyr man/man1/Xephyr.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hw/kdrive/ephyr/Xephyr ${STAGEDIR}${PREFIX}/bin/
-#.if defined(WITH_NEW_XORG)
- -${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/man/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
-#.else
- -${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
-#.endif
+ ${INSTALL_MAN} ${WRKSRC}/hw/kdrive/ephyr/man/Xephyr.1 ${STAGEDIR}${PREFIX}/man/man1/
.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index 1a9c2026a2c0..878f1426a30c 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -82,12 +82,6 @@ OPTIONS_GROUP_VIDEO+= PYGLET
.include <bsd.port.options.mk>
-.if ${ARCH} == i386
-.if !defined(WITH_NEW_XORG)
-BROKEN= Does not compile with old libGL on i386: Undefined symbol glBlendEquationSeparate
-.endif
-.endif
-
.if ${PORT_OPTIONS:MPDF}
.if empty(PORT_OPTIONS:MDOCS)
IGNORE= option PDF requires DOCS
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 5a3fd6090fec..96e1510d8fd9 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -107,10 +107,6 @@ WALLPAPERS_RUN_DEPENDS= ${KDE4_PREFIX}/share/wallpapers/Horos/metadata.desktop:$
.include <bsd.port.options.mk>
-.ifndef(WITH_NEW_XORG)
-IGNORE= requires modern libGL. Please, set WITH_NEW_XORG and update your ports
-.endif
-
.if !exists(/usr/lib/libutempter.so)
LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
.endif
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
index 3c7bc30b5c89..591b77b43032 100644
--- a/x11/xorg-minimal/Makefile
+++ b/x11/xorg-minimal/Makefile
@@ -32,7 +32,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/intel_drv.so:${PORTSDIR}/x11
RUN_DEPENDS+= ${LOCALBASE}/lib/xorg/modules/drivers/${VIDEO_DRIVER}_drv.so:${PORTSDIR}/x11-drivers/xf86-video-${VIDEO_DRIVER}
.endif
-.if ${VIDEO_DRIVER} == intel && defined(WITH_NEW_XORG)
+.if ${VIDEO_DRIVER} == intel
RUN_DEPENDS+= ${LOCALBASE}/lib/va/i965_drv_video.so:${PORTSDIR}/multimedia/libva-intel-driver
.endif