aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-07-11 21:32:55 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-07-11 21:32:55 +0800
commit5c5b94190956a759392ecc9d1d59d039daea405c (patch)
tree0a3799222177a5001145f32a56746b7c58de42f4
parente20dc28b00b1cf3db9789b3b90bf536f74f59b64 (diff)
downloadfreebsd-ports-gnome-5c5b94190956a759392ecc9d1d59d039daea405c.tar.gz
freebsd-ports-gnome-5c5b94190956a759392ecc9d1d59d039daea405c.tar.zst
freebsd-ports-gnome-5c5b94190956a759392ecc9d1d59d039daea405c.zip
Add hooks for winbind
Submitted by: jmurdock@itraktech.com
-rw-r--r--net/samba-devel/Makefile31
-rw-r--r--net/samba/Makefile8
-rw-r--r--net/samba/scripts/configure.samba10
-rw-r--r--net/samba3/Makefile31
4 files changed, 57 insertions, 23 deletions
diff --git a/net/samba-devel/Makefile b/net/samba-devel/Makefile
index 7a7b65ad1dec..b459af9b415f 100644
--- a/net/samba-devel/Makefile
+++ b/net/samba-devel/Makefile
@@ -28,17 +28,6 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
.endif
-.if defined(WITH_QUOTAS)
-CONFIGURE_ARGS+= --with-quotas
-.endif
-
-.if defined(WITH_UTMP)
-CONFIGURE_ARGS+= --with-utmp
-.endif
-
-.if defined(WITH_MSDFS)
-CONFIGURE_ARGS+= --with-msdfs
-.endif
# directories
VARDIR= /var
@@ -61,6 +50,26 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
.include <bsd.port.pre.mk>
+.if defined(WITH_QUOTAS)
+CONFIGURE_ARGS+= --with-quotas
+.endif
+
+.if defined(WITH_UTMP)
+CONFIGURE_ARGS+= --with-utmp
+.endif
+
+.if defined(WITH_MSDFS)
+CONFIGURE_ARGS+= --with-msdfs
+.endif
+
+.if defined(WITH_WINBIND)
+CONFIGURE_ARGS+= --with-winbind
+.endif
+
+.if defined(WITH_WINBIND_AUTH_CHALLENGE)
+CONFIGURE_ARGS+= --with-winbind-auth-challenge
+.endif
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.else
diff --git a/net/samba/Makefile b/net/samba/Makefile
index 2038fdb07ee9..234635e895b7 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -105,6 +105,14 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
WITH_CUPS= yes
.endif
+.if defined(WITH_WINBIND)
+CONFIGURE_ARGS+= --with-winbind
+.endif
+
+.if defined(WITH_WINBIND_AUTH_CHALLENGE)
+CONFIGURE_ARGS+= --with-winbind-auth-challenge
+.endif
+
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.samba
diff --git a/net/samba/scripts/configure.samba b/net/samba/scripts/configure.samba
index aa87e73feea2..80af4c823d43 100644
--- a/net/samba/scripts/configure.samba
+++ b/net/samba/scripts/configure.samba
@@ -13,7 +13,7 @@ if [ "${BATCH}" ]; then
else
/usr/bin/dialog --title "configuration options" --clear \
--checklist "\n\
-Please select desired options:" -1 -1 10 \
+Please select desired options:" -1 -1 12 \
syslog "With syslog support" OFF \
ssl "With ssl support" OFF \
ldap "With LDAP2 support" OFF \
@@ -24,6 +24,8 @@ msdfs "With MSDFS support" OFF \
quota "With Quota support" OFF \
recycle "With Recycle Bin" OFF \
audit "With Audit" OFF \
+winbind "With Winbind" OFF \
+wbauth "With Winbind Auth Challenge" OFF \
2> $tempfile
retval=$?
@@ -79,6 +81,12 @@ while [ "$1" ]; do
\"audit\")
echo "WITH_AUDIT=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
;;
+ \"winbind\")
+ echo "WITH_WINBIND=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ ;;
+ \"wbauth\")
+ echo "WITH_WINBIND_AUTH_CHALLENGE=YES" >>${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ ;;
*)
echo "Invalid option: $1"
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 7a7b65ad1dec..b459af9b415f 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -28,17 +28,6 @@ CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
.endif
-.if defined(WITH_QUOTAS)
-CONFIGURE_ARGS+= --with-quotas
-.endif
-
-.if defined(WITH_UTMP)
-CONFIGURE_ARGS+= --with-utmp
-.endif
-
-.if defined(WITH_MSDFS)
-CONFIGURE_ARGS+= --with-msdfs
-.endif
# directories
VARDIR= /var
@@ -61,6 +50,26 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
.include <bsd.port.pre.mk>
+.if defined(WITH_QUOTAS)
+CONFIGURE_ARGS+= --with-quotas
+.endif
+
+.if defined(WITH_UTMP)
+CONFIGURE_ARGS+= --with-utmp
+.endif
+
+.if defined(WITH_MSDFS)
+CONFIGURE_ARGS+= --with-msdfs
+.endif
+
+.if defined(WITH_WINBIND)
+CONFIGURE_ARGS+= --with-winbind
+.endif
+
+.if defined(WITH_WINBIND_AUTH_CHALLENGE)
+CONFIGURE_ARGS+= --with-winbind-auth-challenge
+.endif
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.else