aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-03-30 16:30:33 +0800
committerdinoex <dinoex@FreeBSD.org>2002-03-30 16:30:33 +0800
commit5cc04e71c86c92ab2c7b1c8846095f02cc58108a (patch)
tree236dd18ced03e5cefaff18d6ceee01c2618f983a
parentf39ecc91887ac40d25b58b56c438548a459985f2 (diff)
downloadfreebsd-ports-gnome-5cc04e71c86c92ab2c7b1c8846095f02cc58108a.tar.gz
freebsd-ports-gnome-5cc04e71c86c92ab2c7b1c8846095f02cc58108a.tar.zst
freebsd-ports-gnome-5cc04e71c86c92ab2c7b1c8846095f02cc58108a.zip
Converted in new layout, make portlint happy too.
This is a 6811 cross toolchain for FreeBSD. The GNU binutils contain: as, ld, ar, objcopy, objdump and many other utilities. The format of object files is ELF-32. The GNU Binutils support translation to other formats such as S-records, Intel HEX records, ... WWW: http://home.worldnet.fr/~stcarrez/m68hc11_port.html PR: 17801 Submitted by: jake
-rw-r--r--devel/Makefile1
-rw-r--r--devel/m6811-binutils/Makefile32
-rw-r--r--devel/m6811-binutils/distinfo2
-rw-r--r--devel/m6811-binutils/pkg-comment1
-rw-r--r--devel/m6811-binutils/pkg-descr10
-rw-r--r--devel/m6811-binutils/pkg-plist52
6 files changed, 98 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dae6d7730b98..f32109a9c85d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -287,6 +287,7 @@
SUBDIR += log4cpp
SUBDIR += lwp
SUBDIR += m4
+ SUBDIR += m6811-binutils
SUBDIR += m68k-rtems-binutils
SUBDIR += m68k-rtems-chill
SUBDIR += m68k-rtems-g77
diff --git a/devel/m6811-binutils/Makefile b/devel/m6811-binutils/Makefile
new file mode 100644
index 000000000000..37f16c8bf40d
--- /dev/null
+++ b/devel/m6811-binutils/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: m6811-binutils
+# Date created: Fri Feb 4 12:27:19 PST 2000
+# Whom: jburkhol@home.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= binutils
+PORTVERSION= 2.9.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= binutils
+PKGNAMEPREFIX= m6811-
+
+PATCH_SITES= http://home.worldnet.fr/~stcarrez/snapshots/
+PATCHFILES= binutils-2.9.1-m68hc1x-20000225.diffs.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= jburkhol@home.com
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --target=m6811-elf \
+ --program-prefix=m6811-elf-
+
+MAN1= m6811-elf-ar.1 m6811-elf-nlmconv.1 m6811-elf-c++filt.1 \
+ m6811-elf-nm.1 m6811-elf-objdump.1 m6811-elf-ranlib.1 \
+ m6811-elf-size.1 m6811-elf-strings.1 m6811-elf-strip.1 \
+ m6811-elf-objcopy.1 m6811-elf-addr2line.1 \
+ m6811-elf-as.1 m6811-elf-ld.1
+
+.include <bsd.port.mk>
diff --git a/devel/m6811-binutils/distinfo b/devel/m6811-binutils/distinfo
new file mode 100644
index 000000000000..92fde427fd2e
--- /dev/null
+++ b/devel/m6811-binutils/distinfo
@@ -0,0 +1,2 @@
+MD5 (binutils-2.9.1.tar.gz) = 8f9ad1a6e96742fd3069479171a63c22
+MD5 (binutils-2.9.1-m68hc1x-20000225.diffs.gz) = aa7dab41de2040d3dea5f2e4036cb470
diff --git a/devel/m6811-binutils/pkg-comment b/devel/m6811-binutils/pkg-comment
new file mode 100644
index 000000000000..ece8a9ed1f30
--- /dev/null
+++ b/devel/m6811-binutils/pkg-comment
@@ -0,0 +1 @@
+The binutils-2.9.1 cross-toolchain for the 6811
diff --git a/devel/m6811-binutils/pkg-descr b/devel/m6811-binutils/pkg-descr
new file mode 100644
index 000000000000..6bd7904f0c75
--- /dev/null
+++ b/devel/m6811-binutils/pkg-descr
@@ -0,0 +1,10 @@
+This is a 6811 cross toolchain for FreeBSD.
+
+The GNU binutils contain: as, ld, ar, objcopy, objdump and many other
+utilities. The format of object files is ELF-32. The GNU Binutils support
+translation to other formats such as S-records, Intel HEX records, ...
+
+WWW: http://home.worldnet.fr/~stcarrez/m68hc11_port.html
+
+--
+jburkhol@home.com
diff --git a/devel/m6811-binutils/pkg-plist b/devel/m6811-binutils/pkg-plist
new file mode 100644
index 000000000000..1836d5a32d71
--- /dev/null
+++ b/devel/m6811-binutils/pkg-plist
@@ -0,0 +1,52 @@
+bin/m6811-elf-size
+bin/m6811-elf-objdump
+bin/m6811-elf-ar
+bin/m6811-elf-strings
+bin/m6811-elf-ranlib
+bin/m6811-elf-c++filt
+bin/m6811-elf-objcopy
+bin/m6811-elf-addr2line
+bin/m6811-elf-nm
+bin/m6811-elf-strip
+bin/m6811-elf-as
+bin/m6811-elf-gasp
+bin/m6811-elf-ld
+include/bfd.h
+include/ansidecl.h
+include/bfdlink.h
+info/dir
+lib/libiberty.a
+lib/libbfd.la
+lib/libbfd.a
+lib/libopcodes.la
+lib/libopcodes.a
+m6811-elf/bin/nm
+m6811-elf/bin/strip
+m6811-elf/bin/ar
+m6811-elf/bin/ranlib
+m6811-elf/bin/as
+m6811-elf/bin/ld
+m6811-elf/lib/ldscripts/m68hc11elf.x
+m6811-elf/lib/ldscripts/m68hc11elf.xbn
+m6811-elf/lib/ldscripts/m68hc11elf.xn
+m6811-elf/lib/ldscripts/m68hc11elf.xr
+m6811-elf/lib/ldscripts/m68hc11elf.xu
+m6811-elf/lib/ldscripts/m68hc11elfb.x
+m6811-elf/lib/ldscripts/m68hc11elfb.xbn
+m6811-elf/lib/ldscripts/m68hc11elfb.xn
+m6811-elf/lib/ldscripts/m68hc11elfb.xr
+m6811-elf/lib/ldscripts/m68hc11elfb.xu
+m6811-elf/lib/ldscripts/m68hc12elf.x
+m6811-elf/lib/ldscripts/m68hc12elf.xbn
+m6811-elf/lib/ldscripts/m68hc12elf.xn
+m6811-elf/lib/ldscripts/m68hc12elf.xr
+m6811-elf/lib/ldscripts/m68hc12elf.xu
+m6811-elf/lib/ldscripts/m68hc12elfb.x
+m6811-elf/lib/ldscripts/m68hc12elfb.xbn
+m6811-elf/lib/ldscripts/m68hc12elfb.xn
+m6811-elf/lib/ldscripts/m68hc12elfb.xr
+m6811-elf/lib/ldscripts/m68hc12elfb.xu
+@dirrm m6811-elf/lib/ldscripts
+@dirrm m6811-elf/lib
+@dirrm m6811-elf/bin
+@dirrm m6811-elf