aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-09-17 00:02:50 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2014-09-17 00:02:50 +0800
commit5e092869e200b12cb138e204209dcbb288d34bbb (patch)
tree89af04aa88021481c428b3055d50fb8aa9e1b922
parent109aa0add178f8612c7a204c8f8e7b4b6967ab89 (diff)
downloadfreebsd-ports-gnome-5e092869e200b12cb138e204209dcbb288d34bbb.tar.gz
freebsd-ports-gnome-5e092869e200b12cb138e204209dcbb288d34bbb.tar.zst
freebsd-ports-gnome-5e092869e200b12cb138e204209dcbb288d34bbb.zip
- Continue to define PKGNG_ORIGIN.
- This is used by portupgrade and poudriere bulk/testport -i for install-package. - The change is not backwards compatible; setting PKGNG_ORIGIN was never intended. It is only for reading. With hat: portmgr Discussed with: bapt
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 889d2a07a482..00b13b933ddc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1664,8 +1664,9 @@ LIB32DIR= lib
.endif
PLIST_SUB+= LIB32DIR=${LIB32DIR}
+# Keep PKGNG_ORIGIN/WITH_PKGNG for compat with scripts which are looking for it
PKG_ORIGIN?= ports-mgmt/pkg
-# Keep WITH_PKGNG for compat with scripts which are looking for it
+PKGNG_ORIGIN= ${PKG_ORIGIN}
WITH_PKGNG?= yes
WITH_PKG?= ${WITH_PKGNG}
@@ -3657,8 +3658,8 @@ delete-package-list:
@${ECHO_CMD} "[ -f ${PKGFILE} ] && (${ECHO_CMD} deleting ${PKGFILE}; ${RM} -f ${PKGFILE})"
.endif
-# Used if !defined(NO_STAGE) during install, or manually to install package
-# from local repository.
+# Used by scripts and users to install a package from local repository.
+# Poudriere -i uses this, please keep.
.if !target(install-package)
.if defined(FORCE_PKG_REGISTER)
_INSTALL_PKG_ARGS= -f