aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-09-12 09:39:55 +0800
committerjhale <jhale@FreeBSD.org>2014-09-12 09:39:55 +0800
commit5e8365ef9ad04e3af5ec903c0b0bb68d483a2e3d (patch)
tree5342f2b90069fef5fd9587a0cf12069797394c9a
parentb82419f6affbd10992a55f0879581963352c9db2 (diff)
downloadfreebsd-ports-gnome-5e8365ef9ad04e3af5ec903c0b0bb68d483a2e3d.tar.gz
freebsd-ports-gnome-5e8365ef9ad04e3af5ec903c0b0bb68d483a2e3d.tar.zst
freebsd-ports-gnome-5e8365ef9ad04e3af5ec903c0b0bb68d483a2e3d.zip
New port: net/go-cs
go-cs is a program for concurrently executing ssh(1)/scp(1) on a number of hosts. It is intended to automate running remote commands or copying files between hosts on a network. WWW: http://github.com/akosela/go-cs PR: 193470 Submitted by: Andy Kosela <akosela@andykosela.com>
-rw-r--r--net/Makefile1
-rw-r--r--net/go-cs/Makefile33
-rw-r--r--net/go-cs/distinfo2
-rw-r--r--net/go-cs/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ba4a745655fe..974e95498923 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -144,6 +144,7 @@
SUBDIR += gnome-nettool
SUBDIR += gnu-dico
SUBDIR += gnu-radius
+ SUBDIR += go-cs
SUBDIR += go.net
SUBDIR += gofish
SUBDIR += gogoc
diff --git a/net/go-cs/Makefile b/net/go-cs/Makefile
new file mode 100644
index 000000000000..07926e0ae578
--- /dev/null
+++ b/net/go-cs/Makefile
@@ -0,0 +1,33 @@
+# Created by: Andy Kosela <akosela@andykosela.com>
+# $FreeBSD$
+
+PORTNAME= go-cs
+PORTVERSION= 0.1
+CATEGORIES= net
+
+MAINTAINER= akosela@andykosela.com
+COMMENT= Concurrent ssh client
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${GO_CMD}:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= akosela
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 6ae59df
+
+PLIST_FILES= bin/cs man/man1/cs.1.gz
+
+GO_CMD= ${LOCALBASE}/bin/go
+GO_ARGS= build -ldflags "${STRIP}"
+
+do-build:
+ (cd ${WRKSRC} && ${GO_CMD} ${GO_ARGS} cs.go)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cs.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/go-cs/distinfo b/net/go-cs/distinfo
new file mode 100644
index 000000000000..8582c68954ef
--- /dev/null
+++ b/net/go-cs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go-cs-0.1.tar.gz) = 71b3240810ae7c5ae8fc57a8e9ae3f2cd3ffa2463097344b7b6926bc32c66cfd
+SIZE (go-cs-0.1.tar.gz) = 4484
diff --git a/net/go-cs/pkg-descr b/net/go-cs/pkg-descr
new file mode 100644
index 000000000000..a2516aab7a0d
--- /dev/null
+++ b/net/go-cs/pkg-descr
@@ -0,0 +1,5 @@
+go-cs is a program for concurrently executing ssh(1)/scp(1) on a number
+of hosts. It is intended to automate running remote commands or copying
+files between hosts on a network.
+
+WWW: http://github.com/akosela/go-cs