aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-02-15 01:28:19 +0800
committermarcus <marcus@FreeBSD.org>2008-02-15 01:28:19 +0800
commit5f1bea069cdc8414256becf3a3b48a59d1a9a0a2 (patch)
tree8a0662c3bf86d5ee4b95c7ea34c1139b0a0ef8f0
parent966e9662c3efff72349f48bd8f04fb2368eae57b (diff)
downloadfreebsd-ports-gnome-5f1bea069cdc8414256becf3a3b48a59d1a9a0a2.tar.gz
freebsd-ports-gnome-5f1bea069cdc8414256becf3a3b48a59d1a9a0a2.tar.zst
freebsd-ports-gnome-5f1bea069cdc8414256becf3a3b48a59d1a9a0a2.zip
Chase the updated SHM ABI changes to allow libgtop to report more than
2 GB of SHM on 64-bit architectures. Reported by: csjp
-rw-r--r--devel/libgtop/Makefile1
-rw-r--r--devel/libgtop/files/patch-sysdeps_freebsd_shm_limits.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index f6ca4775389f..8467154af8af 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libgtop
PORTVERSION= 2.20.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/devel/libgtop/files/patch-sysdeps_freebsd_shm_limits.c b/devel/libgtop/files/patch-sysdeps_freebsd_shm_limits.c
new file mode 100644
index 000000000000..755bb62311ac
--- /dev/null
+++ b/devel/libgtop/files/patch-sysdeps_freebsd_shm_limits.c
@@ -0,0 +1,22 @@
+--- sysdeps/freebsd/shm_limits.c.orig 2008-02-14 12:26:46.000000000 -0500
++++ sysdeps/freebsd/shm_limits.c 2008-02-14 12:26:29.000000000 -0500
+@@ -25,6 +25,7 @@
+ #include <glibtop/shm_limits.h>
+
+ #include <sys/types.h>
++#include <sys/param.h>
+ #include <sys/sysctl.h>
+
+ static unsigned long _glibtop_sysdeps_shm_limits =
+@@ -46,7 +47,11 @@ void
+ glibtop_get_shm_limits_s (glibtop *server, glibtop_shm_limits *buf)
+ {
+ size_t len;
++#if __FreeBSD_version < 800020
+ int shmmax, shmmin, shmmni, shmseg, shmall;
++#else
++ unsigned long shmmax, shmmin, shmmni, shmseg, shmall;
++#endif
+
+ glibtop_init_s (&server, GLIBTOP_SYSDEPS_SHM_LIMITS, 0);
+