aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-08 16:04:04 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-08 16:04:04 +0800
commit5f5fa9ad85e9a0ea7aea9c2e7b5d058790116468 (patch)
tree4b73409985b156444768ef6039a67ff33e713666
parentdfc2fd885de02f581020f626d1dab809e107622d (diff)
downloadfreebsd-ports-gnome-5f5fa9ad85e9a0ea7aea9c2e7b5d058790116468.tar.gz
freebsd-ports-gnome-5f5fa9ad85e9a0ea7aea9c2e7b5d058790116468.tar.zst
freebsd-ports-gnome-5f5fa9ad85e9a0ea7aea9c2e7b5d058790116468.zip
- Mark MAKE_JOBS_SAFE
- Trim header
-rw-r--r--archivers/amigadepacker/Makefile8
-rw-r--r--deskutils/notify-osd/Makefile7
-rw-r--r--devel/p5-Perl-Unsafe-Signals/Makefile7
-rw-r--r--devel/p5-Uniq/Makefile7
-rw-r--r--games/ctris/Makefile7
-rw-r--r--misc/shuffle-db/Makefile7
-rw-r--r--www/p5-Google-Search/Makefile7
-rw-r--r--www/p5-HTML-DOM/Makefile7
-rw-r--r--www/p5-Reddit/Makefile7
-rw-r--r--www/p5-WWW-Scripter-Plugin-Ajax/Makefile7
-rw-r--r--www/p5-WWW-Scripter-Plugin-JavaScript/Makefile7
-rw-r--r--www/p5-WWW-Scripter/Makefile7
12 files changed, 25 insertions, 60 deletions
diff --git a/archivers/amigadepacker/Makefile b/archivers/amigadepacker/Makefile
index 56a63ca38a40..7e9c741494e2 100644
--- a/archivers/amigadepacker/Makefile
+++ b/archivers/amigadepacker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: amigadepacker
-# Date created: 18 Oct 2009
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= amigadepacker
PORTVERSION= 0.04
@@ -26,6 +22,8 @@ ALL_TARGET= ${PORTNAME}
MAN1= amigadepacker.1
PLIST_FILES= bin/amigadepacker
+MAKE_JOBS_SAFE= yes
+
post-patch:
@${REINPLACE_CMD} -E '/^(CC|CFLAGS)/d' ${WRKSRC}/Makefile.in
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index bea9f87b9c5f..27af62a87db6 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: notify-osd
-# Date created: 05 May 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= notify-osd
PORTVERSION= 0.9.29
@@ -27,5 +23,6 @@ GNU_CONFIGURE= yes
USE_GNOME= libwnck gconf2
USE_GMAKE= yes
USE_GCC= 4.4+
+MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/devel/p5-Perl-Unsafe-Signals/Makefile b/devel/p5-Perl-Unsafe-Signals/Makefile
index 996138121d0e..d9344ac0e1b4 100644
--- a/devel/p5-Perl-Unsafe-Signals/Makefile
+++ b/devel/p5-Perl-Unsafe-Signals/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Perl-Unsafe-Signals
-# Date created: 19 Oct 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Perl-Unsafe-Signals
PORTVERSION= 0.02
@@ -15,6 +11,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Allow unsafe handling of signals in selected blocks
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= Perl::Unsafe::Signals.3
diff --git a/devel/p5-Uniq/Makefile b/devel/p5-Uniq/Makefile
index 4f5513c4c036..e8011973e584 100644
--- a/devel/p5-Uniq/Makefile
+++ b/devel/p5-Uniq/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Uniq
-# Date created: 06 Oct 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Uniq
PORTVERSION= 0.01
@@ -16,6 +12,7 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Perl extension for managing a uniq list of values
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= Uniq.3
diff --git a/games/ctris/Makefile b/games/ctris/Makefile
index 7ad81a9f6bd9..dae9429dfa02 100644
--- a/games/ctris/Makefile
+++ b/games/ctris/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ctetris
-# Date created: 14 Aug 2004
-# Whom: Travis Poppe <tlp@liquidx.org>
-#
+# Created by: Travis Poppe <tlp@liquidx.org>
# $FreeBSD$
-#
PORTNAME= ctris
PORTVERSION= 0.42
@@ -18,6 +14,7 @@ LICENSE= GPLv2
USE_BZIP2= yes
MANCOMPRESSED= yes
+MAKE_JOBS_SAFE= yes
MAN6= ctris.6
PLIST_FILES= bin/ctris
diff --git a/misc/shuffle-db/Makefile b/misc/shuffle-db/Makefile
index f24ed8b061ba..8b30d5bbf106 100644
--- a/misc/shuffle-db/Makefile
+++ b/misc/shuffle-db/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shuffle-db
-# Date created: 16 Jan 2007
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= shuffle-db
DISTVERSION= 1.0-rc1
@@ -16,6 +12,7 @@ COMMENT= An iPod shuffle database builder
USE_PYTHON= yes
NO_BUILD= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/rebuild_db
PLIST_FILES= bin/rebuild_db.py
diff --git a/www/p5-Google-Search/Makefile b/www/p5-Google-Search/Makefile
index b61175622fc1..b6850bab27c6 100644
--- a/www/p5-Google-Search/Makefile
+++ b/www/p5-Google-Search/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Google-Search
-# Date created: 20 Jul 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Google-Search
PORTVERSION= 0.028
@@ -24,6 +20,7 @@ RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= Google::Search.3 Google::Search::Result.3
diff --git a/www/p5-HTML-DOM/Makefile b/www/p5-HTML-DOM/Makefile
index 4b05dcdd06e5..04069d97f483 100644
--- a/www/p5-HTML-DOM/Makefile
+++ b/www/p5-HTML-DOM/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-HTML-DOM
-# Date created: 26 Jan 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= HTML-DOM
PORTVERSION= 0.053
@@ -25,6 +21,7 @@ BUILD_DEPENDS= p5-CSS-DOM>=0:${PORTSDIR}/www/p5-CSS-DOM \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
.include "${MASTERDIR}/Makefile.man"
diff --git a/www/p5-Reddit/Makefile b/www/p5-Reddit/Makefile
index 0971dabe4dcc..2815fea11a74 100644
--- a/www/p5-Reddit/Makefile
+++ b/www/p5-Reddit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Reddit
-# Date created: 18 Apr 2012
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Reddit
PORTVERSION= 0.3.02.20120418
@@ -25,6 +21,7 @@ RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= Reddit.3
diff --git a/www/p5-WWW-Scripter-Plugin-Ajax/Makefile b/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
index 690d7ad1d3fd..9950de1c6b03 100644
--- a/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
+++ b/www/p5-WWW-Scripter-Plugin-Ajax/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-WWW-Scripter-Plugin-Ajax
-# Date created: 28 Jan 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= WWW-Scripter-Plugin-Ajax
PORTVERSION= 0.09
@@ -19,6 +15,7 @@ RUN_DEPENDS= p5-WWW-Scripter-Plugin-JavaScript>0:${PORTSDIR}/www/p5-WWW-Scripter
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= WWW::Scripter::Plugin::Ajax.3
diff --git a/www/p5-WWW-Scripter-Plugin-JavaScript/Makefile b/www/p5-WWW-Scripter-Plugin-JavaScript/Makefile
index 19beedb3dd3e..a19b595dc361 100644
--- a/www/p5-WWW-Scripter-Plugin-JavaScript/Makefile
+++ b/www/p5-WWW-Scripter-Plugin-JavaScript/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-WWW-Scripter-Plugin-JavaScript
-# Date created: 27 Jan 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= WWW-Scripter-Plugin-JavaScript
PORTVERSION= 0.008
@@ -19,6 +15,7 @@ RUN_DEPENDS= p5-WWW-Scripter>0:${PORTSDIR}/www/p5-WWW-Scripter \
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= WWW::Scripter::Plugin::JavaScript.3 \
WWW::Scripter::Plugin::JavaScript::JE.3
diff --git a/www/p5-WWW-Scripter/Makefile b/www/p5-WWW-Scripter/Makefile
index b50833e06043..9f70981d6b43 100644
--- a/www/p5-WWW-Scripter/Makefile
+++ b/www/p5-WWW-Scripter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-WWW-Scripter
-# Date created: 26 Jan 2010
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= WWW-Scripter
PORTVERSION= 0.029
@@ -21,6 +17,7 @@ RUN_DEPENDS= p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww \
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN3= WWW::Scripter::Location.3 WWW::Scripter.3 \
WWW::Scripter::History.3 WWW::Scripter::WindowGroup.3