aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-12-22 02:12:11 +0800
committeryuri <yuri@FreeBSD.org>2017-12-22 02:12:11 +0800
commit5fa63007c7ae2042b9072a39cb823a708314e4f1 (patch)
tree3bebf314cc98e759f321faf226081193e9b06e14
parent706088d2a51fb14185118f02f363733ccd7f6f88 (diff)
downloadfreebsd-ports-gnome-5fa63007c7ae2042b9072a39cb823a708314e4f1.tar.gz
freebsd-ports-gnome-5fa63007c7ae2042b9072a39cb823a708314e4f1.tar.zst
freebsd-ports-gnome-5fa63007c7ae2042b9072a39cb823a708314e4f1.zip
New port: sysutils/twmn: Notification system for tiling window managers
There were some questions about the version. The source code has 1.2 in it, but it hasn't been tagged on github. So I left it as g20171216. PR: 224470 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D13563
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/twmn/Makefile40
-rw-r--r--sysutils/twmn/distinfo3
-rw-r--r--sysutils/twmn/pkg-descr15
4 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ee5629f27db6..c01386ce098e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1200,6 +1200,7 @@
SUBDIR += trueos-libqt5
SUBDIR += tuptime
SUBDIR += tw_cli
+ SUBDIR += twmn
SUBDIR += tzdialog
SUBDIR += u-boot-a13-olinuxino
SUBDIR += u-boot-a64-olinuxino
diff --git a/sysutils/twmn/Makefile b/sysutils/twmn/Makefile
new file mode 100644
index 000000000000..b9c34d86274e
--- /dev/null
+++ b/sysutils/twmn/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= twmn
+PORTVERSION= g20171216
+CATEGORIES= sysutils
+
+MAINTAINER= dg@syrec.org
+COMMENT= Notification system for tiling window managers
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_system.so:devel/boost-libs
+
+USES= qmake
+USE_GITHUB= yes
+GH_ACCOUNT= sboli
+GH_TAGNAME= 5b92ac5
+USE_QT5= core dbus gui network widgets x11extras buildtools_build
+LDFLAGS+= -Wl,--as-needed # see bug#224488
+
+PORTDOCS= README.md
+PORTEXAMPLES= *
+
+PLIST_FILES= bin/twmnc bin/twmnd
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/twmnc ${STAGEDIR}${PREFIX}/bin/twmnd
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/twmn/distinfo b/sysutils/twmn/distinfo
new file mode 100644
index 000000000000..4f96af2da78b
--- /dev/null
+++ b/sysutils/twmn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513803467
+SHA256 (sboli-twmn-g20171216-5b92ac5_GH0.tar.gz) = bd9793942919de021e2c88f69795a2fde11441c5e9153b89a1f96ad1009774cb
+SIZE (sboli-twmn-g20171216-5b92ac5_GH0.tar.gz) = 75071
diff --git a/sysutils/twmn/pkg-descr b/sysutils/twmn/pkg-descr
new file mode 100644
index 000000000000..88abd2b459d7
--- /dev/null
+++ b/sysutils/twmn/pkg-descr
@@ -0,0 +1,15 @@
+twmn is a notification system for tiling window managers. It consists of the
+two programs:
+
+twmnc: command line tool to send notifications to twmnd. You can also use
+notify-send for a similar purpose, but twmnc is more powerful. See
+twmnc --help for more information.
+
+twmnd: daemon listening to notification requests and showing them one after
+another. Configure it at ~/.config/twmn/twmn.conf. The file is generated the
+first time twmnd is launched.
+
+Notifications are shown in a one-line bar called the notification slide.
+They can be navigated through and activated with shortcuts.
+
+WWW: https://github.com/sboli/twmn