aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-11-13 16:23:15 +0800
committerahze <ahze@FreeBSD.org>2004-11-13 16:23:15 +0800
commit60097af291c708b3d07882686046f0cda1748d42 (patch)
treed64b4d221b6dda93c2f07396edb05b2b0daa13b5
parent37d4aaea2989227c12d78b59d470f49476ab5e14 (diff)
downloadfreebsd-ports-gnome-60097af291c708b3d07882686046f0cda1748d42.tar.gz
freebsd-ports-gnome-60097af291c708b3d07882686046f0cda1748d42.tar.zst
freebsd-ports-gnome-60097af291c708b3d07882686046f0cda1748d42.zip
Chase changes to firefox
Approved by: marcus (co mentor)
-rw-r--r--graphics/librsvg2/Makefile7
-rw-r--r--www/flashplugin-firefox/Makefile4
-rw-r--r--www/mozex-firefox/Makefile1
-rw-r--r--www/mozex/Makefile2
-rw-r--r--www/mozex/Makefile.xpi4
-rw-r--r--www/mplayer-plugin/Makefile22
-rw-r--r--www/preferential-firefox/Makefile1
-rw-r--r--www/preferential/Makefile2
-rw-r--r--www/xpi-mozex/Makefile1
-rw-r--r--www/xpi-preferential/Makefile1
10 files changed, 18 insertions, 27 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index 1d534fa7dbc0..b936beb8cb5b 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= librsvg2
PORTVERSION= 2.8.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
@@ -50,8 +51,8 @@ OPTIONS= MOZILLA_PLUGIN "Enable the RSVG browser plug-in" no
.if defined(WITH_MOZILLA_PLUGIN)
.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="firefox"
-BUILD_DEPENDS+= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
-RUN_DEPENDS+= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+BUILD_DEPENDS+= ${X11BASE}/libdata/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS+= ${X11BASE}/libdata/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
.else
BUILD_DEPENDS+= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
RUN_DEPENDS+= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
@@ -69,7 +70,7 @@ HEADERS_SUFX=
HEADERS_SUFX= -devel
.else
.if ${WITH_MOZILLA}=="firefox"
-CONFIGURE_ENV+= PKG_CONFIG_PATH=${X11BASE}/lib/firefox/lib/pkgconfig
+HEADERS_SUFX=
.endif
.endif
.endif
diff --git a/www/flashplugin-firefox/Makefile b/www/flashplugin-firefox/Makefile
index 6f130d6e2fd8..ae6ee4edf294 100644
--- a/www/flashplugin-firefox/Makefile
+++ b/www/flashplugin-firefox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flashplugin-firefox
PORTVERSION= 0.4.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://www.swift-tools.net/Flash/
DISTNAME= flash-${PORTVERSION}
@@ -22,7 +22,7 @@ RUN_DEPENDS?= firefox:${PORTSDIR}/www/firefox
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/Plugin
-PLUGIN_DIR?= lib/firefox/lib/firefox-1.0/plugins
+PLUGIN_DIR?= lib/firefox/plugins
PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
do-install:
diff --git a/www/mozex-firefox/Makefile b/www/mozex-firefox/Makefile
index 0e81705fa715..093604488d92 100644
--- a/www/mozex-firefox/Makefile
+++ b/www/mozex-firefox/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= mozex
+PORTREVISION= 2
#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
MAINTAINER= ports@FreeBSD.org
diff --git a/www/mozex/Makefile b/www/mozex/Makefile
index 83836a609d26..24282a80c28c 100644
--- a/www/mozex/Makefile
+++ b/www/mozex/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozex
PORTVERSION= 1.07
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= www mail news ftp
MASTER_SITES= http://downloads.mozdev.org/mozex/ \
http://mozdev.sweetooth.org/mozex/
diff --git a/www/mozex/Makefile.xpi b/www/mozex/Makefile.xpi
index ccf6c2fc2b83..bc2fd9aedfe1 100644
--- a/www/mozex/Makefile.xpi
+++ b/www/mozex/Makefile.xpi
@@ -38,12 +38,12 @@ MOZDIR!= ${FIND} ${X11BASE}/lib -name firefox-bin -exec dirname {} \; | ${HEAD}
MOZDIR=
. endif
. if empty(MOZDIR)
-MOZVER= firefox-1.0 # Warning! chase this when upgrading firefox.
+MOZVER= firefox
. else
MOZVER!= ${BASENAME} ${MOZDIR}
. endif
MOZPORT= firefox
-MOZLDIR= lib/firefox/lib/${MOZVER}
+MOZLDIR= lib/firefox
.endif
.if empty(MOZDIR)
MOZDIR= ${X11BASE}/${MOZLDIR}
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 32e38b012898..777074afe53a 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayerplug-in
PORTVERSION= 2.70
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -16,8 +16,8 @@ MAINTAINER= marcus@FreeBSD.org
COMMENT= A Mozilla plugin for the MPlayer media player
.if defined(WITH_MOZILLA) && ${WITH_MOZILLA}=="firefox"
-BUILD_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
-RUN_DEPENDS= ${X11BASE}/lib/firefox/lib/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/firefox-plugin.pc:${PORTSDIR}/www/firefox
.else
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/mozilla-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/mozilla${HEADERS_SUFX}
@@ -45,19 +45,7 @@ HEADERS_SUFX=
.if ${WITH_MOZILLA}=="mozilla-devel"
HEADERS_SUFX= -devel
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk1"
-HEADERS_SUFX= -devel-gtk1
-CONFIGURE_ARGS+= --disable-gtk2 \
- --enable-gtk1
-.else
-.if ${WITH_MOZILLA}=="firefox"
-CONFIGURE_ENV+= PKG_CONFIG_PATH=${X11BASE}/lib/firefox/lib/pkgconfig
-.else
-HEADERS_SUFX= -gtk1
-CONFIGURE_ARGS+= --disable-gtk2 \
- --enable-gtk1
-.endif
-.endif
+HEADERS_SUFX=
.endif
.endif
.endif
@@ -69,8 +57,6 @@ pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} " firefox "
@${ECHO_MSG} " mozilla-devel "
- @${ECHO_MSG} " mozilla-gtk1 "
- @${ECHO_MSG} " mozilla-devel-gtk1 "
@${ECHO_MSG} ""
post-patch:
diff --git a/www/preferential-firefox/Makefile b/www/preferential-firefox/Makefile
index 7bf8caeb66ec..79720d4c60fb 100644
--- a/www/preferential-firefox/Makefile
+++ b/www/preferential-firefox/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= preferential
+POREREVISION= 2
#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
MAINTAINER= ports@FreeBSD.org
diff --git a/www/preferential/Makefile b/www/preferential/Makefile
index b28fde291cd8..62d30ba8c318 100644
--- a/www/preferential/Makefile
+++ b/www/preferential/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= preferential
PORTVERSION= 0.6.1a
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= www
MASTER_SITES= http://downloads.mozdev.org/preferential/versions/ \
http://mozdev.mirrors.nyphp.org/preferential/versions/
diff --git a/www/xpi-mozex/Makefile b/www/xpi-mozex/Makefile
index 0e81705fa715..093604488d92 100644
--- a/www/xpi-mozex/Makefile
+++ b/www/xpi-mozex/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= mozex
+PORTREVISION= 2
#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
MAINTAINER= ports@FreeBSD.org
diff --git a/www/xpi-preferential/Makefile b/www/xpi-preferential/Makefile
index 7bf8caeb66ec..79720d4c60fb 100644
--- a/www/xpi-preferential/Makefile
+++ b/www/xpi-preferential/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= preferential
+POREREVISION= 2
#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
MAINTAINER= ports@FreeBSD.org