aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-05-19 00:46:07 +0800
committernovel <novel@FreeBSD.org>2005-05-19 00:46:07 +0800
commit611dd95f0de7b4dadd445fde40f1c79b70bc78d9 (patch)
tree4e1da3bb9775adae6f6f7dee71c978e53db0b396
parent08e438fa690fc53a442a92c7f966076a78c507ac (diff)
downloadfreebsd-ports-gnome-611dd95f0de7b4dadd445fde40f1c79b70bc78d9.tar.gz
freebsd-ports-gnome-611dd95f0de7b4dadd445fde40f1c79b70bc78d9.tar.zst
freebsd-ports-gnome-611dd95f0de7b4dadd445fde40f1c79b70bc78d9.zip
Add misc/bdelta - an advanced delta creator, patcher, and library.
-rw-r--r--misc/Makefile1
-rw-r--r--misc/bdelta/Makefile28
-rw-r--r--misc/bdelta/distinfo2
-rw-r--r--misc/bdelta/pkg-descr1
4 files changed, 32 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 03a96cb6756a..907871b80aa6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -20,6 +20,7 @@
SUBDIR += astrolog
SUBDIR += bb
SUBDIR += bbjd
+ SUBDIR += bdelta
SUBDIR += bestfit
SUBDIR += bibletime
SUBDIR += bidwatcher
diff --git a/misc/bdelta/Makefile b/misc/bdelta/Makefile
new file mode 100644
index 000000000000..275bac96cd1b
--- /dev/null
+++ b/misc/bdelta/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bdelta
+# Date created: 2005-05-18
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bdelta
+PORTVERSION= 0.1.0
+CATEGORIES= misc devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= deltup
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= An advanced delta creator, patcher, and library
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+PLIST_FILES= bin/bdelta \
+ bin/bpatch \
+ lib/libbdelta.so
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bdelta ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bpatch ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libbdelta.so ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/misc/bdelta/distinfo b/misc/bdelta/distinfo
new file mode 100644
index 000000000000..adda0a751c01
--- /dev/null
+++ b/misc/bdelta/distinfo
@@ -0,0 +1,2 @@
+MD5 (bdelta-0.1.0.tar.gz) = db7db68664de8d30efc10edd2ee7f46f
+SIZE (bdelta-0.1.0.tar.gz) = 7418
diff --git a/misc/bdelta/pkg-descr b/misc/bdelta/pkg-descr
new file mode 100644
index 000000000000..e44737d00d3a
--- /dev/null
+++ b/misc/bdelta/pkg-descr
@@ -0,0 +1 @@
+BDelta is an advanced delta creator, patcher, and library.