aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-07-13 08:17:04 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2016-07-13 08:17:04 +0800
commit6132b99f9a06af00e0701c32fd67d8aa6c8fd99a (patch)
treee0ebd00ee1fc4b98f4c5d8b0998d2b39ab758522
parent2e94d74398005d20988d71e5e7a4c94e604b1cd2 (diff)
downloadfreebsd-ports-gnome-6132b99f9a06af00e0701c32fd67d8aa6c8fd99a.tar.gz
freebsd-ports-gnome-6132b99f9a06af00e0701c32fd67d8aa6c8fd99a.tar.zst
freebsd-ports-gnome-6132b99f9a06af00e0701c32fd67d8aa6c8fd99a.zip
Upgrade from 1.11.1 to 1.11.2.
<ChangeLog> *) Change: now nginx always uses internal MD5 and SHA1 implementations; the --with-md5 and --with-sha1 configure options were canceled. *) Feature: variables support in the stream module. *) Feature: the ngx_stream_map_module. *) Feature: the ngx_stream_return_module. *) Feature: a port can be specified in the "proxy_bind", "fastcgi_bind", "memcached_bind", "scgi_bind", and "uwsgi_bind" directives. *) Feature: now nginx uses the IP_BIND_ADDRESS_NO_PORT socket option when available. *) Bugfix: a segmentation fault might occur in a worker process when using HTTP/2 and the "proxy_request_buffering" directive. *) Bugfix: the "Content-Length" request header line was always added to requests passed to backends, including requests without body, when using HTTP/2. *) Bugfix: "http request count is zero" alerts might appear in logs when using HTTP/2. *) Bugfix: unnecessary buffering might occur when using the "sub_filter" directive; the issue had appeared in 1.9.4. </ChangeLog>
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_sticky_misc.c17
3 files changed, 24 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 88f2a9acca4e..16f8334353ad 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
-PORTVERSION= 1.11.1
+PORTVERSION= 1.11.2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -325,6 +325,7 @@ NGINX_ACCESSKEY_VERSION= 2.0.3
MASTER_SITES+= LOCAL/osa:accesskey
DISTFILES+= nginx-accesskey-${NGINX_ACCESSKEY_VERSION}.tar.gz:accesskey
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_VERSION}
+IGNORE= ACCESSKEY: a patch requires
.endif
.if ${PORT_OPTIONS:MHTTP_ADDITION}
@@ -659,6 +660,7 @@ GH_ACCOUNT+= vkholodkov:upload
GH_PROJECT+= nginx-upload-module:upload
GH_TAGNAME+= ${GIT_UPLOAD_VERSION}:upload
CONFIGURE_ARGS+=--add-module=${WRKSRC_upload}
+IGNORE= HTTP_UPLOAD: a patch requires
.endif
.if ${PORT_OPTIONS:MHTTP_UPLOAD_PROGRESS}
@@ -699,6 +701,7 @@ NGINX_UPSTREAM_STICKY_VERSION= 1.2.4
MASTER_SITES+= https://bitbucket.org/nginx-goodies/nginx-sticky-module-ng/get/:upstreamsticky
DISTFILES+= ${NGINX_UPSTREAM_STICKY_VERSION}.tar.gz:upstreamsticky
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-goodies-nginx-sticky-module-ng-c825ea7c5c91/
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sticky_misc.c
.endif
.if ${PORT_OPTIONS:MHTTP_VIDEO_THUMBEXTRACTOR}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 23c444eb04fc..60f242aa3966 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1464999596
-SHA256 (nginx-1.11.1.tar.gz) = 5d8dd0197e3ffeb427729c045382182fb28db8e045c635221b2e0e6722821ad0
-SIZE (nginx-1.11.1.tar.gz) = 913417
+TIMESTAMP = 1467754266
+SHA256 (nginx-1.11.2.tar.gz) = a0327be3e647bdc4a1b3ef98946a8e8fbf258ce8da6bed9a94222b249ae2700a
+SIZE (nginx-1.11.2.tar.gz) = 924979
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
SHA256 (ngx_http_auth_pam_module-1.2.tar.gz) = 5a85970ba61a99f55a26d2536a11d512b39bbd622f5737d25a9a8c10db81efa9
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_sticky_misc.c b/www/nginx-devel/files/extra-patch-ngx_http_sticky_misc.c
new file mode 100644
index 000000000000..4683d9dcd3a6
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_sticky_misc.c
@@ -0,0 +1,17 @@
+--- ../nginx-goodies-nginx-sticky-module-ng-c825ea7c5c91/ngx_http_sticky_misc.c.orig 2016-07-10 11:39:07.943834000 -0400
++++ ../nginx-goodies-nginx-sticky-module-ng-c825ea7c5c91/ngx_http_sticky_misc.c 2016-07-10 11:43:05.601078000 -0400
+@@ -12,6 +12,14 @@
+
+ #include "ngx_http_sticky_misc.h"
+
++#ifndef MD5_DIGEST_LENGTH
++ #define MD5_DIGEST_LENGTH 16
++#endif
++#ifndef MD5_CBLOCK
++ #define MD5_CBLOCK 64
++#endif
++
++
+ #ifndef ngx_str_set
+ #define ngx_str_set(str, text) (str)->len = sizeof(text) - 1; (str)->data = (u_char *) text
+ #endif