aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-15 21:01:56 +0800
committeredwin <edwin@FreeBSD.org>2004-12-15 21:01:56 +0800
commit61421aa5f8767f2c5249b485b1c6cfd60ac16b1b (patch)
tree93ef133ed34a821c02b4288cf4bc8b68a031f272
parent7cb22dc5b9383476e7642aef5c3afd5cdf53171b (diff)
downloadfreebsd-ports-gnome-61421aa5f8767f2c5249b485b1c6cfd60ac16b1b.tar.gz
freebsd-ports-gnome-61421aa5f8767f2c5249b485b1c6cfd60ac16b1b.tar.zst
freebsd-ports-gnome-61421aa5f8767f2c5249b485b1c6cfd60ac16b1b.zip
New port: graphics/linux-panorama-tools - another program to mount panoramic images - also a dependency of hugin
Software to View, Create, Edit and Remap Panoramic Images : * PTStitcher: High quality, simple to use, all format stitching software. * Panorama Tools: Photoshop plug-in for panorama creation, editing and remapping. * PTViewer: High quality spherical viewer, Standalone and java versions for many platforms. This port uses only PTStitcher as a dependency for hugin. PR: ports/71848 Submitted by: Carlos Eduardo G. Carvalho <cartola@openit.com.br>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-panorama-tools/Makefile44
-rw-r--r--graphics/linux-panorama-tools/distinfo2
-rw-r--r--graphics/linux-panorama-tools/pkg-descr15
-rw-r--r--graphics/linux-panorama-tools/pkg-plist6
5 files changed, 68 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7b7c4a7abd35..6668fa2fa8b8 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -280,6 +280,7 @@
SUBDIR += linux-imlib
SUBDIR += linux-jpeg
SUBDIR += linux-libmng
+ SUBDIR += linux-panorama-tools
SUBDIR += linux-png
SUBDIR += linux-png10
SUBDIR += linux-tiff
diff --git a/graphics/linux-panorama-tools/Makefile b/graphics/linux-panorama-tools/Makefile
new file mode 100644
index 000000000000..8ccd9566679b
--- /dev/null
+++ b/graphics/linux-panorama-tools/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: linux-panorama-tools
+# Date created: 26 august 2004
+# Whom: cartola (Carlos E. G. Carvalho)
+#
+# $FreeBSD$
+#
+# This port has been made as a running dependence for the hugin port.
+# The hugin port for itself would run with no problem without this port,
+# but the final step that generates the panorama images make use of the
+# external program PTStitcher, installed by this port.
+# This port, as a dependence, does not install the complete linux
+# panorama tools, just the few things necessary to hugin. If someone
+# wants the rest just tell me.
+
+PORTNAME= linux-panorama-tools
+PORTVERSION= 2.6b1
+CATEGORIES= graphics
+MASTER_SITES= http://www.path.unimelb.edu.au/~dersch/
+DISTNAME= PanoTools
+
+MAINTAINER= cartola@openit.com.br
+COMMENT= Software to View, Create, Edit and Remap Panoramic Images
+
+RUN_DEPENDS= ${LINUXBASE}/usr/bin/jpegtran:${PORTSDIR}/graphics/linux-jpeg \
+ ${LINUXBASE}/usr/bin/tiffcmp:${PORTSDIR}/graphics/linux-tiff \
+ ${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png
+
+USE_LINUX= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/PTLinux
+PROGRAM= Helpers/PTStitcher
+
+do-install:
+ ${MKDIR} ${PREFIX}/${PORTNAME}/lib
+ ${MKDIR} ${PREFIX}/${PORTNAME}/bin
+ ${CP} ${WRKSRC}/${PROGRAM} ${PREFIX}/${PORTNAME}/bin
+ ${CHMOD} 555 ${PREFIX}/${PORTNAME}/bin/PTStitcher
+ ${CP} ${WRKSRC}/libpano12.so ${PREFIX}/${PORTNAME}/lib
+ ${CHMOD} 555 ${PREFIX}/${PORTNAME}/lib/libpano12.so
+ ${LN} -s ${PREFIX}/${PORTNAME}/bin/PTStitcher ${PREFIX}/bin/PTStitcher
+ ${LINUXBASE}/sbin/ldconfig ${PREFIX}/${PORTNAME}/lib/
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-panorama-tools/distinfo b/graphics/linux-panorama-tools/distinfo
new file mode 100644
index 000000000000..524c6cda4b98
--- /dev/null
+++ b/graphics/linux-panorama-tools/distinfo
@@ -0,0 +1,2 @@
+MD5 (PanoTools.tar.gz) = 0e3a75d81027d9a404411b5c8cdbf445
+SIZE (PanoTools.tar.gz) = 516217
diff --git a/graphics/linux-panorama-tools/pkg-descr b/graphics/linux-panorama-tools/pkg-descr
new file mode 100644
index 000000000000..1246178f4527
--- /dev/null
+++ b/graphics/linux-panorama-tools/pkg-descr
@@ -0,0 +1,15 @@
+Software to View, Create, Edit and Remap Panoramic Images :
+
+
+* PTStitcher: High quality, simple to use, all format stitching software.
+* Panorama Tools: Photoshop plug-in for panorama creation, editing and
+ remapping.
+* PTViewer: High quality spherical viewer, Standalone and java versions
+ for many platforms.
+
+This port uses only PTStitcher as a dependency for hugin.
+
+WWW: http://www.path.unimelb.edu.au/~dersch/
+
+- Ported by Cartola
+cartola@openit.com.br
diff --git a/graphics/linux-panorama-tools/pkg-plist b/graphics/linux-panorama-tools/pkg-plist
new file mode 100644
index 000000000000..04c497cd3a21
--- /dev/null
+++ b/graphics/linux-panorama-tools/pkg-plist
@@ -0,0 +1,6 @@
+bin/PTStitcher
+linux-panorama-tools/bin/PTStitcher
+linux-panorama-tools/lib/libpano12.so
+@dirrm linux-panorama-tools/bin
+@dirrm linux-panorama-tools/lib
+@dirrm linux-panorama-tools