aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2014-11-19 20:38:24 +0800
committerlme <lme@FreeBSD.org>2014-11-19 20:38:24 +0800
commit61c3d95c05438c7276b46d020007b7ddfeca4af8 (patch)
tree255381eedc88889a82a1e07c2609e8b87d246d61
parentf0b7aac9af1a793cc184bd447e77de1aca3e8858 (diff)
downloadfreebsd-ports-gnome-61c3d95c05438c7276b46d020007b7ddfeca4af8.tar.gz
freebsd-ports-gnome-61c3d95c05438c7276b46d020007b7ddfeca4af8.tar.zst
freebsd-ports-gnome-61c3d95c05438c7276b46d020007b7ddfeca4af8.zip
Update to 2.2.0
-rw-r--r--net-mgmt/icinga2/Makefile36
-rw-r--r--net-mgmt/icinga2/distinfo4
-rw-r--r--net-mgmt/icinga2/files/icinga2.in4
-rw-r--r--net-mgmt/icinga2/files/patch-CMakeLists.txt12
-rw-r--r--net-mgmt/icinga2/files/patch-components__CMakeLists.txt19
-rw-r--r--net-mgmt/icinga2/files/patch-components__db_ido_mysql__CMakeLists.txt9
-rw-r--r--net-mgmt/icinga2/files/patch-components__db_ido_pgsql__CMakeLists.txt9
-rw-r--r--net-mgmt/icinga2/files/patch-etc_CMakeLists.txt79
-rw-r--r--net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake11
-rw-r--r--net-mgmt/icinga2/pkg-plist132
10 files changed, 144 insertions, 171 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 4d96d832b05a..05a33859273e 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= icinga2
-DISTVERSION= 2.1.1
-PORTREVISION= 3
+DISTVERSION= 2.2.0
CATEGORIES= net-mgmt
MASTER_SITES= http://github.com/Icinga/${PORTNAME}/archive/v${DISTVERSION}.tar.gz?dummy=/
@@ -11,29 +10,29 @@ COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:${PORTSDIR}/devel/py-setuptools${PYTHON_SUFFIX}
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libyajl.so:${PORTSDIR}/devel/yajl \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo # for better debugging
RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-USES= alias bison cmake python
+USES= alias bison cmake
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= MYSQL PGSQL
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
-OPTIONS_DEFAULT= MYSQL PGSQL MONPLUGINS EXAMPLES
+OPTIONS_DEFAULT= MYSQL PGSQL MONPLUGINS
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/monitoring-plugins
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
-MYSQL_CMAKE_ON= -DWITH_MYSQL:BOOL=true
-PGSQL_CMAKE_ON= -DWITH_PGSQL:BOOL=true
+MYSQL_CMAKE_ON= -DICINGA2_WITH_MYSQL:BOOL=true
+PGSQL_CMAKE_ON= -DICINGA2_WITH_PGSQL:BOOL=true
ICINGA2USER?= icinga
ICINGA2GROUP?= icinga
@@ -58,7 +57,7 @@ SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
WWWGRP=${WWWGRP}
# Config files with references to "Linux"
-LINUX_CONFIG= groups.conf services.conf hosts/localhost.conf
+LINUX_CONFIG= groups.conf services.conf hosts.conf
MYSQL_USE= mysql=yes
PGSQL_USES= pgsql
@@ -73,24 +72,13 @@ CXXFLAGS+= -I${LOCALBASE}/include/flex
.endif
post-patch:
- ${REINPLACE_CMD} -e '/^add_subdirectory(initsystem)/d' \
- -e '/logrotate\.d/d' ${WRKSRC}/etc/CMakeLists.txt
.for f in ${LINUX_CONFIG}
${REINPLACE_CMD} 's,[Ll]inux,FreeBSD,g' ${WRKSRC}/etc/icinga2/conf.d/${f}
.endfor
-.if !${PORT_OPTIONS:MMYSQL}
- ${REINPLACE_CMD} '/^add_subdirectory(db_ido_mysql)/d' ${WRKSRC}/components/CMakeLists.txt
-.endif
-.if !${PORT_OPTIONS:MMYSQL}
- ${REINPLACE_CMD} '/^add_subdirectory(db_ido_pgsql)/d' ${WRKSRC}/components/CMakeLists.txt
-.endif
-post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
-.for db in mysql pgsql
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${db}
- (cd ${WRKSRC}/components/db_ido_${db} && ${COPYTREE_SHARE} schema ${STAGEDIR}${EXAMPLESDIR}/${db})
-.endfor
-.endif
+pre-install:
+ ${FIND} ${WRKSRC}/etc -type f -name "*.conf" -exec ${MV} {} {}.sample \;
+ ${FIND} ${WRKSRC}/etc/icinga2/scripts -type f -name "*.sh" \
+ -exec ${MV} {} {}.sample \;
.include <bsd.port.mk>
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index b874d9d864b3..a3d0dadfbf79 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga2-2.1.1.tar.gz) = 57755272a32f6286632f07153225bb066cae07affe8731d4628cef7695de74a2
-SIZE (icinga2-2.1.1.tar.gz) = 574595
+SHA256 (icinga2-2.2.0.tar.gz) = a42923a1dc20b84ab2692d27f4c5e6c85ebbdb869668931fce3ffdeceee2b07e
+SIZE (icinga2-2.2.0.tar.gz) = 679413
diff --git a/net-mgmt/icinga2/files/icinga2.in b/net-mgmt/icinga2/files/icinga2.in
index d87313107434..6aad8c28e7bd 100644
--- a/net-mgmt/icinga2/files/icinga2.in
+++ b/net-mgmt/icinga2/files/icinga2.in
@@ -52,7 +52,7 @@ configtest_cmd="${checkconfig_cmd}"
sig_reload=HUP
required_files="${icinga2_configfile}"
-command_args="-d -e ${icinga2_errorlogfile} -u ${icinga2_user} -g ${icinga2_group} -c ${icinga2_configfile}"
+command_args="daemon -d -e ${icinga2_errorlogfile} -c ${icinga2_configfile}"
icinga2_checkconfig() {
echo -n "Performing sanity check of icinga2 configuration: "
@@ -61,7 +61,7 @@ icinga2_checkconfig() {
quietredir="2>&1 >/dev/null"
fi
- ${command} -c ${icinga2_configfile} -C -u ${icinga2_user} -g ${icinga2_group}
+ ${command} daemon -c ${icinga2_configfile} -C
if [ $? -ne 0 ]; then
echo "FAILED"
diff --git a/net-mgmt/icinga2/files/patch-CMakeLists.txt b/net-mgmt/icinga2/files/patch-CMakeLists.txt
deleted file mode 100644
index b450b97eafdd..000000000000
--- a/net-mgmt/icinga2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- CMakeLists.txt.orig 2014-06-16 23:18:51.000000000 +0000
-+++ CMakeLists.txt 2014-06-16 23:19:01.000000000 +0000
-@@ -27,6 +27,9 @@
- FORCE)
- endif()
-
-+option(WITH_MYSQL "MySQL support" OFF)
-+option(WITH_PGSQL "PostgreSQL support" OFF)
-+
- file(STRINGS icinga2.spec VERSION_LINE REGEX "^Version: ")
- string(REPLACE "Version: " "" ICINGA2_VERSION ${VERSION_LINE})
-
diff --git a/net-mgmt/icinga2/files/patch-components__CMakeLists.txt b/net-mgmt/icinga2/files/patch-components__CMakeLists.txt
deleted file mode 100644
index 248fe4b11458..000000000000
--- a/net-mgmt/icinga2/files/patch-components__CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
---- components/CMakeLists.txt.orig 2014-06-16 23:20:12.000000000 +0000
-+++ components/CMakeLists.txt 2014-06-16 23:20:18.000000000 +0000
-@@ -1,7 +1,14 @@
- add_subdirectory(checker)
- add_subdirectory(compat)
--add_subdirectory(db_ido_mysql)
--add_subdirectory(db_ido_pgsql)
-+
-+if(WITH_MYSQL)
-+ add_subdirectory(db_ido_mysql)
-+endif()
-+
-+if(WITH_PGSQL)
-+ add_subdirectory(db_ido_pgsql)
-+endif()
-+
- add_subdirectory(demo)
- add_subdirectory(livestatus)
- add_subdirectory(notification)
diff --git a/net-mgmt/icinga2/files/patch-components__db_ido_mysql__CMakeLists.txt b/net-mgmt/icinga2/files/patch-components__db_ido_mysql__CMakeLists.txt
deleted file mode 100644
index b88cbc6011ad..000000000000
--- a/net-mgmt/icinga2/files/patch-components__db_ido_mysql__CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
---- components/db_ido_mysql/CMakeLists.txt.orig 2014-06-16 23:31:26.000000000 +0000
-+++ components/db_ido_mysql/CMakeLists.txt 2014-06-16 23:31:37.000000000 +0000
-@@ -38,4 +38,6 @@
- RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/icinga2
- )
-+else()
-+ message( FATAL_ERROR "You have selected MySQL support, but MySQL could not be found." )
- endif()
diff --git a/net-mgmt/icinga2/files/patch-components__db_ido_pgsql__CMakeLists.txt b/net-mgmt/icinga2/files/patch-components__db_ido_pgsql__CMakeLists.txt
deleted file mode 100644
index a404a017fa48..000000000000
--- a/net-mgmt/icinga2/files/patch-components__db_ido_pgsql__CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
---- components/db_ido_pgsql/CMakeLists.txt.orig 2014-06-16 23:27:15.000000000 +0000
-+++ components/db_ido_pgsql/CMakeLists.txt 2014-06-16 23:29:03.000000000 +0000
-@@ -40,4 +40,6 @@
- RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/icinga2
- )
-+else()
-+ message( FATAL_ERROR "You have selected PostgreSQL support, but PostgreSQL could not be found." )
- endif()
diff --git a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
new file mode 100644
index 000000000000..5239c4ade2ce
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
@@ -0,0 +1,79 @@
+--- etc/CMakeLists.txt.orig 2014-11-18 14:28:49 UTC
++++ etc/CMakeLists.txt
+@@ -23,43 +23,43 @@ configure_file(icinga2/constants.conf.cm
+
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ configure_file(logrotate.d/icinga2.cmake ${CMAKE_CURRENT_BINARY_DIR}/logrotate.d/icinga2 @ONLY)
++ install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/logrotate.d/icinga2 ${CMAKE_INSTALL_SYSCONFDIR}/logrotate.d)
+ endif()
+
+-install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/init.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+-install_if_not_exists(icinga2/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+-install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+-install_if_not_exists(icinga2/zones.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+-install_if_not_exists(icinga2/conf.d/commands.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/downtimes.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/groups.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/hosts.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/notifications.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/satellite.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/templates.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/timeperiods.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/conf.d/users.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/features-available/api.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/checker.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/command.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/compatlog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/debuglog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/gelf.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/graphite.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/icingastatus.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/ido-mysql.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/ido-pgsql.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/livestatus.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/mainlog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/notification.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/perfdata.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/statusdata.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/features-available/syslog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/scripts/mail-host-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
+-install_if_not_exists(icinga2/scripts/mail-service-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
++install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/init.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
++install_if_not_exists(icinga2/icinga2.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
++install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
++install_if_not_exists(icinga2/zones.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
++install_if_not_exists(icinga2/conf.d/commands.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/downtimes.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/groups.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/hosts.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/notifications.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/satellite.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/services.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/templates.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/timeperiods.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/conf.d/users.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
++install_if_not_exists(icinga2/features-available/api.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/checker.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/command.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/compatlog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/debuglog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/gelf.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/graphite.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/icingastatus.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/ido-mysql.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/ido-pgsql.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/livestatus.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/mainlog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/notification.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/perfdata.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/statusdata.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/features-available/syslog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
++install_if_not_exists(icinga2/scripts/mail-host-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
++install_if_not_exists(icinga2/scripts/mail-service-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
+ install_if_not_exists(icinga2/zones.d/README ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/zones.d)
+ install_if_not_exists(icinga2/repository.d/README ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/repository.d)
+-install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/logrotate.d/icinga2 ${CMAKE_INSTALL_SYSCONFDIR}/logrotate.d)
+
+ install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}${CMAKE_INSTALL_FULL_SYSCONFDIR}/icinga2/pki\")")
+ install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}${CMAKE_INSTALL_FULL_SYSCONFDIR}/icinga2/repository.d\")")
diff --git a/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake b/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake
deleted file mode 100644
index 584a7e62ccc8..000000000000
--- a/net-mgmt/icinga2/files/patch-third-party__cmake__GNUInstallDirs.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- third-party/cmake/GNUInstallDirs.cmake.orig 2014-10-03 15:04:47.712808574 +0200
-+++ third-party/cmake/GNUInstallDirs.cmake 2014-10-03 15:05:17.916805737 +0200
-@@ -166,7 +166,7 @@
- set(CMAKE_INSTALL_DATADIR "${CMAKE_INSTALL_DATAROOTDIR}")
- endif()
-
--if(CMAKE_SYSTEM_NAME STREQUAL "OpenBSD")
-+if(CMAKE_SYSTEM_NAME MATCHES "^(DragonFly|FreeBSD|OpenBSD)$")
- if(NOT CMAKE_INSTALL_INFODIR)
- set(CMAKE_INSTALL_INFODIR "" CACHE PATH "info documentation (info)")
- set(CMAKE_INSTALL_INFODIR "info")
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index b5b5fb92891f..5b8a1034c2f1 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -1,50 +1,44 @@
-bin/icinga2-build-ca
-bin/icinga2-build-key
-bin/icinga2-sign-key
-%%ETCDIR%%/conf.d/commands.conf
-%%ETCDIR%%/conf.d/downtimes.conf
-%%ETCDIR%%/conf.d/groups.conf
-%%ETCDIR%%/conf.d/hosts/localhost.conf
-%%ETCDIR%%/conf.d/hosts/localhost/disk.conf
-%%ETCDIR%%/conf.d/hosts/localhost/http.conf
-%%ETCDIR%%/conf.d/hosts/localhost/icinga.conf
-%%ETCDIR%%/conf.d/hosts/localhost/load.conf
-%%ETCDIR%%/conf.d/hosts/localhost/procs.conf
-%%ETCDIR%%/conf.d/hosts/localhost/ssh.conf
-%%ETCDIR%%/conf.d/hosts/localhost/swap.conf
-%%ETCDIR%%/conf.d/hosts/localhost/users.conf
-%%ETCDIR%%/conf.d/notifications.conf
-%%ETCDIR%%/conf.d/services.conf
-%%ETCDIR%%/conf.d/templates.conf
-%%ETCDIR%%/conf.d/timeperiods.conf
-%%ETCDIR%%/conf.d/users.conf
-%%ETCDIR%%/constants.conf
-%%ETCDIR%%/features-available/api.conf
-%%ETCDIR%%/features-available/checker.conf
-%%ETCDIR%%/features-available/command.conf
-%%ETCDIR%%/features-available/compatlog.conf
-%%ETCDIR%%/features-available/debuglog.conf
-%%ETCDIR%%/features-available/graphite.conf
-%%ETCDIR%%/features-available/icingastatus.conf
-%%ETCDIR%%/features-available/livestatus.conf
-%%ETCDIR%%/features-available/mainlog.conf
-%%ETCDIR%%/features-available/notification.conf
-%%ETCDIR%%/features-available/perfdata.conf
-%%ETCDIR%%/features-available/statusdata.conf
-%%ETCDIR%%/features-available/syslog.conf
+etc/bash_completion.d/icinga2
+@sample %%ETCDIR%%/conf.d/commands.conf.sample
+@sample %%ETCDIR%%/conf.d/downtimes.conf.sample
+@sample %%ETCDIR%%/conf.d/groups.conf.sample
+@sample %%ETCDIR%%/conf.d/hosts.conf.sample
+@sample %%ETCDIR%%/conf.d/notifications.conf.sample
+@sample %%ETCDIR%%/conf.d/satellite.conf.sample
+@sample %%ETCDIR%%/conf.d/services.conf.sample
+@sample %%ETCDIR%%/conf.d/templates.conf.sample
+@sample %%ETCDIR%%/conf.d/timeperiods.conf.sample
+@sample %%ETCDIR%%/conf.d/users.conf.sample
+@sample %%ETCDIR%%/constants.conf.sample
+@sample %%ETCDIR%%/features-available/api.conf.sample
+@sample %%ETCDIR%%/features-available/checker.conf.sample
+@sample %%ETCDIR%%/features-available/command.conf.sample
+@sample %%ETCDIR%%/features-available/compatlog.conf.sample
+@sample %%ETCDIR%%/features-available/debuglog.conf.sample
+@sample %%ETCDIR%%/features-available/gelf.conf.sample
+@sample %%ETCDIR%%/features-available/graphite.conf.sample
+@sample %%ETCDIR%%/features-available/icingastatus.conf.sample
+@sample(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-mysql.conf.sample
+@sample(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-pgsql.conf.sample
+@sample %%ETCDIR%%/features-available/livestatus.conf.sample
+@sample %%ETCDIR%%/features-available/mainlog.conf.sample
+@sample %%ETCDIR%%/features-available/notification.conf.sample
+@sample %%ETCDIR%%/features-available/perfdata.conf.sample
+@sample %%ETCDIR%%/features-available/statusdata.conf.sample
+@sample %%ETCDIR%%/features-available/syslog.conf.sample
%%ETCDIR%%/features-enabled/checker.conf
%%ETCDIR%%/features-enabled/mainlog.conf
%%ETCDIR%%/features-enabled/notification.conf
-@(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-mysql.conf
-@(icinga,icinga,0640) %%ETCDIR%%/features-available/ido-pgsql.conf
-%%ETCDIR%%/icinga2.conf
-%%ETCDIR%%/scripts/mail-host-notification.sh
-%%ETCDIR%%/scripts/mail-service-notification.sh
-%%ETCDIR%%/zones.conf
+@sample %%ETCDIR%%/icinga2.conf.sample
+@sample %%ETCDIR%%/init.conf.sample
+%%ETCDIR%%/repository.d/README
+@sample %%ETCDIR%%/scripts/mail-host-notification.sh.sample
+@sample %%ETCDIR%%/scripts/mail-service-notification.sh.sample
+@sample %%ETCDIR%%/zones.conf.sample
%%ETCDIR%%/zones.d/README
lib/icinga2/libbase.so
-lib/icinga2/libcJSON.so
lib/icinga2/libchecker.so
+lib/icinga2/libcli.so
lib/icinga2/libcompat.so
lib/icinga2/libconfig.so
lib/icinga2/libdb_ido.so
@@ -60,36 +54,9 @@ lib/icinga2/libmmatch.so
lib/icinga2/libnotification.so
lib/icinga2/libperfdata.so
lib/icinga2/libremote.so
-%%PYTHON_SITELIBDIR%%/icinga2-2.1.1-py%%PYTHON_VER%%.egg-info/PKG-INFO
-%%PYTHON_SITELIBDIR%%/icinga2-2.1.1-py%%PYTHON_VER%%.egg-info/SOURCES.txt
-%%PYTHON_SITELIBDIR%%/icinga2-2.1.1-py%%PYTHON_VER%%.egg-info/dependency_links.txt
-%%PYTHON_SITELIBDIR%%/icinga2-2.1.1-py%%PYTHON_VER%%.egg-info/entry_points.txt
-%%PYTHON_SITELIBDIR%%/icinga2-2.1.1-py%%PYTHON_VER%%.egg-info/top_level.txt
-%%PYTHON_SITELIBDIR%%/icinga2/__init__.py
-%%PYTHON_SITELIBDIR%%/icinga2/__init__.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/commands/__init__.py
-%%PYTHON_SITELIBDIR%%/icinga2/commands/__init__.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/commands/list_objects.py
-%%PYTHON_SITELIBDIR%%/icinga2/commands/list_objects.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/config.py
-%%PYTHON_SITELIBDIR%%/icinga2/config.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/utils/__init__.py
-%%PYTHON_SITELIBDIR%%/icinga2/utils/__init__.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/utils/debug.py
-%%PYTHON_SITELIBDIR%%/icinga2/utils/debug.pyc
-%%PYTHON_SITELIBDIR%%/icinga2/utils/netstring.py
-%%PYTHON_SITELIBDIR%%/icinga2/utils/netstring.pyc
-man/man8/icinga2-build-ca.8.gz
-man/man8/icinga2-build-key.8.gz
-man/man8/icinga2-disable-feature.8.gz
-man/man8/icinga2-enable-feature.8.gz
man/man8/icinga2-prepare-dirs.8.gz
-man/man8/icinga2-sign-key.8.gz
man/man8/icinga2.8.gz
sbin/icinga2
-sbin/icinga2-disable-feature
-sbin/icinga2-enable-feature
-sbin/icinga2-list-objects
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/COPYING.Exceptions
@@ -98,19 +65,21 @@ sbin/icinga2-list-objects
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/1-about.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/2-getting-started.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/3-monitoring-basics.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/4-monitoring-remote-systems.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/5-addons-plugins.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/6-configuring-icinga-2.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/7-troubleshooting.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/3-troubleshooting.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/4-monitoring-basics.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/5-monitoring-remote-systems.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/6-addons-plugins.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/7-configuring-icinga-2.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/8-migration.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/9-appendix.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/schema/mysql.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/schema/upgrade/2.0.2.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/schema/upgrade/2.1.0.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/schema/pgsql.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/schema/upgrade/2.0.2.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/schema/upgrade/2.1.0.sql
+%%DATADIR%%-ido-mysql/schema/mysql.sql
+%%DATADIR%%-ido-mysql/schema/upgrade/2.0.2.sql
+%%DATADIR%%-ido-mysql/schema/upgrade/2.1.0.sql
+%%DATADIR%%-ido-mysql/schema/upgrade/2.2.0.sql
+%%DATADIR%%-ido-pgsql/schema/pgsql.sql
+%%DATADIR%%-ido-pgsql/schema/upgrade/2.0.2.sql
+%%DATADIR%%-ido-pgsql/schema/upgrade/2.1.0.sql
+%%DATADIR%%-ido-pgsql/schema/upgrade/2.2.0.sql
%%DATADIR%%/include/command-icinga.conf
%%DATADIR%%/include/command-plugins-manubulon.conf
%%DATADIR%%/include/command-plugins.conf
@@ -119,10 +88,7 @@ sbin/icinga2-list-objects
%%DATADIR%%/include/manubulon
%%DATADIR%%/include/plugins
%%DATADIR%%/include/timeperiod.conf
-%%DATADIR%%/pki/openssl-quiet.cnf
-%%DATADIR%%/pki/openssl.cnf
-%%DATADIR%%/pki/pkifuncs
-%%DATADIR%%/pki/vars
+@dir %%ETCDIR%%/pki
@dir /var/cache/icinga2
@dir /var/lib/icinga2/api/log
@dir /var/lib/icinga2/api/repository