aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-08-27 09:50:15 +0800
committerclsung <clsung@FreeBSD.org>2007-08-27 09:50:15 +0800
commit61e6e1f499c9593011535278c52971ee5d519054 (patch)
tree8a05cd645001c030c8bbc41f2aee4003aed0aabc
parent886db5b5ceafde09f27b4f3f1a45781de3c26c44 (diff)
downloadfreebsd-ports-gnome-61e6e1f499c9593011535278c52971ee5d519054.tar.gz
freebsd-ports-gnome-61e6e1f499c9593011535278c52971ee5d519054.tar.zst
freebsd-ports-gnome-61e6e1f499c9593011535278c52971ee5d519054.zip
This module can be used to test that you're logging the right
thing with Log::Log4perl. It checks that we get what, and only what, we expect logged by your code. WWW: http://search.cpan.org/dist/Test-Log4perl/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Log4perl/Makefile33
-rw-r--r--devel/p5-Test-Log4perl/distinfo3
-rw-r--r--devel/p5-Test-Log4perl/pkg-descr5
-rw-r--r--devel/p5-Test-Log4perl/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f54279fca241..1a5591f1b60f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1559,6 +1559,7 @@
SUBDIR += p5-Test-Inline
SUBDIR += p5-Test-JSON
SUBDIR += p5-Test-LectroTest
+ SUBDIR += p5-Test-Log4perl
SUBDIR += p5-Test-LongString
SUBDIR += p5-Test-Manifest
SUBDIR += p5-Test-MockModule
diff --git a/devel/p5-Test-Log4perl/Makefile b/devel/p5-Test-Log4perl/Makefile
new file mode 100644
index 000000000000..c7e395e18675
--- /dev/null
+++ b/devel/p5-Test-Log4perl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Test-Log4perl
+# Date created: August 27, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Log4perl
+PORTVERSION= 0.1001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Test::Log4perl - test Log::Log4perl
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Lingua/EN/Numbers/Ordinate.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Numbers-Ordinate \
+ ${SITE_PERL}/Class/Accessor/Chained.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Log4perl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Log4perl/distinfo b/devel/p5-Test-Log4perl/distinfo
new file mode 100644
index 000000000000..8e865ee644cb
--- /dev/null
+++ b/devel/p5-Test-Log4perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Log4perl-0.1001.tar.gz) = 0100dc0cab90bbcc476de9da29c59018
+SHA256 (Test-Log4perl-0.1001.tar.gz) = 4b0444bd849db5b246841a6109475725c46b7b6daa8a9a242d5ed6b7e1cc8e94
+SIZE (Test-Log4perl-0.1001.tar.gz) = 9394
diff --git a/devel/p5-Test-Log4perl/pkg-descr b/devel/p5-Test-Log4perl/pkg-descr
new file mode 100644
index 000000000000..c11cc7ed2b5e
--- /dev/null
+++ b/devel/p5-Test-Log4perl/pkg-descr
@@ -0,0 +1,5 @@
+This module can be used to test that you're logging the right
+thing with Log::Log4perl. It checks that we get what, and only
+what, we expect logged by your code.
+
+WWW: http://search.cpan.org/dist/Test-Log4perl/
diff --git a/devel/p5-Test-Log4perl/pkg-plist b/devel/p5-Test-Log4perl/pkg-plist
new file mode 100644
index 000000000000..5d917c52c5cd
--- /dev/null
+++ b/devel/p5-Test-Log4perl/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Log4perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Log4perl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Log4perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test