aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-08 20:50:20 +0800
committeredwin <edwin@FreeBSD.org>2006-01-08 20:50:20 +0800
commit6342b7f85c4e4bad9f387b1d081a01dc6806eec2 (patch)
treec1b58729c78a15a1fc28f86e3b2a0d2e0f7046f1
parentf43401d5d1b57679254edebc31feb062c256be46 (diff)
downloadfreebsd-ports-gnome-6342b7f85c4e4bad9f387b1d081a01dc6806eec2.tar.gz
freebsd-ports-gnome-6342b7f85c4e4bad9f387b1d081a01dc6806eec2.tar.zst
freebsd-ports-gnome-6342b7f85c4e4bad9f387b1d081a01dc6806eec2.zip
New port: devel/pecl-svn
PHP bindings to the libsvn library which provide access to subversion repositories. WWW: http://pecl.php.net/package/svn PR: ports/91471 Submitted by: Alex Kiesel <kiesel@schlund.de>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-svn/Makefile25
-rw-r--r--devel/pecl-svn/distinfo3
-rw-r--r--devel/pecl-svn/files/patch-config.m416
-rw-r--r--devel/pecl-svn/pkg-descr4
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6d170042a9ec..e1ade491c3e7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1309,6 +1309,7 @@
SUBDIR += pear-apd
SUBDIR += pecl-runkit
SUBDIR += pecl-statgrab
+ SUBDIR += pecl-svn
SUBDIR += pedisassem
SUBDIR += perforce
SUBDIR += perltidy
diff --git a/devel/pecl-svn/Makefile b/devel/pecl-svn/Makefile
new file mode 100644
index 000000000000..6e5282de667e
--- /dev/null
+++ b/devel/pecl-svn/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pecl-ssh2
+# Date created: 20051220
+# Whom: Alex Kiesel <kiesel@schlund.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= svn
+PORTVERSION= 0.1
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= svn-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A PECL extension to the libsvn library
+
+LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-svn/distinfo b/devel/pecl-svn/distinfo
new file mode 100644
index 000000000000..bdb9d0b74810
--- /dev/null
+++ b/devel/pecl-svn/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/svn-0.1.tgz) = c5b4e16a224ffeafae0bc4cc71f08e63
+SHA256 (PECL/svn-0.1.tgz) = fb4f9b56cdd31f679921f94bdc9a63976d4695108a1150ceb53ab06402460547
+SIZE (PECL/svn-0.1.tgz) = 14801
diff --git a/devel/pecl-svn/files/patch-config.m4 b/devel/pecl-svn/files/patch-config.m4
new file mode 100644
index 000000000000..fe4bf149e69b
--- /dev/null
+++ b/devel/pecl-svn/files/patch-config.m4
@@ -0,0 +1,16 @@
+--- config.m4 Sat Jan 7 19:58:52 2006
++++ config.m4.new Sat Jan 7 20:00:55 2006
+@@ -36,10 +36,10 @@
+ if test -d $i/lib64 ; then
+ PHP_SVN_LDFLAGS="-L$i/lib64 $PHP_SVN_LDFLAGS"
+ fi
+- PHP_SVN_LDFLAGS="$PHP_SVN_LDFLAGS -lsvn_client-1 -lapr-0"
++ PHP_SVN_LDFLAGS="$PHP_SVN_LDFLAGS -lsvn_client-1 -lapr-1"
+ fi
+- if test -r $i/include/apr-0/apr.h ; then
+- PHP_SVN_INCLUDES="$PHP_SVN_INCLUDES -I$i/include/apr-0"
++ if test -r $i/include/apr-1/apr.h ; then
++ PHP_SVN_INCLUDES="$PHP_SVN_INCLUDES -I$i/include/apr-1"
+ elif test -r $i/include/apache2/apr.h ; then
+ PHP_SVN_INCLUDES="$PHP_SVN_INCLUDES -I$i/include/apache2"
+ fi
diff --git a/devel/pecl-svn/pkg-descr b/devel/pecl-svn/pkg-descr
new file mode 100644
index 000000000000..d2c7eb31d922
--- /dev/null
+++ b/devel/pecl-svn/pkg-descr
@@ -0,0 +1,4 @@
+PHP bindings to the libsvn library which provide access to subversion
+repositories.
+
+WWW: http://pecl.php.net/package/svn