aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-07-25 07:43:26 +0800
committergerald <gerald@FreeBSD.org>2015-07-25 07:43:26 +0800
commit63f2fdc7139d8fe8eb89fada7a806eb1b7837a8e (patch)
tree188fb3a64c69a0b7d22fa8a76b1067d72114233e
parente4ee8d88a5666a1b4e3b4a750883c512cb725d71 (diff)
downloadfreebsd-ports-gnome-63f2fdc7139d8fe8eb89fada7a806eb1b7837a8e.tar.gz
freebsd-ports-gnome-63f2fdc7139d8fe8eb89fada7a806eb1b7837a8e.tar.zst
freebsd-ports-gnome-63f2fdc7139d8fe8eb89fada7a806eb1b7837a8e.zip
Update from GCC 5.1 (the first release of GCC 5) to GCC 5.2.
This mostly brings bug fixes across teh board plus, thanks to andreast@, support for position independent code directly upstream, so we can remove files/patch-pie-support.
-rw-r--r--lang/gcc5/Makefile3
-rw-r--r--lang/gcc5/distinfo4
-rw-r--r--lang/gcc5/files/patch-pie-support73
3 files changed, 3 insertions, 77 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 5c4592a38281..227bbd5fe102 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 5.1.0
-PORTREVISION= 1
+PORTVERSION= 5.2.0
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
diff --git a/lang/gcc5/distinfo b/lang/gcc5/distinfo
index 760f6b2326c0..1adcf0a8f821 100644
--- a/lang/gcc5/distinfo
+++ b/lang/gcc5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-5.1.0.tar.bz2) = b7dafdf89cbb0e20333dbf5b5349319ae06e3d1a30bf3515b5488f7e89dca5ad
-SIZE (gcc-5.1.0.tar.bz2) = 94954411
+SHA256 (gcc-5.2.0.tar.bz2) = 5f835b04b5f7dd4f4d2dc96190ec1621b8d89f2dc6f638f9f8bc1b1014ba8cad
+SIZE (gcc-5.2.0.tar.bz2) = 95221552
diff --git a/lang/gcc5/files/patch-pie-support b/lang/gcc5/files/patch-pie-support
deleted file mode 100644
index 7fc70b40e715..000000000000
--- a/lang/gcc5/files/patch-pie-support
+++ /dev/null
@@ -1,73 +0,0 @@
---- gcc/config/freebsd-spec.h.orig 2015-01-05 13:33:28.000000000 +0100
-+++ gcc/config/freebsd-spec.h 2015-05-19 12:13:47.863772000 +0200
-@@ -66,8 +66,9 @@
- "%{!shared: \
- %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} \
- %{!p:%{profile:gcrt1.o%s} \
-- %{!profile:crt1.o%s}}}} \
-- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
-+ %{!profile: \
-+ %{pie: Scrt1.o%s;:crt1.o%s}}}}} \
-+ crti.o%s %{static:crtbeginT.o%s;shared|pie:crtbeginS.o%s;:crtbegin.o%s}"
-
- /* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
- the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -76,7 +77,7 @@
- `crtn.o'. */
-
- #define FBSD_ENDFILE_SPEC \
-- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
-+ "%{shared|pie:crtendS.o%s;:crtend.o%s} crtn.o%s"
-
- /* Provide a LIB_SPEC appropriate for FreeBSD as configured and as
- required by the user-land thread model. Before __FreeBSD_version
---- gcc/config/i386/freebsd.h.orig 2015-01-05 13:33:28.000000000 +0100
-+++ gcc/config/i386/freebsd.h 2015-05-19 12:13:47.865132000 +0200
-@@ -59,28 +59,15 @@
- #define SUBTARGET_EXTRA_SPECS \
- { "fbsd_dynamic_linker", FBSD_DYNAMIC_LINKER }
-
--/* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
-- the magical crtbegin.o file (see crtstuff.c) which provides part
-- of the support for getting C++ file-scope static object constructed
-- before entering `main'. */
--
--#undef STARTFILE_SPEC
--#define STARTFILE_SPEC \
-- "%{!shared: \
-- %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} \
-- %{!p:%{profile:gcrt1.o%s} \
-- %{!profile:crt1.o%s}}}} \
-- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
--
--/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
-- the magical crtend.o file (see crtstuff.c) which provides part of
-- the support for getting C++ file-scope static object constructed
-- before entering `main', followed by a normal "finalizer" file,
-- `crtn.o'. */
--
--#undef ENDFILE_SPEC
--#define ENDFILE_SPEC \
-- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
-+/* Use the STARTFILE_SPEC from config/freebsd-spec.h. */
-+
-+#undef STARTFILE_SPEC
-+#define STARTFILE_SPEC FBSD_STARTFILE_SPEC
-+
-+/* Use the ENDFILE_SPEC from config/freebsd-spec.h. */
-+
-+#undef ENDFILE_SPEC
-+#define ENDFILE_SPEC FBSD_ENDFILE_SPEC
-
- /* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
- for the special GCC options -static and -shared, which allow us to
---- gcc/testsuite/lib/target-supports.exp.orig 2015-03-26 00:35:54.000000000 +0100
-+++ gcc/testsuite/lib/target-supports.exp 2015-05-19 12:13:47.868191000 +0200
-@@ -952,6 +952,7 @@
-
- proc check_effective_target_pie { } {
- if { [istarget *-*-darwin\[912\]*]
-+ || [istarget *-*-freebsd*]
- || [istarget *-*-linux*]
- || [istarget *-*-gnu*] } {
- return 1;