aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-28 05:25:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-28 05:25:32 +0800
commit64b142f93738fd1d4242df1afca27affad33f192 (patch)
treeaa633376753365ae5e8fdfbad9f83326be4c893c
parent72016ca920017ef27cb1ed720c6d44bbb7972a22 (diff)
downloadfreebsd-ports-gnome-64b142f93738fd1d4242df1afca27affad33f192.tar.gz
freebsd-ports-gnome-64b142f93738fd1d4242df1afca27affad33f192.tar.zst
freebsd-ports-gnome-64b142f93738fd1d4242df1afca27affad33f192.zip
- Use USES=compiler:c++11-lib
- Mark broken for FreeBSD 8.x and 9.x without libc++
-rw-r--r--www/aria2/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
index 60002b5fedb2..7b46363d1af0 100644
--- a/www/aria2/Makefile
+++ b/www/aria2/Makefile
@@ -30,7 +30,7 @@ USE_CXXSTD= c++11
USE_GNOME= libxml2
USE_OPENSSL= yes
USE_XZ= yes
-USES= compiler:c++11-lang pathfix pkgconfig
+USES= compiler:c++11-lib pathfix pkgconfig
CA_BUNDLE_CONFIGURE_OFF=--without-ca-bundle
CA_BUNDLE_CONFIGURE_ON= --with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
@@ -46,6 +46,10 @@ ARIA2_DISK_CACHE?= 16M
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 1000500 && !exists(/usr/lib/libc++.so)
+BROKEN= Build with clang and libc++ only
+.endif
+
.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
BROKEN= Does not install on powerpc-9
.endif