aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-09-20 21:10:35 +0800
committerjohans <johans@FreeBSD.org>2015-09-20 21:10:35 +0800
commit6520eed312fb93d71685a8de5d28f9f7e2a37222 (patch)
treeab7c9a4c4f0c9b0163daefd813a12e4b276462b3
parent1acead60e2a82bdc96900a1bfbf3d23b2b9f0ae3 (diff)
downloadfreebsd-ports-gnome-6520eed312fb93d71685a8de5d28f9f7e2a37222.tar.gz
freebsd-ports-gnome-6520eed312fb93d71685a8de5d28f9f7e2a37222.tar.zst
freebsd-ports-gnome-6520eed312fb93d71685a8de5d28f9f7e2a37222.zip
- Fix pike shebangs
- Fix post-configure - move arch-independent bits out of ${ARCH} != i386; apparently this fixes build in 10.x+ i386 - Sort USES PR: 203128 Submitted by: amdmi3
-rw-r--r--www/caudium14/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/www/caudium14/Makefile b/www/caudium14/Makefile
index 33660bfbe1da..489547920285 100644
--- a/www/caudium14/Makefile
+++ b/www/caudium14/Makefile
@@ -4,7 +4,7 @@
PORTNAME= caudium14
PORTVERSION= ${DISTVERSION}.${PIKEVERSION}
DISTVERSION= 1.4.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://caudium.googlecode.com/files/
DISTNAME= Caudium-${DISTVERSION}
@@ -16,7 +16,7 @@ BUILD_DEPENDS= pike78:${PORTSDIR}/lang/pike78
LIB_DEPENDS= libsablot.so:${PORTSDIR}/textproc/sablotron
RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
-USES= tar:bzip2 gmake
+USES= gmake tar:bzip2
# Pike version included from lang/pike78
SUB_LIST+= PIKEVERSION=${PIKEVERSION}
@@ -33,6 +33,10 @@ DOCSDIR= ${PREFIX}/share/doc/caudium
OPTIONS_DEFINE= DOCS
post-patch:
+ @${REINPLACE_CMD} -i '' -e '1s:@PIKE@:${LOCALBASE}/bin/pike:' \
+ ${WRKSRC}/server/start-caudium.in
+ @${REINPLACE_CMD} -i '' -e '1s:bin/pike:${LOCALBASE}/bin/pike:' \
+ ${WRKSRC}/server/protocols/tetris.pike
@${SED} -e 's:@CAUDIUM_SERVERDIR@:${PREFIX}/caudium/server:' \
-e 's:^#############$$:${ECHO} "$${caudium_enable}" | ${EGREP} -iq "^yes|^true" || exit:' \
-e 's:/tmp/caudium_pid:/var/run/caudium.pid:' \
@@ -48,14 +52,15 @@ post-install:
.include <bsd.port.pre.mk>
post-configure:
-.if ${ARCH} != i386
-. for m in Mhash PCRE PiXSL UltraLog _Caudium
+.for m in Mhash PCRE PiXSL UltraLog _Caudium
@${REINPLACE_CMD} -e 's/^LD=.*/LD= ld -shared/' \
- -e '/^CFLAGS=/s/$$/ -fPIC/' \
-e 's/^LIBGCC=.*/LIBGCC=/' \
${WRKSRC}/src/cmods/$m/Makefile
-. endfor
-.endif
+. if ${ARCH} != i386
+ @${REINPLACE_CMD} -e '/^CFLAGS=/s/$$/ -fPIC/' \
+ ${WRKSRC}/src/cmods/$m/Makefile
+. endif
+.endfor
.include "../../lang/pike78/Makefile.common"
.include <bsd.port.post.mk>