aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-04-26 12:17:52 +0800
committermarcus <marcus@FreeBSD.org>2002-04-26 12:17:52 +0800
commit65a854a55c0e1866e9613a0627e8dbaff1ea1fd4 (patch)
tree98f3cab6083ba03207bbc064126be5ea22e954ff
parent6a03f9d079e12e17be6e93e74933dfd20fc38785 (diff)
downloadfreebsd-ports-gnome-65a854a55c0e1866e9613a0627e8dbaff1ea1fd4.tar.gz
freebsd-ports-gnome-65a854a55c0e1866e9613a0627e8dbaff1ea1fd4.tar.zst
freebsd-ports-gnome-65a854a55c0e1866e9613a0627e8dbaff1ea1fd4.zip
Add a conditional broken message so that people stop asking why Mozilla
fails to build when they have freetype 1.x installed. Reviewed by: sobomax Approved by: sobomax
-rw-r--r--www/mozilla-devel/Makefile9
-rw-r--r--www/mozilla-vendor/Makefile9
-rw-r--r--www/mozilla/Makefile9
-rw-r--r--www/seamonkey/Makefile9
-rw-r--r--www/seamonkey2/Makefile9
5 files changed, 40 insertions, 5 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mozilla-vendor/Makefile b/www/mozilla-vendor/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/mozilla-vendor/Makefile
+++ b/www/mozilla-vendor/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 45e0390e8e1a..b94279093545 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -69,10 +69,17 @@ PLIST_SUB+= CHATZILLA=""
PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
+
+.include <bsd.port.pre.mk>
+
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
+.if exists(${LOCALBASE}/include/freetype/freetype.h)
+BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
+.endif
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
@@ -93,4 +100,4 @@ do-install:
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>