aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-12 14:08:52 +0800
committerwen <wen@FreeBSD.org>2010-03-12 14:08:52 +0800
commit661f7b7f79af0de234db5fb64f55aab9beb90a3b (patch)
tree7bd04ac7959b4490b7b63af84eb6440246156c3e
parentcafa6b0d3505366798eb9d9a28ed0d7b6d3c7ca4 (diff)
downloadfreebsd-ports-gnome-661f7b7f79af0de234db5fb64f55aab9beb90a3b.tar.gz
freebsd-ports-gnome-661f7b7f79af0de234db5fb64f55aab9beb90a3b.tar.zst
freebsd-ports-gnome-661f7b7f79af0de234db5fb64f55aab9beb90a3b.zip
List::Util::WeightedRoundRobin is a utility for creating a weighted list
based on the input and associated weights. WWW: http://search.cpan.org/dist/List-Util-WeightedRoundRobin/
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-List-Util-WeightedRoundRobin/Makefile21
-rw-r--r--misc/p5-List-Util-WeightedRoundRobin/distinfo3
-rw-r--r--misc/p5-List-Util-WeightedRoundRobin/pkg-descr4
-rw-r--r--misc/p5-List-Util-WeightedRoundRobin/pkg-plist7
5 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index ff1d2856d52c..dc580b124358 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -407,6 +407,7 @@
SUBDIR += p5-I18N-LangTags
SUBDIR += p5-LEGO-RCX
SUBDIR += p5-List-Compare
+ SUBDIR += p5-List-Util-WeightedRoundRobin
SUBDIR += p5-Locale-Codes
SUBDIR += p5-Locale-Geocode
SUBDIR += p5-Locale-Msgcat
diff --git a/misc/p5-List-Util-WeightedRoundRobin/Makefile b/misc/p5-List-Util-WeightedRoundRobin/Makefile
new file mode 100644
index 000000000000..6601ca5ba9c6
--- /dev/null
+++ b/misc/p5-List-Util-WeightedRoundRobin/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-List-Util-WeightedRoundRobin
+# Date created: 12th march, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= List-Util-WeightedRoundRobin
+PORTVERSION= 0.4
+CATEGORIES= misc perl5 geography
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Creates a list based on weighted input
+
+PERL_CONFIGURE= yes
+
+MAN3= List::Util::WeightedRoundRobin.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-List-Util-WeightedRoundRobin/distinfo b/misc/p5-List-Util-WeightedRoundRobin/distinfo
new file mode 100644
index 000000000000..8b17f681374e
--- /dev/null
+++ b/misc/p5-List-Util-WeightedRoundRobin/distinfo
@@ -0,0 +1,3 @@
+MD5 (List-Util-WeightedRoundRobin-0.4.tar.gz) = 03013630a0c67a5fdd99f4e8a7905b75
+SHA256 (List-Util-WeightedRoundRobin-0.4.tar.gz) = 0bba950d7e4fd83e1f35810f3bc98da59d4d67977db4a4c5493911ad1f3e7256
+SIZE (List-Util-WeightedRoundRobin-0.4.tar.gz) = 2297
diff --git a/misc/p5-List-Util-WeightedRoundRobin/pkg-descr b/misc/p5-List-Util-WeightedRoundRobin/pkg-descr
new file mode 100644
index 000000000000..5de7a9b3e6aa
--- /dev/null
+++ b/misc/p5-List-Util-WeightedRoundRobin/pkg-descr
@@ -0,0 +1,4 @@
+List::Util::WeightedRoundRobin is a utility for creating a weighted list
+based on the input and associated weights.
+
+WWW: http://search.cpan.org/dist/List-Util-WeightedRoundRobin/
diff --git a/misc/p5-List-Util-WeightedRoundRobin/pkg-plist b/misc/p5-List-Util-WeightedRoundRobin/pkg-plist
new file mode 100644
index 000000000000..cfa4ac5a6a35
--- /dev/null
+++ b/misc/p5-List-Util-WeightedRoundRobin/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/List/Util/WeightedRoundRobin.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Util/WeightedRoundRobin/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Util/WeightedRoundRobin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List
+@dirrmtry %%SITE_PERL%%/List/Util
+@dirrmtry %%SITE_PERL%%/List