aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-12-09 10:19:59 +0800
committermezz <mezz@FreeBSD.org>2005-12-09 10:19:59 +0800
commit663388e1e0934484b269959c137289e2ed29181d (patch)
treec6439a75660ff3cdaab1a2a12d500d3f34ace9a9
parent73d50dc97577d261f0cd160be6f70428961b323c (diff)
downloadfreebsd-ports-gnome-663388e1e0934484b269959c137289e2ed29181d.tar.gz
freebsd-ports-gnome-663388e1e0934484b269959c137289e2ed29181d.tar.zst
freebsd-ports-gnome-663388e1e0934484b269959c137289e2ed29181d.zip
- Use an awsome new USE_GECKO.
- Firefox is no longer part of option, because it doesn't build with new Firefox 1.5. So... Current, it only has Mozilla. If it works with the other gecko-based such as Seamonkey, Thunderbird or so, then let me know and I shall add it in the list.
-rw-r--r--www/ruby-gtkmozembed/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/www/ruby-gtkmozembed/Makefile b/www/ruby-gtkmozembed/Makefile
index f3eb90a6ec7d..1d74c13ff940 100644
--- a/www/ruby-gtkmozembed/Makefile
+++ b/www/ruby-gtkmozembed/Makefile
@@ -18,21 +18,10 @@ DIST_SUBDIR= ruby
MAINTAINER= mezz@FreeBSD.org
COMMENT= Ruby binding for GtkMozEmbed a widget embedding a Mozilla Gecko renderer
-BUILD_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
- ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-
-.if !defined(WITH_MOZILLA)
-MOZILLA= firefox
-.else
-.if ${WITH_MOZILLA}=="mozilla"
-MOZILLA= mozilla
-.else
-MOZILLA= firefox
-.endif
-.endif
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
USE_RUBY= yes
+USE_GECKO= mozilla
USE_REINPLACE= yes
USE_RUBY_EXTCONF= yes
@@ -43,8 +32,11 @@ INSTALL_TARGET= site-install
DOCS= COPYING.LIB ChangeLog README
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+
post-patch:
- @${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|${MOZILLA}-gtkmozembed|g' \
+ @${REINPLACE_CMD} -e 's|mozilla-|${GECKO}-|g' \
${WRKSRC}/extconf.rb
post-install:
@@ -57,4 +49,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>