aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-23 03:23:24 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-23 03:23:24 +0800
commit671d6f72c6a6d483ee16a92163755c89811c2533 (patch)
tree5f4246431980992be223470b50bde8914084d17b
parent51a3a882520ab97c5b2d14b0fa8c440d7e73cc50 (diff)
downloadfreebsd-ports-gnome-671d6f72c6a6d483ee16a92163755c89811c2533.tar.gz
freebsd-ports-gnome-671d6f72c6a6d483ee16a92163755c89811c2533.tar.zst
freebsd-ports-gnome-671d6f72c6a6d483ee16a92163755c89811c2533.zip
misc/glow: Fix build on 13
Add the workaround for a bug in Glow that it uses the default C++ compiler when the supplied LLVM version is different. Reported by: fallout MFH: 2020Q3
-rw-r--r--misc/glow/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/misc/glow/Makefile b/misc/glow/Makefile
index 583822b86359..945baaa6bdee 100644
--- a/misc/glow/Makefile
+++ b/misc/glow/Makefile
@@ -41,6 +41,7 @@ CMAKE_ARGS= -DFREEBSD_LLVM_VERSION:STRING=${LLVM_VER} -DGIT_SHA1:STRING="\"${GH_
CMAKE_OFF= GLOW_BUILD_EXAMPLES GLOW_BUILD_TESTS
BINARY_ALIAS= python=${PYTHON_CMD}
+BINARY_ALIAS+= c++=${LOCALBASE}/bin/clang++${LLVM_VER:S/.//} # workaround for the llvm version mixup: https://github.com/pytorch/glow/issues/4910
LLVM_VER= ${LLVM_DEFAULT:C/(.)(.)/\1.\2/}