aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-09-05 15:22:47 +0800
committerdanfe <danfe@FreeBSD.org>2013-09-05 15:22:47 +0800
commit6741a733d57a46465e151cd9258765bb5885a9a3 (patch)
tree9c51c36b0a8af77b906a415b496afd72e6dba95a
parent6322d7a7acb70996e1b10532d64a46d181d07268 (diff)
downloadfreebsd-ports-gnome-6741a733d57a46465e151cd9258765bb5885a9a3.tar.gz
freebsd-ports-gnome-6741a733d57a46465e151cd9258765bb5885a9a3.tar.zst
freebsd-ports-gnome-6741a733d57a46465e151cd9258765bb5885a9a3.zip
- Fix the build against Clang
- Drop the check for old OSVERSION - Improve OPTIONS descriptions - Remove non-working WWW line - Add LICENSE (GPLv2) while here Reported by: pkg-fallout
-rw-r--r--games/quetoo/Makefile13
-rw-r--r--games/quetoo/files/patch-clang-fixes53
-rw-r--r--games/quetoo/pkg-descr2
3 files changed, 59 insertions, 9 deletions
diff --git a/games/quetoo/Makefile b/games/quetoo/Makefile
index 9cbc243001e8..2a4960d46a2b 100644
--- a/games/quetoo/Makefile
+++ b/games/quetoo/Makefile
@@ -11,6 +11,8 @@ MASTER_SITES= http://tastyspleen.net/~jdolan/ \
MAINTAINER= danfe@FreeBSD.org
COMMENT= Fast, stable, compatible, and secure Quake II client
+LICENSE= GPLv2
+
USE_BZIP2= yes
USE_SDL= sdl
USE_GL= glut
@@ -30,10 +32,10 @@ OPTIONS_DEFINE= GAME CTF VANCTF QMASS MYSQL DOCS
# they're available via `quake2-data' and `quake2-ctf' ports.
OPTIONS_DEFAULT= VANCTF QMASS
-GAME_DESC= Build main game shared object file
-CTF_DESC= Build Capture The Flag modification
-VANCTF_DESC= Build Vanilla CTF modification
-QMASS_DESC= Build QMass deathmatch modification
+GAME_DESC= Build main game (default mod)
+CTF_DESC= Build Capture The Flag mod
+VANCTF_DESC= Build Vanilla CTF mod
+QMASS_DESC= Build QMass deathmatch mod
MYSQL_DESC= Enable frag logging with MySQL
.include <bsd.port.options.mk>
@@ -85,9 +87,6 @@ post-patch: .SILENT
${REINPLACE_CMD} -E 's,^(eval PKGDATADIR=).*$$,\1"${Q2DIR}", ; \
19752s,sdl-config,${SDL_CONFIG}, ; \
s,^(GAME_MODULES=")baseq2",\1",' ${WRKSRC}/configure
-.if ${OSVERSION} < 800501
- ${REINPLACE_CMD} -e 's,const struct,struct,' ${WRKSRC}/src/files.c
-.endif
${REINPLACE_CMD} -e 's,-ldl,,' ${WRKSRC}/src/Makefile.in
do-install:
diff --git a/games/quetoo/files/patch-clang-fixes b/games/quetoo/files/patch-clang-fixes
new file mode 100644
index 000000000000..3053f1706187
--- /dev/null
+++ b/games/quetoo/files/patch-clang-fixes
@@ -0,0 +1,53 @@
+--- src/sv_user.c.orig 2007-12-28 07:25:47.000000000 +0800
++++ src/sv_user.c 2013-09-05 14:53:30.000000000 +0800
+@@ -363,7 +363,7 @@ void SV_Info_f(void){
+ continue; //only print serverinfo cvars
+
+ snprintf(line, MAX_STRING_CHARS, "%s %s\n", cvar->name, cvar->string);
+- SV_ClientPrintf(sv_client, PRINT_MEDIUM, line);
++ SV_ClientPrintf(sv_client, PRINT_MEDIUM, "%s", line);
+ }
+ }
+
+--- src/cl_main.c.orig 2007-12-28 07:25:47.000000000 +0800
++++ src/cl_main.c 2013-09-05 14:53:30.000000000 +0800
+@@ -691,7 +691,7 @@ void CL_Ping_f(void){
+ }
+
+ if(!adr.port) adr.port = BigShort(PORT_SERVER);
+- Netchan_OutOfBandPrint(NS_CLIENT, adr, va("info %i", PROTOCOL_34));
++ Netchan_OutOfBandPrint(NS_CLIENT, adr, "info %i", PROTOCOL_34);
+ return;
+ }
+
+@@ -700,7 +700,7 @@ void CL_Ping_f(void){
+
+ adr.type = NA_IP_BROADCAST;
+ adr.port = BigShort(PORT_SERVER);
+- Netchan_OutOfBandPrint(NS_CLIENT, adr, va("info %i", PROTOCOL_34));
++ Netchan_OutOfBandPrint(NS_CLIENT, adr, "info %i", PROTOCOL_34);
+ }
+
+
+--- src/cl_keys.c.orig 2007-12-28 07:25:47.000000000 +0800
++++ src/cl_keys.c 2013-09-05 14:53:30.000000000 +0800
+@@ -143,7 +143,7 @@ void CompleteCommand(void){
+ cvar = Cvar_CompleteVariable(partial, &cvars); //partial cvar lookup
+ if(cvar && !strcmp(cvar, partial)) goto append; //exact match
+
+- if(cmds == 1 && cvars == 0) cmd = cmd;
++ if(cmds == 1 && cvars == 0);
+ else if(cmds == 0 && cvars == 1) cmd = cvar;
+ else cmd = NULL;
+
+--- src/qmass/g_cmds.c.orig 2007-12-28 07:25:44.000000000 +0800
++++ src/qmass/g_cmds.c 2013-09-05 14:53:30.000000000 +0800
+@@ -724,7 +724,7 @@ void Cmd_Say_f(edict_t *ent, qboolean te
+
+ if(chatlog != NULL){ //write chatlog
+
+- fprintf(chatlog, text);
++ fprintf(chatlog, "%s", text);
+
+ fflush(chatlog);
+ }
diff --git a/games/quetoo/pkg-descr b/games/quetoo/pkg-descr
index 55577fb889a6..d12e6ede1008 100644
--- a/games/quetoo/pkg-descr
+++ b/games/quetoo/pkg-descr
@@ -20,5 +20,3 @@ following features will sound good to you:
* Vastly improved console with Bash-style tab completion, positioned
editing, mouse wheel scrolling, etc.
* Optional deathmatch mod with MySQL frag logging and team play
-
-WWW: http://jdolan.dyndns.org/trac/wiki/Quetoo