diff options
author | koobs <koobs@FreeBSD.org> | 2013-12-04 22:08:03 +0800 |
---|---|---|
committer | koobs <koobs@FreeBSD.org> | 2013-12-04 22:08:03 +0800 |
commit | 67b00be1eb575b14f7e183b438164e2a077bec1a (patch) | |
tree | 754b3663485f9b13ff4b8f3685115ac80f066624 | |
parent | bfa77c61f4e4cf73ab2024e70078cd760599c09b (diff) | |
download | freebsd-ports-gnome-67b00be1eb575b14f7e183b438164e2a077bec1a.tar.gz freebsd-ports-gnome-67b00be1eb575b14f7e183b438164e2a077bec1a.tar.zst freebsd-ports-gnome-67b00be1eb575b14f7e183b438164e2a077bec1a.zip |
devel/zmq: Move to net/libzmq2 & update to align with other ZeroMQ ports
All other core ZeroMQ library ports have been moved to the net/ category
along with the czmq client library. This change completes the set,
enabling greater flexibility and choice for maintainers of ZeroMQ-based
software in the ports tree.
- Move devel/zmq to net/libzmq2
- Update devel/ and net/ category Makefiles
- Add MOVED entry
- Update LIB_DEPENDS in dependent ports
net/libzmq2:
- Switch primary category to net
- Enable STAGE support
- Add DEBUG option
- Update COMMENT to match libzmq[34]
- Update pkg-descr to match libzmq[34]
- Update CONFLICTS
- Add LICENSE
- Sort USE_* section
- Remove MAN macros and move entries to pkg-plist
- Add regression-test target for QA
Reviewed by: makc
Approved by: Gea-Suan Lin <gslin@gslin.org> (maintainer, via email)
-rw-r--r-- | MOVED | 1 | ||||
-rw-r--r-- | devel/Makefile | 1 | ||||
-rw-r--r-- | devel/cocaine-core/Makefile | 4 | ||||
-rw-r--r-- | devel/jzmq/Makefile | 3 | ||||
-rw-r--r-- | devel/zmq/Makefile | 54 | ||||
-rw-r--r-- | devel/zmq/pkg-descr | 3 | ||||
-rw-r--r-- | devel/zmq/pkg-plist | 9 | ||||
-rw-r--r-- | net/Makefile | 1 | ||||
-rw-r--r-- | net/libzmq2/Makefile | 37 | ||||
-rw-r--r-- | net/libzmq2/distinfo (renamed from devel/zmq/distinfo) | 0 | ||||
-rw-r--r-- | net/libzmq2/pkg-descr | 8 | ||||
-rw-r--r-- | net/libzmq2/pkg-plist | 38 | ||||
-rw-r--r-- | net/p5-ZeroMQ/Makefile | 4 | ||||
-rw-r--r-- | textproc/groonga/Makefile | 3 | ||||
-rw-r--r-- | textproc/rubygem-zmq/Makefile | 3 | ||||
-rw-r--r-- | www/blastbeat/Makefile | 4 | ||||
-rw-r--r-- | www/mongrel2/Makefile | 3 |
17 files changed, 99 insertions, 77 deletions
@@ -5288,3 +5288,4 @@ editors/gphpedit||2013-12-01|Has expired: No longer maintaned upstream irc/inspircd12|irc/inspircd|2013-12-01|Has expired: No upstream support; known vulnerable. Please use irc/inspircd graphics/py-clutter||2013-12-01|Has expired: Broken for more than 6 month graphics/py-clutter-gtk||2013-12-01|Has expired: depends on expired graphics/py-clutter +devel/zmq|net/zmq|2013-12-05|Rename according to upstream and move to more suitable category diff --git a/devel/Makefile b/devel/Makefile index 45162cee52f8..636a680a37d1 100644 --- a/devel/Makefile +++ b/devel/Makefile @@ -4540,7 +4540,6 @@ SUBDIR += z80-asm SUBDIR += z80asm SUBDIR += z80ex - SUBDIR += zmq SUBDIR += zookeeper SUBDIR += zpu-binutils SUBDIR += zpu-gcc diff --git a/devel/cocaine-core/Makefile b/devel/cocaine-core/Makefile index 62765621af3f..a19746d35678 100644 --- a/devel/cocaine-core/Makefile +++ b/devel/cocaine-core/Makefile @@ -3,7 +3,7 @@ PORTNAME= cocaine-core PORTVERSION= 0.10 -PORTREVISION= 2 +PORTREVISION= 3 CATEGORIES= devel MASTER_SITES= GH GHC @@ -17,7 +17,7 @@ LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \ ltdl:${PORTSDIR}/devel/libltdl \ msgpack:${PORTSDIR}/devel/msgpack \ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \ - zmq:${PORTSDIR}/devel/zmq + zmq:${PORTSDIR}/net/libzmq2 USES= cmake USE_GCC= yes diff --git a/devel/jzmq/Makefile b/devel/jzmq/Makefile index 4744186c3521..1ab73e352010 100644 --- a/devel/jzmq/Makefile +++ b/devel/jzmq/Makefile @@ -2,6 +2,7 @@ PORTNAME= jzmq PORTVERSION= 2011.04.26 +PORTREVISION= 1 CATEGORIES= devel java MASTER_SITES= LOCAL/olgeni DISTNAME= zeromq-${PORTNAME}-${PORTVERSION} @@ -9,7 +10,7 @@ DISTNAME= zeromq-${PORTNAME}-${PORTVERSION} MAINTAINER= olgeni@FreeBSD.org COMMENT= Java bindings for ZeroMQ -LIB_DEPENDS= zmq.1:${PORTSDIR}/devel/zmq +LIB_DEPENDS= zmq.1:${PORTSDIR}/net/libzmq2 USES= pkgconfig USE_AUTOTOOLS= autoconf:env libtool automake:env diff --git a/devel/zmq/Makefile b/devel/zmq/Makefile deleted file mode 100644 index 2128baed41b6..000000000000 --- a/devel/zmq/Makefile +++ /dev/null @@ -1,54 +0,0 @@ -# Created by: Gea-Suan Lin <gslin@gslin.org> -# $FreeBSD$ - -PORTNAME= zmq -PORTVERSION= 2.2.0 -CATEGORIES= devel net -MASTER_SITES= http://download.zeromq.org/ -DISTNAME= zeromq-${DISTVERSION} - -MAINTAINER= gslin@gslin.org -COMMENT= Open source message queue optimised for performance - -GNU_CONFIGURE= yes -USES= pathfix -USE_LDCONFIG= yes - -CONFLICTS= zmq-devel-[0-9]* - -MAN3= zmq_bind.3 \ - zmq_close.3 \ - zmq_connect.3 \ - zmq_device.3 \ - zmq_errno.3 \ - zmq_getsockopt.3 \ - zmq_init.3 \ - zmq_msg_close.3 \ - zmq_msg_copy.3 \ - zmq_msg_data.3 \ - zmq_msg_init.3 \ - zmq_msg_init_data.3 \ - zmq_msg_init_size.3 \ - zmq_msg_move.3 \ - zmq_msg_size.3 \ - zmq_poll.3 \ - zmq_recv.3 \ - zmq_send.3 \ - zmq_setsockopt.3 \ - zmq_socket.3 \ - zmq_strerror.3 \ - zmq_term.3 \ - zmq_version.3 -MAN7= zmq.7 \ - zmq_cpp.7 \ - zmq_epgm.7 \ - zmq_inproc.7 \ - zmq_ipc.7 \ - zmq_pgm.7 \ - zmq_tcp.7 - -NO_STAGE= yes -post-patch: - ${REINPLACE_CMD} -e '9s|$$| -pthread|' ${WRKSRC}/src/libzmq.pc.in - -.include <bsd.port.mk> diff --git a/devel/zmq/pkg-descr b/devel/zmq/pkg-descr deleted file mode 100644 index f0ae7b25a473..000000000000 --- a/devel/zmq/pkg-descr +++ /dev/null @@ -1,3 +0,0 @@ -An open source message queue optimised for performance. - -WWW: http://www.zeromq.org/ diff --git a/devel/zmq/pkg-plist b/devel/zmq/pkg-plist deleted file mode 100644 index 4e408277245e..000000000000 --- a/devel/zmq/pkg-plist +++ /dev/null @@ -1,9 +0,0 @@ -@comment $FreeBSD$ -lib/libzmq.so.1 -lib/libzmq.la -lib/libzmq.a -lib/libzmq.so -libdata/pkgconfig/libzmq.pc -include/zmq.hpp -include/zmq_utils.h -include/zmq.h diff --git a/net/Makefile b/net/Makefile index 636b08f1d828..1c4d05eba2c1 100644 --- a/net/Makefile +++ b/net/Makefile @@ -349,6 +349,7 @@ SUBDIR += libunp SUBDIR += libutp SUBDIR += libvncserver + SUBDIR += libzmq2 SUBDIR += libzmq3 SUBDIR += libzmq4 SUBDIR += liferea diff --git a/net/libzmq2/Makefile b/net/libzmq2/Makefile new file mode 100644 index 000000000000..9a9061b866d0 --- /dev/null +++ b/net/libzmq2/Makefile @@ -0,0 +1,37 @@ +# Created by: Gea-Suan Lin <gslin@gslin.org> +# $FreeBSD$ + +PORTNAME= zmq +PORTVERSION= 2.2.0 +PORTREVISION= 1 +CATEGORIES= net +MASTER_SITES= http://download.zeromq.org/ +DISTNAME= zeromq-${DISTVERSION} + +MAINTAINER= gslin@gslin.org +COMMENT= ZeroMQ core library (Version 2) + +LICENSE= LGPL3 + +USES= pathfix +USE_LDCONFIG= yes +GNU_CONFIGURE= yes + +CONFLICTS= libzmq[^2]-[0-9]* + +OPTIONS_DEFINE= DEBUG +DEBUG_CONFIGURE_ON= --enable-debug + +.include <bsd.port.options.mk> + +.if ${PORT_OPTIONS:MDEBUG} +WITH_DEBUG= yes +.endif + +post-patch: + ${REINPLACE_CMD} -e '9s|$$| -pthread|' ${WRKSRC}/src/libzmq.pc.in + +regression-test: build + cd ${WRKSRC} && ${MAKE} check + +.include <bsd.port.mk> diff --git a/devel/zmq/distinfo b/net/libzmq2/distinfo index 3d5ffe171146..3d5ffe171146 100644 --- a/devel/zmq/distinfo +++ b/net/libzmq2/distinfo diff --git a/net/libzmq2/pkg-descr b/net/libzmq2/pkg-descr new file mode 100644 index 000000000000..ce51410fdf40 --- /dev/null +++ b/net/libzmq2/pkg-descr @@ -0,0 +1,8 @@ +ZeroMQ - Distributed Computing Made Simple + + * The socket library that acts as a concurrency framework. + * Carries messages across inproc, IPC, TCP, and multicast. + * Connect N-to-N via fanout, pubsub, pipeline, request-reply. + * Asynch I/O for scalable multicore message-passing apps. + +WWW: http://www.zeromq.org/ diff --git a/net/libzmq2/pkg-plist b/net/libzmq2/pkg-plist new file mode 100644 index 000000000000..dfc9746e6755 --- /dev/null +++ b/net/libzmq2/pkg-plist @@ -0,0 +1,38 @@ +lib/libzmq.so.1 +lib/libzmq.la +lib/libzmq.a +lib/libzmq.so +libdata/pkgconfig/libzmq.pc +include/zmq.hpp +include/zmq_utils.h +include/zmq.h +man/man3/zmq_bind.3.gz +man/man3/zmq_close.3.gz +man/man3/zmq_connect.3.gz +man/man3/zmq_device.3.gz +man/man3/zmq_errno.3.gz +man/man3/zmq_getsockopt.3.gz +man/man3/zmq_init.3.gz +man/man3/zmq_msg_close.3.gz +man/man3/zmq_msg_copy.3.gz +man/man3/zmq_msg_data.3.gz +man/man3/zmq_msg_init.3.gz +man/man3/zmq_msg_init_data.3.gz +man/man3/zmq_msg_init_size.3.gz +man/man3/zmq_msg_move.3.gz +man/man3/zmq_msg_size.3.gz +man/man3/zmq_poll.3.gz +man/man3/zmq_recv.3.gz +man/man3/zmq_send.3.gz +man/man3/zmq_setsockopt.3.gz +man/man3/zmq_socket.3.gz +man/man3/zmq_strerror.3.gz +man/man3/zmq_term.3.gz +man/man3/zmq_version.3.gz +man/man7/zmq.7.gz +man/man7/zmq_cpp.7.gz +man/man7/zmq_epgm.7.gz +man/man7/zmq_inproc.7.gz +man/man7/zmq_ipc.7.gz +man/man7/zmq_pgm.7.gz +man/man7/zmq_tcp.7.gz diff --git a/net/p5-ZeroMQ/Makefile b/net/p5-ZeroMQ/Makefile index 187c7c4a3f74..ceed2a9a631b 100644 --- a/net/p5-ZeroMQ/Makefile +++ b/net/p5-ZeroMQ/Makefile @@ -2,7 +2,7 @@ PORTNAME= ZeroMQ PORTVERSION= 0.21 -PORTREVISION= 1 +PORTREVISION= 2 CATEGORIES= net perl5 MASTER_SITES= CPAN MASTER_SITE_SUBDIR= CPAN:DMAKI @@ -16,7 +16,7 @@ LICENSE_COMB= dual RUN_DEPENDS= p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken BUILD_DEPENDS= p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken -LIB_DEPENDS= zmq.1:${PORTSDIR}/devel/zmq \ +LIB_DEPENDS= zmq.1:${PORTSDIR}/net/libzmq2 \ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \ diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile index 685bdeb92f5f..f9e9b679ed34 100644 --- a/textproc/groonga/Makefile +++ b/textproc/groonga/Makefile @@ -2,6 +2,7 @@ PORTNAME= groonga PORTVERSION= 3.0.0 +PORTREVISION= 1 CATEGORIES= textproc MASTER_SITES= http://packages.groonga.org/source/groonga/ @@ -56,7 +57,7 @@ CONFIGURE_ARGS+= --with-libevent=${LOCALBASE} \ --enable-zeromq LIB_DEPENDS+= event-1.4:${PORTSDIR}/devel/libevent \ msgpack:${PORTSDIR}/devel/msgpack \ - zmq:${PORTSDIR}/devel/zmq + zmq:${PORTSDIR}/net/libzmq2 PLIST_SUB+= SUGGEST="" .else CONFIGURE_ARGS+= --without-libevent \ diff --git a/textproc/rubygem-zmq/Makefile b/textproc/rubygem-zmq/Makefile index 8fa0695cba47..a1661f973944 100644 --- a/textproc/rubygem-zmq/Makefile +++ b/textproc/rubygem-zmq/Makefile @@ -2,13 +2,14 @@ PORTNAME= zmq PORTVERSION= 2.1.4 +PORTREVISION= 1 CATEGORIES= textproc rubygems MASTER_SITES= RG MAINTAINER= ruby@FreeBSD.org COMMENT= Ruby ZeroMQ gem -LIB_DEPENDS= zmq:${PORTSDIR}/devel/zmq +LIB_DEPENDS= zmq:${PORTSDIR}/net/libzmq2 USE_RUBY= yes USE_RUBYGEMS= yes diff --git a/www/blastbeat/Makefile b/www/blastbeat/Makefile index 76a7d0461d55..e0a0f8996b5d 100644 --- a/www/blastbeat/Makefile +++ b/www/blastbeat/Makefile @@ -3,7 +3,7 @@ PORTNAME= blastbeat PORTVERSION= 20121205 -PORTREVISION= 1 +PORTREVISION= 2 CATEGORIES= www MASTER_SITES= GH GHC @@ -17,7 +17,7 @@ LICENSE_PERMS= auto-accept LIB_DEPENDS= ev:${PORTSDIR}/devel/libev \ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \ - zmq:${PORTSDIR}/devel/zmq + zmq:${PORTSDIR}/net/libzmq2 USE_GMAKE= yes USE_GITHUB= yes diff --git a/www/mongrel2/Makefile b/www/mongrel2/Makefile index eff977e56512..b6386ae22bf2 100644 --- a/www/mongrel2/Makefile +++ b/www/mongrel2/Makefile @@ -3,13 +3,14 @@ PORTNAME= mongrel2 PORTVERSION= 1.7.5 +PORTREVISION= 1 CATEGORIES= www MASTER_SITES= http://mongrel2.org/static/downloads/ MAINTAINER= vg@FreeBSD.org COMMENT= Is an application, language, and network arch -LIB_DEPENDS= zmq.1:${PORTSDIR}/devel/zmq \ +LIB_DEPENDS= zmq.1:${PORTSDIR}/net/libzmq2 \ sqlite3.8:${PORTSDIR}/databases/sqlite3 USE_GMAKE= yes |