aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-07 22:30:31 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-07 22:30:31 +0800
commit67c4c1692dbfd64fadce6fd84d4a9d3a92171b46 (patch)
treea3994c3d0c314a5bd8b51a102ee8114d7a24b6ea
parent56c67f6effc52af0ef99c1e4fb7af00ff4b3dd59 (diff)
downloadfreebsd-ports-gnome-67c4c1692dbfd64fadce6fd84d4a9d3a92171b46.tar.gz
freebsd-ports-gnome-67c4c1692dbfd64fadce6fd84d4a9d3a92171b46.tar.zst
freebsd-ports-gnome-67c4c1692dbfd64fadce6fd84d4a9d3a92171b46.zip
Use shebangfix macro
-rw-r--r--sysutils/hploscripts/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/sysutils/hploscripts/Makefile b/sysutils/hploscripts/Makefile
index f55713534f11..0ff738b6483e 100644
--- a/sysutils/hploscripts/Makefile
+++ b/sysutils/hploscripts/Makefile
@@ -13,18 +13,18 @@ COMMENT= HP Lights-Out management perl scripts
BUILD_DEPENDS= p5-IO-Socket-SSL>=1.19:${PORTSDIR}/security/p5-IO-Socket-SSL
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= locfg.pl
+
PORTDOCS= iLO_perl_xml.pdf linux-LOsamplescripts.txt
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-post-patch:
- @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/locfg.pl
-
do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.xml ${EXAMPLESDIR}
@@ -33,7 +33,8 @@ do-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/iLO_perl_xml.pdf ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/linux-LOsamplescripts3.00.0-2.txt ${DOCSDIR}/linux-LOsamplescripts.txt
+ ${INSTALL_DATA} ${WRKSRC}/linux-LOsamplescripts3.00.0-2.txt \
+ ${DOCSDIR}/linux-LOsamplescripts.txt
.endif
regression-test: build