aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-02 17:51:10 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-02 17:51:10 +0800
commit682326aae8019bf358942eca3757cd78db5dccca (patch)
tree5f964f59a9e5e9ccc347825ff47bc19330b2223c
parent47629e47629f2ce14406e5fd57f0aa15714c5c24 (diff)
downloadfreebsd-ports-gnome-682326aae8019bf358942eca3757cd78db5dccca.tar.gz
freebsd-ports-gnome-682326aae8019bf358942eca3757cd78db5dccca.tar.zst
freebsd-ports-gnome-682326aae8019bf358942eca3757cd78db5dccca.zip
Mark as broken with gcc4.2.
-rw-r--r--games/pykawari/Makefile4
-rw-r--r--games/sopwith/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
index 3851d2adf187..e21265678f20 100644
--- a/games/pykawari/Makefile
+++ b/games/pykawari/Makefile
@@ -35,6 +35,10 @@ CFLAGS+= ${PTHREAD_CFLAGS} -fPIC
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
.endif
diff --git a/games/sopwith/Makefile b/games/sopwith/Makefile
index 53ac20e24421..4d28b07f8171 100644
--- a/games/sopwith/Makefile
+++ b/games/sopwith/Makefile
@@ -23,4 +23,10 @@ GNU_CONFIGURE= yes
MAN6= sopwith.6
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>