aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2013-12-14 21:28:35 +0800
committertota <tota@FreeBSD.org>2013-12-14 21:28:35 +0800
commit685bc2e870213e7e7b9e58f15cdc47eee1661c74 (patch)
tree55c22a1d6669638b0feb4fcf83f03d3ff679ed10
parent012ee9604b90bf4de77e0f8e179a7e0830f90a70 (diff)
downloadfreebsd-ports-gnome-685bc2e870213e7e7b9e58f15cdc47eee1661c74.tar.gz
freebsd-ports-gnome-685bc2e870213e7e7b9e58f15cdc47eee1661c74.tar.zst
freebsd-ports-gnome-685bc2e870213e7e7b9e58f15cdc47eee1661c74.zip
- Add LEGAL_TEXT to sync with the 'why' column in LEGAL [1]
- Add LICENSE section - Support STAGEDIR Submitted by: eadler (via private e-mail) [1]
-rw-r--r--devel/astah-community/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 17cf33e64e94..5c04a99a2f4a 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -11,7 +11,13 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}-${REVISION}
MAINTAINER= tota@FreeBSD.org
COMMENT= Java/UML Object-Oriented Design Tool
+LICENSE= EULA
+LICENSE_NAME= End User License Agreement
+LICENSE_TEXT= ${RESTRICTED}
+LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell no-auto-accept
+
RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
+LEGAL_TEXT= License restrictions
USE_ZIP= yes
USE_JAVA= yes
@@ -42,7 +48,6 @@ REINPLACE_ARGS= -i ""
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -64,22 +69,22 @@ post-patch:
do-install:
.for script in ${PLIST_FILES:S!bin/!!}
- ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docfile in ${PORTDOCS:Napi}
- ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
.endfor
- ${MKDIR} ${DOCSDIR}/api
- (cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/api
+ (cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}/api)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for examplefile in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${examplefile} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.endif